locked
Can't find MSVCP71.dll Battlefield 2142 server software wont run. RRS feed

  • Question

  • I have been trying to get the Battlefield 2142 server software to run on my server for a few days now. I have had it working before, but I do not remember what operating system, or what install it was on. However, whenever I run the program it tells me that it can't locate component MSVCP71.dll. I have tried reinstalling, installing .NET Framework 1.1 through 3.5. I have tried installing microsoft visual studio 6. I have also obtained copies of the DLL and put them in the Windows/System, Windows/System32, and in the folder the program itself is in. None of these have fixed the problem. I have also tried regsvr32 on the dll to register it, and it always tells me it can't locate the file.

    Any ideas?

    Thursday, February 24, 2011 9:49 PM

All replies

  • Bump.
    Monday, February 28, 2011 5:57 AM
  • mscp71.dll is a c runtime and required to allow the game to run.

    try looking for a compressed version in your install cd. and expand it to the system\dllcache folder.

    Try regsvr32 msvcp71.dll from an adminstrator cmd.exe

    Source

    http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/msvcp71dll/bf7a2488-21d8-47af-9e3b-800d3683bc89

     

    Keith

    Friday, March 11, 2011 5:59 AM
  • I can't find the dll on the disk anywhere. I copied the version I have on my computer to my server. I put it in system32/dllcache, there is no dllcache in the system folder. I also tried regsvr32 again and nothing happened.
    Monday, March 14, 2011 4:43 PM
  • The run time for visual C++ 2003 will contain your missing dll. On your installation disk should be a dot net under the install additional. its been awhile since I have used it. The dot net 1.1 should be an option on your installation disks after placing in dvd drive.

    While you have time, please consider using a cd/dvd cleaner disk in yur computers drive just for reliability proposes. And if yu still have a 3.5 floppy drive its also a good time to clean it with the appropriate kit.

    As an alternative my suggestion instead is download dot net 1.1 from here and install it.

    http://www.microsoft.com/downloads/en/details.aspx?FamilyId=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en

    And see if this replaces the missing .dll it is a part of dot net 1.1 also update to 1.1 sp1. After rebooting you should be able to access your application. If this helps. Please mark this as answered and repost back your results if successful or not.

     

    Keith

    Wednesday, March 16, 2011 1:29 AM
  • I've done that before, and I just did it again, same problem.

    What I was thinking is perhaps because my primary drive is labeled H: and not C: the program was looking in the C: drive and not finding it instead of looking in the drive it is installed on. However, since regsvr32 cannot locate it either, it makes me think something else is wrong.

    Thanks, sharf.

    Monday, March 21, 2011 12:08 AM
  • Then the www.sysinternals.com site has Microsoft owned tools. They were bought by Microsoft and the process monitor to figure out what is calling the missing file. The blog covers using the tol and there is a forum there to ask if it doesnt work right for you. If it doesn't please let me know and I will follow up. Keith
    Monday, March 21, 2011 10:28 PM
  • This link mentions using google to download the file and place it in the proper directory.

    And then register the .dll

    Hopefully this works for you

     

    http://social.microsoft.com/Forums/en-US/kernel/thread/a0967d47-a066-46be-a952-a19e345c3fc0

     

    Keith

    Thursday, June 2, 2011 9:09 PM