locked
AppV 5.1 100% downloaded suddenly containing sparse files which cannot be accessed RRS feed

  • Question

  • Hi,

    I have some trouble with a packaged application which is optimized for streaming and already 100% downloaded. And still marked as 100% downloaded. After a working for a few days it freezes while starting when trying to load some files. Looking in windows explorer the files are marked with the grey X which means they are sparse files (as far as I understand). Trying to access this files by any means fails and the eventlog shows the following event (some parts translated from german):

    Protokollname: Microsoft-AppV-Client/Admin
    Source:        Microsoft-AppV-Client
    Event-ID:   14021
    Aufgabenkategorie:Streaming
    Ebene:         Error
    Schlüsselwörter:Streaming
    User:      XXX
    Computer:      XXX
    Description:
    Content required by an application could not be retrieved from the network. A request for file C:\ProgramData\App-V\A67EFCB9-2C3A-4D94-AB1F-97F9E5CD711D\703DD08A-4C81-4076-96C0-4F9226BAEC49\Root\VFS\ProgramFilesX64\Vectorworks2015\RWeiterungen\Wörterbücher\German.clx from package version {703dd08a-4c81-4076-96c0-4f9226baec49} failed with error Falscher Parameter..  Check your network connection and try again.

    So I doublechecked the permissions on the smb share where the .appv file is loaded from and everything seems to be fine. I even tried giving read permissions to "everyone" but the error remains.

    So my two questions are: why are the files suddenly becoming sparse files and what can I do to fix it? And why ist their content inaccessible (and what can I do to fix it)?

    Flushing the app-v client cache helps, but after a few days the error starts appearing again. At the moment I'm trying forcing the clients to load the whole application without any optimization for streaming, but I'd prefer annother solution.

    I'd appreciate any hints.

    Regards
    Michael

    Wednesday, November 25, 2015 2:52 PM

Answers

All replies

  • Can you try using Hot Fix 1 for App-V 5.1 which is released now.

    https://support.microsoft.com/en-us/kb/3115834


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    • Marked as answer by Urist_McMimos Friday, December 4, 2015 2:15 PM
    Wednesday, November 25, 2015 6:03 PM
  • Thanks for the link, I just installed it.

    Sadly it doesn't help for already damaged packages, but maybe it prevents them from breaking again. I'll report back in a few days.

    Annother thing I noticed: at least some of the files where parts get missing are files that are loaded first in the small part optimized for streaming.
    Friday, November 27, 2015 2:16 PM
  • It could be possible that your (3th party) virusscanner is corrupting things. Exclude the PackageInstallationRoot, and check if the problem is solved.
    • Edited by Roy Essers Friday, November 27, 2015 4:59 PM
    Friday, November 27, 2015 4:33 PM
  • Thanks, but antivirus was my first idea, too. So I already checked.

    It is running fine for one Week now, It looks like Hotfix 1 solved the Problem. If it should break again I'll unmark it as an answer.

    Thanks for your help

    Friday, December 4, 2015 2:17 PM