locked
Disabling APIPA RRS feed

  • Question

  • Hello,

    I'm having a Windows Server 2012 trying to connect with a remote device via Modem. The remote device gives the server the IP to stablish the session. The problem is that the IP given is 169.254.x.x (a range reserved for APIPA automatic IP assignment).

    Therefore, to try to avoid IP conflicts (the session cannot be stablished with these IPs), I am trying to disable APIPA service on the Windows Server 2012 (totally or at least in the modem adapter). The question is that I am not able to do this. I found on internet several ways to do that, but none of them works for me. They are the following:

    1) Modifying the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    create D-Word IPAutoconfigurationEnabled should be 0 for disabled 1 for enabled.

    (neither it works if I create this in all the adapters that belongs to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces)

    2) Vía netsh: 

     netsh interface ipv4 set interface 11 dadtransmits=0 store=persistent 

     (described in http://the-it-wonders.blogspot.com.es/2013/04/autoconfiguration-ipv4-address-196254xx.html)

    Anyone can help me with any other trying?


    Friday, February 19, 2016 1:37 PM

Answers

  • Hi Daniel,

               1.>> Anyone can help me with any other trying?

                    I just found the solution that you posted  above on the internet.If they don’t help,please try to update adapter’s driver,or reinstall network adapter and try again.

                    With APIPA, a Windows computer can assign itself an Internet Protocol (IP) address in the event that a DHCP server is not available or does not exist on the network.

                    There is a workaround,give them static IP adresses.

               2. >>I'm having a Windows Server 2012 trying to connect with a remote device via Modem.

                    According your description ,the remote device need a public IP address,typically,it is a static IP address ,provides by the ISP.So it is not necessary to disable APIPA.

                

      Best Regards,

    Cartman


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, February 22, 2016 6:54 AM