locked
Cut, Copy, and paste advanced options ignored RRS feed

  • Question

  • I'm trying to configure Word 2010 so that pasted text keeps only the text, not any formatting. To that end I've navigated to File\Options\Advanced and the Cut, copy, and paste section and changed the the following options:

    Pasting within the same document: Keep Text Only

    Pasting between documents: Keep Text Only

    Pasting between documents when style definitions conflict: Keep Text Only

    Pasting from other programs: Keep Text Only

    As far as I can tell from these options this should ensure that no matter where I'm copying from, I should only, ever get the source text and never any formatting pasted into Word. This, however, is not the case. When I past from my browser, for example, I get different fonts, font sizes, font weight (bold) and even hyperlinks coming in. For the life of me I cannot figure out why this setting is not working. When I exit Word and open it again the settings are still there so everything I can see indicates that they are stored properly however Word seems to ignore these settings.

    On a related note, I've set the same options for my Outlook email editor (in File\Options\Mail\Editor Options...\Advanced\Cut, copy, and paste) and I experience the same problem as I do in Word with source formatting showing up in my emails even though I've set it to keep only the text.

    I'm running the 32 bit version of Office 2010 version 14.0.6023.1000 on 64 bit Windows 7 Professional SP1. Can anyone suggest a solution?

    Wednesday, September 7, 2011 9:13 PM

Answers

  • "Sihgneg" wrote in message news:8fe24bc5-8bb9-4742-a917-47074d7ff2e8@communitybridge.codeplex.com...
     
    Tried renaming Normal.dotm and then starting Word. It created the new Normal.dotm but the problem remained.
     
    This same issue exists for me in Outlook when composing emails. I have File | Options | Mail | Editor Options | Advanced | Cut, copy and paste settings set to Keep Text Only but the behaviour is the same as in Word. Source formatting is kept with my default paste and my only way to get the unformatted text is to use the Paste Special option and then select Unformatted Text.
     
     
    If you paste as Unformatted Text a lot, you could make use of the following macro:
     
    Sub PastePlainText()
    On Error Resume Next
    Selection.PasteSpecial DataType:=wdPasteText
    End Sub
     
    Store the macro in the Normal template. Add a keyboard shortcut and/or a button to the QAT.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Hutchma Friday, October 28, 2011 6:19 PM
    Friday, October 28, 2011 5:31 PM
  • In addition to a Word macro that pastes unformatted text, I use Pure Text.  I really needed to use it just last week when I was pasting from PowerPoint to Word.  My macro wouldn't work on the PowerPoint table but Pure Text did.  It's Windows-based freeware.

    OBTW:  I tried working with the keep text only settings in W2007. But decided that I really need the regular paste too often, and went back to using  my paste unformatted text macro.  So I hadn't tried it with W2010 until I read your post  last night.  My result is the same as yours.  Word totally ignores the setting.

    Pam

    • Marked as answer by Hutchma Friday, October 28, 2011 11:47 PM
    Friday, October 28, 2011 11:04 PM

All replies

  • It seems to work when I test it on my system. Are you sure that there is no direct formatting applied to the location where you paste?
     
    "Keep Text Only" does imply that the pasted text will adjust to the settings at the insertion point.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Max Meng Tuesday, September 13, 2011 8:34 AM
    • Unmarked as answer by Hutchma Wednesday, October 26, 2011 9:07 PM
    • Edited by Stefan BlomMVP Wednesday, October 26, 2011 9:19 PM
    Thursday, September 8, 2011 10:41 PM
  • Yes, I am certain there is no other formatting messing with this. I can open a brand new Word document, confirm these settings and see that my font is the default "Calibri (Body)." I paste into the docment from my web browser and even though everything is set to only keep text the font size, type and colour will change depending on the source I copy from. Even hyperlinks are copied into the document.
    Wednesday, October 26, 2011 9:09 PM
  • I have done some further testing and I simply can’t reproduce this. “Keep Text Only” behaves on my system. If you use the Home | Paste | Paste Special option, and choose to paste as “Unformatted Text,” does that work properly?
     
    Are you running any add-ins on your system (add-ins that possibly affect paste behavior)?
     
    As far as hyperlinks are concerned, this is probably the result of the automatic conversion. Clear the “Internet and network paths with hyperlinks” option in File | Options | Proofing | AutoCorrect Options | AutoFormat As You Type.

    Stefan Blom, Microsoft Word MVP
    Wednesday, October 26, 2011 9:30 PM
  • Thanks for your reply.

    Yes, if I use the Paste Special option of "Unformatted Text" the text is pasted in just as I want it, text only without any of the source formatting (font face, size, colour or hyperlink data).

    I do not believe there are any add-ins affecting this. Looking at File | Options | Add-Ins the only active applications add-ins listed are:
    - Acrobat PDFMaker Office COM Addin
    - Instant Messaging Contacts (English)

    I tried disabling the AutoFormat As You Type setting you suggested but that did not prevent the hyperlink data from coming in... I'm pretty sure the "Keep Text Only" setting should deal with that as well.

    I guess I can only conclude that there's *something* wrong with my installation or environment that's causing this setting to fail. Thanks for your help anyway though.

    Wednesday, October 26, 2011 10:07 PM
  • Just in case, you could try disabling those add-ins, and see if it makes a difference. See the sections referring to add-ins in the article at http://support.microsoft.com/kb/921541/en-us (How to troubleshoot problems that occur when you start or use Word 2010, Word 2007, Word 2003, or Word 2002).

    Stefan Blom, Microsoft Word MVP
    Wednesday, October 26, 2011 10:16 PM
  • Tried disabling add-ins and it didn't make a difference... such a strange quirk. Thanks again for your help... whatever is causing things setting to not work properly will, apparently, remain a mystery.
    Thursday, October 27, 2011 5:50 PM
  • "Sihgneg" wrote in message news:edf72d5d-3f6f-42d3-ad64-d1bbc885d22e@communitybridge.codeplex.com...
    Tried disabling add-ins and it didn't make a difference... such a strange quirk. Thanks again for your help... whatever is causing things setting to not work properly will, apparently, remain a mystery.

     
     
    One additional suggestion (if you haven’t already tried it): Exit Word and rename the Normal template. Then restart Word and see if the issue remains.

    Stefan Blom, Microsoft Word MVP
    Thursday, October 27, 2011 6:08 PM
  • Tried renaming Normal.dotm and then starting Word. It created the new Normal.dotm but the problem remained.

    This same issue exists for me in Outlook when composing emails. I have File | Options | Mail | Editor Options | Advanced | Cut, copy and paste settings set to Keep Text Only but the behaviour is the same as in Word. Source formatting is kept with my default paste and my only way to get the unformatted text is to use the Paste Special option and then select Unformatted Text.

    Thursday, October 27, 2011 6:38 PM
  • "Sihgneg" wrote in message news:8fe24bc5-8bb9-4742-a917-47074d7ff2e8@communitybridge.codeplex.com...
     
    Tried renaming Normal.dotm and then starting Word. It created the new Normal.dotm but the problem remained.
     
    This same issue exists for me in Outlook when composing emails. I have File | Options | Mail | Editor Options | Advanced | Cut, copy and paste settings set to Keep Text Only but the behaviour is the same as in Word. Source formatting is kept with my default paste and my only way to get the unformatted text is to use the Paste Special option and then select Unformatted Text.
     
     
    If you paste as Unformatted Text a lot, you could make use of the following macro:
     
    Sub PastePlainText()
    On Error Resume Next
    Selection.PasteSpecial DataType:=wdPasteText
    End Sub
     
    Store the macro in the Normal template. Add a keyboard shortcut and/or a button to the QAT.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Hutchma Friday, October 28, 2011 6:19 PM
    Friday, October 28, 2011 5:31 PM
  • That's a workable solution and works well for me in Word, thank you.

    I tried to implement it in Outlook too but it doesn't look like there's any way to add a keyboard shortcut to a macro in Outlook. :(

    Friday, October 28, 2011 6:19 PM
  • "Sihgneg" wrote in message news:23b3084e-46d8-4556-af31-8a1062bf0ea4@communitybridge.codeplex.com...
     
    That's a workable solution and works well for me in Word, thank you.
     
    I tried to implement it in Outlook too but it doesn't look like there's any way to add a keyboard shortcut to a macro in Outlook. :(
     
     
     
    You are welcome.
     
    Note that Outlook’s object model is quite different from Word’s, so you probably couldn’t use the macro in Outlook anyway.

    Stefan Blom, Microsoft Word MVP
    Friday, October 28, 2011 6:58 PM
  • In addition to a Word macro that pastes unformatted text, I use Pure Text.  I really needed to use it just last week when I was pasting from PowerPoint to Word.  My macro wouldn't work on the PowerPoint table but Pure Text did.  It's Windows-based freeware.

    OBTW:  I tried working with the keep text only settings in W2007. But decided that I really need the regular paste too often, and went back to using  my paste unformatted text macro.  So I hadn't tried it with W2010 until I read your post  last night.  My result is the same as yours.  Word totally ignores the setting.

    Pam

    • Marked as answer by Hutchma Friday, October 28, 2011 11:47 PM
    Friday, October 28, 2011 11:04 PM
  • I tried working with the keep text only settings in W2007. But decided that I really need the regular paste too often, and went back to using  my paste unformatted text macro.  So I hadn't tried it with W2010 until I read your post  last night.  My result is the same as yours.  Word totally ignores the setting.
     
    How strange that we are getting opposite results here. :-(  Have you installed the most recent updates for Office 2010? Which operating system are you using? I’m using Windows 7 Home Premium 64 bit and Office 14.0.6106.5005 32 bit.
     
     

    Stefan Blom, Microsoft Word MVP
    Friday, October 28, 2011 11:14 PM
  • Thanks Pam for the suggestion. I will look into Pure Text. It's nice to know I'm not the only one who has encountered this issue. The strange thing is I'm sure I remember this option working for me properly with Office 2007... it was one of my favourite options they added in that revision.

    I'm using Windows 7 Professional 64 bit and Office  14.0.6106.5005 32 bit.

    Friday, October 28, 2011 11:43 PM
  • Stefan, I have the same operating system and same version of Office.

    Sihgneg, yes, it did work in W2007.

    Come to think of it though, I have used that setting a few times in W2010--to help someone with a problem probably--and I think I'd have remembered if it hadn't worked.  So I wonder if this is new. 

    Pam


    • Edited by PamCaswell Saturday, October 29, 2011 12:30 AM
    Saturday, October 29, 2011 12:30 AM
  • Come to think of it though, I have used that setting a few times in W2010--to help someone with a problem probably--and I think I'd have remembered if it hadn't worked.  So I wonder if this is new.
     
    So what might be different between my system and yours, when the basics seem to be identical? That’s worth thinking about. :-)

    Stefan Blom, Microsoft Word MVP

    Saturday, October 29, 2011 10:32 AM
  • Sorry, busy weekend.  I'll try unloading  my add-ons and get back to you.

    Pam

    Monday, October 31, 2011 7:48 PM
  • I know this is old and it's marked as answered even though there's no answer as to why this is happening. I've been able to reproduce this behavior on my system and I believe this is an unidentified bug in the software. If I choose the option to not display formatting options when I paste content, my preferences are ignored and the source formatting is applied. When I leave the option to display paste options turned on, my preferences are obeyed and only the text is pasted into my document. Can anybody else try this on their systems and verify my results with the program?
    Monday, April 23, 2012 7:46 PM
  • Thank you Thank you Thank you. I have asked my IT to help, as well as a special PC help service. This 'fixed' my problem of not merging formatting automatically
    Tuesday, August 14, 2012 11:44 PM
  • I know this is old and it's marked as answered even though there's no answer as to why this is happening. I've been able to reproduce this behavior on my system and I believe this is an unidentified bug in the software. If I choose the option to not display formatting options when I paste content, my preferences are ignored and the source formatting is applied. When I leave the option to display paste options turned on, my preferences are obeyed and only the text is pasted into my document. Can anybody else try this on their systems and verify my results with the program?
                     
    I can reproduce this as well. Word seems to ignore the chosen paste formats, and instead use the defaults, unless "Show Paste Options button when content is pasted" is selected. This must be a bug. :-(

    Stefan Blom, Microsoft Word MVP

    Wednesday, August 15, 2012 10:01 AM
  • I have this problem in MS Office 2010 on Windows 7.  All options are set to "Keep Text Only".  I also unchecked "Keep  bullets and numbers when pasting text with Keep Text Only option", "Use smart cut and paste", and "AutoFormat As You Type --> Internet and network paths with hyperlinks".

    I select text in Google Chrome, paste it into my Word document, and it has all the font, color, and size seen in Chrome.

    Extremely irritating.

    Wednesday, October 24, 2012 9:01 PM
  • I have this problem in MS Office 2010 on Windows 7.  All options are set to "Keep Text Only".  I also unchecked "Keep  bullets and numbers when pasting text with Keep Text Only option", "Use smart cut and paste", and "AutoFormat As You Type --> Internet and network paths with hyperlinks".

    I select text in Google Chrome, paste it into my Word document, and it has all the font, color, and size seen in Chrome.

    Extremely irritating.


                   
    Well, there is a workaround mentioned in the previous replies: Make sure to select "Show Paste Options button when content is pasted"; Word will then honor the paste options that you are referring to.

    Stefan Blom, Microsoft Word MVP

    • Proposed as answer by CharlyLLV Saturday, March 23, 2013 8:50 PM
    Wednesday, October 24, 2012 9:26 PM
  • How does one use a macro in word? 

    How does another user how will not enable macros get this benefit?

    This same thing is happening to me. I can't for the life of me figure out why. Interestingly though this works (pasting with destination formatting respected) only if I hit return or one single space.

    I am creating a report template and I know the users wont care that the final product has old and new styles (font, size, etc.) 

    So I cant use a macro, and I cant rely on the user to do this right. What are my options?

    Wednesday, October 14, 2015 11:23 PM
  • This issue still persists in Word 2016. How is it even possible that this has not been fixed yet? I want no Paste Options button and keep text only as default. Is that so exotic that it was never tested by Microsoft??
    Sunday, February 19, 2017 1:24 PM
  • This issue still persists in Word 2016. How is it even possible that this has not been fixed yet? I want no Paste Options button and keep text only as default. Is that so exotic that it was never tested by Microsoft??

                 

    Very few posters here is in a position to make decisions on Microsoft's behalf. My gues is that this bug has low priority since there is a known workaround. 

    What you can do is post suggestions and/or feedback in the Uservoice forum at http://word.uservoice.com.

       

    Stefan Blom, Microsoft Word MVP

    Sunday, February 19, 2017 7:36 PM
  • I've been able to reproduce this behavior on my system and I believe this is an unidentified bug in the software.

    If I choose the option to not display formatting options when I paste content, my preferences are ignored and the source formatting is applied.

    When I leave the option to display paste options turned on, my preferences are obeyed and only the text is pasted into my document.

    FOR ANY ONE LOOKING FOR A VIABLE SOLUTION TRY ABOVE. IT WORKED FOR ME.

    I have been wrestling with finding a solution for this bug for months now. If you keep the "Show Paste Options Button When Content Is Pasted" checked, MS Word will obey the "Keep Text Only" rule.

    I am using Office 2016 on a Windows 10 machine.

    • Proposed as answer by Preyker Thursday, January 18, 2018 10:33 AM
    Wednesday, September 20, 2017 3:40 AM
  • If you keep the "Show Paste Options Button When Content Is Pasted" checked, MS Word will obey the "Keep Text Only" rule. I am using Office 2016 on a Windows 10 machine.

    I can confirm this solution for Outlook 2007 (!) as well.
    Thursday, January 18, 2018 10:36 AM