locked
How to disable POP3 and IMAP4 class Discovery for the new Exchange 2010 MP RRS feed

  • Question

  • Hello,

     

    We just installed the new Exchange 2010 MP yesterday and started receiving POP3 and IMAP4 connectivity failure alerts.  Since we do not use these two protocols in our environment I wanted to know the best practice on how to disable these.

     

    Should I override/disable the Discovery for these classes itself?  Or, should I just go directly to the alerting Rule and disable it and leave the Discovery enabled?

     

    Thanks,

    Tom


    Tom Martin Email: tmartin@caa.com
    • Edited by martit01 Monday, April 11, 2011 6:03 PM changed Title to better indicate the direction of the post.
    Friday, April 8, 2011 5:09 PM

Answers

  • The discovered types are assciate with an individual discovery.  So if you see a discovery that has the types that drive the monitoring you want to disable, disable that discovery.  It is all or nothing, you cannot disable discovery on a type by type basis.

    In your example, the first one disocvers and tests client access via POP3.

    The second two discovery the organization and client access. 


    Microsoft Corporation
    • Marked as answer by martit01 Friday, April 29, 2011 4:40 PM
    Tuesday, April 12, 2011 4:01 PM
  • I disabled the monitoring by following these steps:

    In the "Monitoring" tab click "Windows computers", find the exchange server for which you are receiving the alert, right-click it and click Open -> Health Explorer.

    In the "Entity Health" you should find right away the monitors for POP  and IMAP (they should be marked with a red x): right click the monitor -> Monitor Properties.

    Go to the "Overrides" tab and disable/override the monitors.

    • Proposed as answer by Bob CornelissenMVP Wednesday, April 20, 2011 5:16 AM
    • Marked as answer by Yog Li Tuesday, May 3, 2011 9:20 AM
    Monday, April 18, 2011 1:23 PM

All replies

  • Hi Tom, You can kill the discovery. All things below it (monitors and rules) will stop calling for attention.
    Bob Cornelissen - BICTT (My BICTT Blog)
    Monday, April 11, 2011 7:08 AM
  • Thanks Bob,

     

    So under Object Discoveries for POP3 - Exchange 2010 scope, I see the following:

     

    Discovered Type: POP3(1)

                    Microsoft.Exchange.2010.ClientAccessComponent.DiscoveryRule – Target: Client Access

     

    Discovered Type:POP3 Service (2)

                    Microsoft.Exchange.2010.Organization.DiscoveryRule – Target: Server Role

                    Microsoft.Exchange.2010.ClientAccessComponent.DiscoveryRule – Target: Client Access

     

    Which ones of these Object Discoveries do I need to disable?

     

    Do I disable them “For all objects of class: Client Access”  and “For all objects of class: Server Role”

     

    Thanks,

    Tom


    Tom Martin Email: tmartin@caa.com
    Monday, April 11, 2011 5:06 PM
  • The discovered types are assciate with an individual discovery.  So if you see a discovery that has the types that drive the monitoring you want to disable, disable that discovery.  It is all or nothing, you cannot disable discovery on a type by type basis.

    In your example, the first one disocvers and tests client access via POP3.

    The second two discovery the organization and client access. 


    Microsoft Corporation
    • Marked as answer by martit01 Friday, April 29, 2011 4:40 PM
    Tuesday, April 12, 2011 4:01 PM
  • I disabled the monitoring by following these steps:

    In the "Monitoring" tab click "Windows computers", find the exchange server for which you are receiving the alert, right-click it and click Open -> Health Explorer.

    In the "Entity Health" you should find right away the monitors for POP  and IMAP (they should be marked with a red x): right click the monitor -> Monitor Properties.

    Go to the "Overrides" tab and disable/override the monitors.

    • Proposed as answer by Bob CornelissenMVP Wednesday, April 20, 2011 5:16 AM
    • Marked as answer by Yog Li Tuesday, May 3, 2011 9:20 AM
    Monday, April 18, 2011 1:23 PM