Network driver issues after Sysprep & Capture reboot RRS feed

  • Question

  • Hi all

    I have a fresh customised PC build that was ready for capture. I proceeded to follow same steps I have done for MDT 2010 but for 2012 U1. 

    I created a general sysprep and capture task that I start from within windows and it goes through the various initial tasks no problem by runningthe LiteTouch.vbs file in the Scripts directory. The PC is removed from the domain.

    Problem is that upon reboot into WindowsPE where it would begin to actually capture the image, it throws the following error:

    A connection to the deployment share (\\SERVER\DeploymentShare$) could not be made. The following networking device did not have a driver installed.

    It then lists my network driver.

    The thing is though that this driver is indeed injected into the Out-Of-Box drivers directory, I have tried not only updating the deployment share but recreating the boot images. The NIC in the PC has a WinPE driver from the manufacturer and I have imported this but no joy. I have also checked the WinPE settings and that has all drivers selected.

    To confuse things the same PC was deployed to previously using MDT 2012 (booting off USB drive to deployments share) and it worked fine booting into WinPE and deployment server.

    Any ideas? I thought the WinPE wasn't getting the driver loaded but doesn't a deployment use the same WinPE version as the sysprep and capture and so if the driver works for the deployment it should for the capture?

    My next step is to create a new selection profile and only add the NIC driver and set that to WinPE as I have read it could have too many drivers injected into the default profile?

    Can anyone point me to the right logs that I could post up to help? would these be on the Deployment server or locally when I reboot and go back into PC after the capture fails?


    Sunday, July 21, 2013 11:07 AM

All replies

  • The only question to ask that you didn't already provide is if you are using WAIK or ADK?

    To answer your question, the Deployment and the Capture do use the same WinPE, assuming it was copied onto the USB from the same source.  Is it possible a change was made to the WinPE and regenerated between when you got the USB to boot and now with the attempt to Capture?  I think your plan to try a Selection Profile with just the single NIC Driver you expect to work to be a good one.

    As for logs, if this is a problem with the drivers in WinPE, there won't really be any logs that would help.  Nothing will be on the Deployment server since the booting machine can't talk to the network (no driver) and the few logs locally on the device won't say much because they can't connect to the Deployment server to start the Task Sequence.

    Going back to my first question... if you are using WAIK, the simple thing may be to upgrade to ADK.  ADK has a much greater depth of "built-in" driver support and may obviate the need to inject drivers anymore for WinPE (which has been my experience, currently).

    David Coulter | | @DCtheGeek

    Sunday, July 21, 2013 3:46 PM
  • The ADK runs off of WinPE 4.0, (Windows 8). If you are using the ADK now, does your driver support Windows 8?
    Monday, July 22, 2013 7:09 PM