none
Running "Apply Patches" task step in standard Task sequence - do packages need to be added to WinPE ISO? (And a WSUS issue) RRS feed

  • Question

  • Hi All,

    I trying to set-up MDT 2013 to produce a Patched Windows 7 image, and although I'm pointing MDT to our WSUS server, OS updates do not get applied during the installation of the OS in "State Restore -- Windows Update (Pre-Application Installation)". This task step is enabled and in the later step ("State Restore -- Windows Update (Post-Application Installation)", I see that Office applications DO get updated. I think WSUS is set to send updates to unknown computer - I can see Unknown computer register to WSUS and, of course, Office updates are getting applied.

    Anyhow, I though I would try to import some packages in MDT and install them in this fashion. I take it that these packages need to be included into the WinPE ISO? At the moment, the WinPE ISO uses a selection profile to just use Windows 8 drivers (no Packages included). I had assumed that the ISO would only need info for WinPE itself, but then again I suppose that's why its called an "Install Updates Offline" step...

    In which case, would it be recommended to create multiple Deployment Shares for each OS? If you want to do the same for Windows 8 and (eventually) Windows 10, then I assume that all these packages would need to be included in the WinPE ISO, and as only one set of ISO can practically be managed per Deployment share, it would seem to be preferable to create multiple WinPE ISOs.

    Many thanks.


    Chris

    Saturday, August 15, 2015 3:31 PM

All replies

  • Well, I have tried a few things to setup the OS patches to get installed during installation rather that via WSUS, but unfortunately everything fails.

    I initially imported bunch of MSU packages, but in the end went back to just one - SP1. I regenerated the WinPE images and tried a new test Standard Task, but this still failed with the following error.

    If I then disable the Task Sequence step "Apply Patches" (an "Install Updates Offline" step) in the Pre-installation group, all progresses as expected, although SP1 (and of course other updates) do not get installed. 

    Any suggestions?


    Chris

    Sunday, August 16, 2015 6:59 PM
  • Just an update.

    Could not resolve the offline patching. However, it would appear the the SP1 may have been corrupt in WSUS. Deleted the file, and re-forced the downland and all started updating as as expected. 


    Chris

    Monday, August 24, 2015 5:42 PM