locked
psconfig.exe after upgrade, how to pause central admin until all other servers are complete RRS feed

  • Question

  • Hello, after any CU or SP upgrade on SharePoint 2007, I satart the wizard (GUI) in the central admin server, pausing at the stage where the GUI says to do so in case of multiple servers, then I run "psconfig -cmd upgrade -inplace b2b -wait -force" on the rest of the servers, and when all other servers complete the psconfig upgrade, I go back to the central admin and resume the GUI to complete the process.

    Is there a way to do the same start/pause/resume using the psconfig command on the central administrator servers? this is the only issue I have to automate the upgrade process.

    Thank you!

    Thursday, March 15, 2012 7:47 PM

Answers

  • Hi

    You'll get that message each time you run the wizard, and you need to run the wizard on one server at a time. Don't be much concerned, it's simply a warning that all the WFE's will need to be updated inorder to work correctly. I usually install all the binaries, run the wizard on the admin server i.e server with Central Admin provisioned, then each of the WFE's one at at time.


    Regards Ram

    Tuesday, March 20, 2012 2:55 AM

All replies

  • Hi,

    You should complete the execution in central admin server before starting this off in other servers in farm


    Thanks, Rahul Rashu

    Friday, March 16, 2012 2:05 AM
  • Hi,

    You should complete the execution in central admin server before starting this off in other servers in farm


    Thanks, Rahul Rashu

    Using the psconfig.exe to start the configuration in central admin should complete before even starting the psconfig in the rest of the servers? Why does the wizard GUI work different? Is there another process involved?

    Thanks!

    Saturday, March 17, 2012 12:02 PM
  • Hi

    You'll get that message each time you run the wizard, and you need to run the wizard on one server at a time. Don't be much concerned, it's simply a warning that all the WFE's will need to be updated inorder to work correctly. I usually install all the binaries, run the wizard on the admin server i.e server with Central Admin provisioned, then each of the WFE's one at at time.


    Regards Ram

    Tuesday, March 20, 2012 2:55 AM