locked
Installer fails on Server side includes not being enabled RRS feed

  • Question

  • I am installing PAS 6.3 on Windows 2003 R2 32bit and I get the error message that Server Side Includes and
    Acitve Server Pages need to be set to allowed. I have checked IIS and both are set to Allowed. Anyone know why the PAS installer would
    think that these two are not set to allowed? Am I missing something here?
    FJK
    Friday, July 31, 2009 5:09 PM

Answers

  • Hello FJK,

    I've encountered this problem a few times and you'll need to verify the actual IIS metabase file to ensure the properties are indeed 'Allowed'.  Each of the following should show a "1" value in the IIS MetaBase.xml:

    1,C:\WINDOWS\system32\inetsrv\ssinc.dll,0,SSINC,Server Side Includes
    1,C:\WINDOWS\system32\inetsrv\asp.dll,0,ASP, Active Server Pages
    1,C:\WINDOWS\system32\inetsrv\httpext.dll,0,WEBDAV,WebDAV

    On other thing to check is Environmental Variables.  If they're not directoed to c:\temp you'll want to adjust them to reflect that path. 

    Example: Temp = c:\temp; tmp = c:\temp

    If neither of those options help, try Allowing 'All Unknown ISAPI Extensions' within the IIS Manager.  I did see that extension interfere one time as well and allowing it resolved the problem.

    Please keep us updated and let us know if you need further assistance.

    Thanks,
    Amanda Ruffner
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Sean_Flanagan Friday, August 28, 2009 8:10 PM
    Wednesday, August 5, 2009 9:49 PM
  • Somehow another one of our admins was able to RDP into the server and the install worked for him. Not sure what happened or changed, but it worked. Thank you for the reply though. This information may come in handy next time.

    Frank
    FJK
    Friday, August 7, 2009 3:31 PM

All replies

  • Hello FJK,

    I've encountered this problem a few times and you'll need to verify the actual IIS metabase file to ensure the properties are indeed 'Allowed'.  Each of the following should show a "1" value in the IIS MetaBase.xml:

    1,C:\WINDOWS\system32\inetsrv\ssinc.dll,0,SSINC,Server Side Includes
    1,C:\WINDOWS\system32\inetsrv\asp.dll,0,ASP, Active Server Pages
    1,C:\WINDOWS\system32\inetsrv\httpext.dll,0,WEBDAV,WebDAV

    On other thing to check is Environmental Variables.  If they're not directoed to c:\temp you'll want to adjust them to reflect that path. 

    Example: Temp = c:\temp; tmp = c:\temp

    If neither of those options help, try Allowing 'All Unknown ISAPI Extensions' within the IIS Manager.  I did see that extension interfere one time as well and allowing it resolved the problem.

    Please keep us updated and let us know if you need further assistance.

    Thanks,
    Amanda Ruffner
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Sean_Flanagan Friday, August 28, 2009 8:10 PM
    Wednesday, August 5, 2009 9:49 PM
  • Somehow another one of our admins was able to RDP into the server and the install worked for him. Not sure what happened or changed, but it worked. Thank you for the reply though. This information may come in handy next time.

    Frank
    FJK
    Friday, August 7, 2009 3:31 PM