locked
Excel to word hyperlink copy RRS feed

  • Question

  • Hi,

    i am trying to copy hyperlinks from excel 2010 to word 2010.

    both files are in same folder in the file server.

    once i copy the hyperlinks, i try to open the link from word. when i move my cursor to the link it gives me a different link starting with C:\users\username\appdata\local\microsoft\windows\ then the actual folder location.

    how do i copy a hyperlink from excel to word with out distroying the source link.

    thank you,

    krishna 


    Krishna Gummadapu

    Tuesday, April 22, 2014 4:53 AM

Answers

  • There are some registry entries that affect how Word treats hyperlinks to UNC/file addresses. In this case the following one may be relevant, but I haven't checked:

    http://support.microsoft.com/kb/967538

    For Word 2010, you would need 
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options
    rather than
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options


    Peter Jamieson

    • Marked as answer by zkandy Wednesday, May 7, 2014 2:32 AM
    Friday, April 25, 2014 2:50 PM

All replies

  • You haven't said what is different about the links. Do not that hyperlinks in Word default to a fully-qualified path. If you want to implement a relative path, check out the solution I've posted at:
    http://windowssecrets.com/forums/showthread.php/154379-Word-Fields-and-Relative-Paths-to-External-Files

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Tuesday, April 22, 2014 6:36 AM
  • Hi Paul,

    the original link will start with Z:\shared folder\folder1\folder2\folder3\file

    the link i am getting is c:\Users\username\appdata\local\microsoft\windows\shared folder\folder1\folder2\folder3\file

    which is under my profile in local computer. when i navigate to windows folder under my profile, there is not shared folder.

    some links are even pointing to temporary internet folder.

    thank you,


    Krishna Gummadapu

    Tuesday, April 22, 2014 6:41 AM
  • That suggests 'Z:' is an alias for 'c:\Users\username\appdata\local\microsoft\windows'.

    As for links pointing to your temporary internet folder, that suggests the file you copied them from was opened in a browser, a zip file or an email and, without a qualified path, that's where the Excel links are pointing to.


    Cheers
    Paul Edstein
    [MS MVP - Word]

    Tuesday, April 22, 2014 6:45 AM
  • Hi Clark,

    i have tried that link and used those options. Still same.

    my issue was, when i am accessing the file server (mapped as network drive to my pc), why word giving me local C drive path to the hyperlink. if i copy those hyperlinks from excel to other excel they are good. exact link and opening fine. but if i copy to word the link changes.

    thank you,

    krishna


    Krishna Gummadapu

    Tuesday, April 22, 2014 6:47 AM
  • Hi Paul,

    Z is a network mapped drive from file server (Domain controller). all hyperlinks are pointing to either word or excel documents from the file server.

    thank you,

    krishna


    Krishna Gummadapu

    Tuesday, April 22, 2014 6:49 AM
  • When you Edit the hyperlink as Z:\shared folder\folder1\folder2\folder3\file in Excel.
    The link should changes to UNC path ,Like \\ServerName\shared folder\folder1\folder2\folder3\file
    Tested this issue in Excel 2010, it works fine when I copy hyperlink from Excel to Word, only the Hyperlink changes to a UNC path.
    Maybe you can try to use UNC path instead of map network driver letter as Hyperlink.

    Wind Zhang
    TechNet Community Support

    Wednesday, April 23, 2014 7:37 AM
  • There are some registry entries that affect how Word treats hyperlinks to UNC/file addresses. In this case the following one may be relevant, but I haven't checked:

    http://support.microsoft.com/kb/967538

    For Word 2010, you would need 
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options
    rather than
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options


    Peter Jamieson

    • Marked as answer by zkandy Wednesday, May 7, 2014 2:32 AM
    Friday, April 25, 2014 2:50 PM