none
Cannot Open CHM Files RRS feed

  • Question

  • I have just switched to Win 7 64 Bit and I cannot open any of my chm files, created for the help text of a desktop application we develop.  When I try to access them from the software, nothing seems to happen.  When I try to open them from Windows Explorer, I get "Cannot Open the File: Mk:@MSITStore: ..." for the selected .chm path/file. I have tried several things found online, but none have helped yet.

    • The files on my network and local are both effected.
    • AV is Trend Micro
    • CHM file created/compiled using RH8

    Any assistance would be greatly appreciated.

    Tuesday, May 4, 2010 4:38 PM

Answers

  • Hope this helps

    Microsoft recently released a security patch that makes it impossible to view CHM files that are stored on a network drive (as opposed to CHM files stored on your own computer). The help file will appear, but instead of the topic text you will see an error message "this page cannot be displayed".

    The security patch and its effects are fully described on Microsoft's web site at http://support.microsoft.com/kb/896358

    If you trust all the computers on your LAN or intranet (and the people using them), you can lower the restrictions on the Local Intranet zone to allow CHM files to be displayed with the following steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
    If this registry subkey does not exist, create it.
    3. Right-click the ItssRestrictions subkey, point to New, and then click DWORD Value.
    4. Type MaxAllowedZone, and then press Enter.
    5. Right-click the MaxAllowedZone value, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor.

    If this solution does not work for you, please see http://support.microsoft.com/kb/896358 for alternatives.

    Thursday, May 6, 2010 2:07 PM

All replies

  • Hope this helps

    Microsoft recently released a security patch that makes it impossible to view CHM files that are stored on a network drive (as opposed to CHM files stored on your own computer). The help file will appear, but instead of the topic text you will see an error message "this page cannot be displayed".

    The security patch and its effects are fully described on Microsoft's web site at http://support.microsoft.com/kb/896358

    If you trust all the computers on your LAN or intranet (and the people using them), you can lower the restrictions on the Local Intranet zone to allow CHM files to be displayed with the following steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
    If this registry subkey does not exist, create it.
    3. Right-click the ItssRestrictions subkey, point to New, and then click DWORD Value.
    4. Type MaxAllowedZone, and then press Enter.
    5. Right-click the MaxAllowedZone value, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor.

    If this solution does not work for you, please see http://support.microsoft.com/kb/896358 for alternatives.

    Thursday, May 6, 2010 2:07 PM
  • I had the same problem I tried everything specified in the support. My folder name that has these .CHM files has "#" that was the reason for me. Just to update so that this might help someone in future .

    • Proposed as answer by Er. Rajan Garg Monday, January 7, 2013 5:15 AM
    Wednesday, January 26, 2011 2:34 PM
  • Thanks Abid.....your suggestion saved me couple of hours....It's strange but in my case if folder name that has .CHM files contains '.chm' causes the problem. CHM open fine after removing .chm from folder name...:)

    Microsoft Rocks!!!

    Cheers,

    Rajan


    Cheers,
    Rajan
    My Blog: http://rajangarg.wordpress.com/
    SharePoint 2010 Document Converter
    Visual Studio 2010 Solution Export Import Add-in

    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    Monday, January 7, 2013 5:18 AM
  • For the first time when you open a chm file, it asks for permission. Uncheck it, i.e., let Windows don't ask again. If this didn't solve the problem, right click on the file and go to the properties at the bottom of the menu, then click on the Unblock at the bottom of the General tab. If again you have the problem, after right click and properties, instead of the General tap go to Details tab, and at the bottom, click on Remove Properties and Personal Information, then at what opens choose "Create a copy with all possible properties removed". You will have a copy of the file at the same folder you saved your chm file. Hopefully the new copy of the file works. Good luck!
    Monday, June 3, 2013 4:12 PM
  • Solution from http://www.techrepublic.com/forums/discussions/cannot-open-the-file-mkmsitstorec/

    • Run the following lines:

      regsvr32 %systemroot%\system32\hhctrl.ocx
      regsvr32 %systemroot%\system32\itss.dll

    Monday, February 3, 2014 3:32 PM
  • thanks, it can solve my problem viewing chm on windows 7 super lite

    Friday, April 19, 2019 4:22 AM