locked
Error opening dashboard page RRS feed

  • Question

  •  

    Hi,

     

    I'm having some trouble opening the page that's created once I have deployed my dashboard to my Sharepoint document library.

     

    When i try to open the page, i receive the following error:

     

    "An error occurred during the processing of /xxxx/xxxx/Shared Documents/PPS Demo Dashboard/Summary.aspx. Unknown server tag 'PPSWebPartsTongue TiedcriptManagerLoader'. "

     

    Has anyone anyone else experienced this problem and managed to fix it?

     

    Thanks,

     

    Michael

     

     

    Friday, November 9, 2007 1:10 AM

Answers

  • Sorry you are having problems.

     

    It appears that the PPS web parts have not been registered on your SharePoint server.  Have you installed PPS on your SharePoint server?  A set of components needs to be installed on the SharePoint site.  Run the Monitoring installer (PSCSrv.msi) on your SharePoint server, and when you run the Configuration Manager, select only the option: "Dashboard Viewer for SharePoint Services".

     

    If that doesn't work, then you may need to manually enable the PPS WebParts for your SharePoint site.  I think there is a blog post somewhere that dicusses this.  Please reply back if you need those instructions.

     

    Regards,

    Tim

    Friday, January 25, 2008 5:41 PM

All replies

  • I am also experiencing the same problem.  Please help...

     

    HP

     

    Friday, January 25, 2008 3:46 PM
  • Sorry you are having problems.

     

    It appears that the PPS web parts have not been registered on your SharePoint server.  Have you installed PPS on your SharePoint server?  A set of components needs to be installed on the SharePoint site.  Run the Monitoring installer (PSCSrv.msi) on your SharePoint server, and when you run the Configuration Manager, select only the option: "Dashboard Viewer for SharePoint Services".

     

    If that doesn't work, then you may need to manually enable the PPS WebParts for your SharePoint site.  I think there is a blog post somewhere that dicusses this.  Please reply back if you need those instructions.

     

    Regards,

    Tim

    Friday, January 25, 2008 5:41 PM
  • Hi,

    My problem occurs when i try to preview my dashboard from DD.

    It gives me this error

    Server Error in '/Preview' Application.

    Method not found: 'Void System.Web.UI.ScriptManager.set_LoadScriptsBeforeUI(Boolean)'.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.MissingMethodException: Method not found: 'Void System.Web.UI.ScriptManager.set_LoadScriptsBeforeUI(Boolean)'.

    Source Error:

    Line 26: 			</asp:WebPartZone></td>
    Line 27: 		</tr>
    Line 28: 	</table><PPSWebPartsTongue TiedcriptManagerLoader runat="server" id="scriptManagerLoader">
    Line 29: 
    Line 30: 	</PPSWebPartsTongue TiedcriptManagerLoader><script type="text/javascript">

    Source File: c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\4c7e8fc9a8ce495a8c299ce8e7b0e7c2\f74e9f4237a24ba8943a75829185207d.aspx    Line: 28

    Stack Trace:

    [MissingMethodException: Method not found: 'Void System.Web.UI.ScriptManager.set_LoadScriptsBeforeUI(Boolean)'.]
       Microsoft.PerformancePoint.Scorecards.WebParts.ScriptManagerLoader..ctor() +0
       ASP._4c7e8fc9a8ce495a8c299ce8e7b0e7c2_f74e9f4237a24ba8943a75829185207d_aspx.__BuildControlscriptManagerLoader() in c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\4c7e8fc9a8ce495a8c299ce8e7b0e7c2\f74e9f4237a24ba8943a75829185207d.aspx:28
       ASP._4c7e8fc9a8ce495a8c299ce8e7b0e7c2_f74e9f4237a24ba8943a75829185207d_aspx.__BuildControl__control4(Control __ctrl) in c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\4c7e8fc9a8ce495a8c299ce8e7b0e7c2\f74e9f4237a24ba8943a75829185207d.aspx:5
       System.Web.UI.CompiledTemplateBuilder.InstantiateIn(Control container) +12
       ASP.res_default_master.__BuildControlPlaceHolderMain() in c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\res\default.master:24
       ASP.res_default_master.__BuildControl__control6() in c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\res\default.master:9
       ASP.res_default_master.__BuildControlTree(res_default_master __ctrl) in c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\res\default.master:1
       ASP.res_default_master.FrameworkInitialize() in c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\preview\e95ea01e\9767768b\App_Web_t4rm0mgx.6.cs:0
       System.Web.UI.UserControl.InitializeAsUserControlInternal() +31
       System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) +1978544
       System.Web.UI.Page.get_Master() +48
       System.Web.UI.Page.ApplyMasterPage() +18
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +543
    



    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

     

     

     

    Please tell me what is to be done, as im completely clueless about this.

    Im waiting for ur reply.help please.

    Tuesday, August 12, 2008 1:15 PM
  • This might be a .Net AJAX versioning problem.  PPS needs version 1.0 of the .Net AJAX library.  If you don't have that version installed, you can install it from: http://www.microsoft.com/downloads/details.aspx?FamilyID=ca9d90fa-e8c9-42e3-aa19-08e2c027f5d6&displaylang=en

     

    Hope that gets you going.

     

    - Tim

    Tuesday, August 12, 2008 2:23 PM
  •  

    HI,

    I already have ASP.Net 2.0 Ajax Extensions 1.0..

    Is this the same thing... shall i remove that and install this... 

    Wednesday, August 13, 2008 4:40 AM
  • Hi,

    I dug more into the error,followed the stack trace, and found out a few things to give you a better picture.

    I opened  "c:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview\4c7e8fc9a8ce495a8c299ce8e7b0e7c2\f74e9f4237a24ba8943a75829185207d.aspx" in

    1)VS2005 and the design view shows me

     

    Error Rendering ControlBig SmileashboardElementContainer_225a5ecf66de42119cc1f96e53bac7fa

    An unhandeled exception has occured.

    Object reference not set to an instance of an object.

     

    2)When i opened the same page in Sharepoint designer...It gave me  the master page error..

    The master page file '../res/default.master' cannot be loaded.

     

    Default.master is opening separately without any problem.

    Also, I tried opening the performancepointdefault.master page from the sharepoint site, it gave me the typical "unexpected error has been encountered" sharepoint error page.

     

    Hope this gives you some idea of my error, I cannot find a way out of this, waiting for your response.

    Wednesday, August 13, 2008 7:05 AM
  • Do you have this same problem when you deploy the Dashboard to SharePoint?

     

    Wednesday, August 13, 2008 2:41 PM