none
Open MS Project 2010 mpp file from a website link in IE8 RRS feed

  • Question

  • Hello,

    I asked this question in the IE forums, but they told me to ask it here, so here goes.

    We're using MS Project Professional 2010, and we have a website that links to the .mpp files stored on a network drive.
    When I click on a link to an .mpp file, I get prompted with a file download dialog, where I click "Open" and MS Project opens, but then gives me this error:

    Image and video hosting by TinyPic


    When I click OK, the mpp file is opened in the browser window. It doesn't make any difference if I set a target on the link.
    The message is not correct:
    - File name and path are correct.
    - File format is MS Project 2010 format, nothing wrong with that.
    - It's not an early version file.

    If I copy paste the link URL in Start > Run, then the file opens just fine inside MS Project 2010, so it's really the browser scenario that is failing here.
    We're using Internet Explorer 8.0.6001.18702.

    If I try this scenario with FireFox, it works perfect. The file opens in MS Project without any error.
    Can I change this behaviour in IE8, so it will open mpp files in the client application, and not in the browser?

    I need to be able to load the mpp files from the network share (so not saving them first locally) in MS Project, so people can work on them in the environment (client application) they know.

    Thanks in advance,
    Kurt

    Monday, December 19, 2011 11:27 AM

Answers

  • I tested Method 1 in XP with IE8 - for the mpp file extension -, it works:

    To configure Internet Explorer to open Office files in the appropriate Office program by using the Folder Options tool:

    1. Open My Computer.
    2. On the Tools menu (or the View menu), click Folder Options (or click Options).
    3. Click the File Types tab.
    4. In the Registered file types list, click the specific Office document type (for example, Microsoft Excel Worksheet), and then click Advanced (or click Edit).
    5. In the Edit File Type dialog box, click to clear the Browse in same window check box (or click to clear the Open Web documents in place check box).
    6. Click OK.

    And for the error message: open a CMD window, locate and test running Winproj.exe with the exact file path + name string used in running through IE8. If Project cannot open the mpp file from the command line, and you get the same error message again, that means the filename string is not correct.


    • Edited by Ismet Kocaman Tuesday, December 20, 2011 10:46 AM
    • Marked as answer by kurtvd Tuesday, June 19, 2012 11:42 AM
    Tuesday, December 20, 2011 10:46 AM
  • Ana,

    To open the mpp file in the client and not in the browser, see the steps provided by Project User above in this thread.
    To fix the error/warning message you get when opening an mpp file, see below.

    We have opened a case for this at Microsoft Support.
    It seems that they have a bug in their registry values that causes this.

    You can fix this by doing following steps:

    - Go to Start Run and enter Regedit.
    - Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MSProject.Project.9
    - Under this you should see a folder called CLSID.
    - For this CLSID folder, change the GUID from {74B78F3A-C8C8-11D1-BE11-00C04FB6FAF1} to {48F937AE-8FE0-40FB-A62D-000AF24AA907}.
    - Close the Registry and then test to confirm that the issue does not occur.

    HOWEVER (!)
    Doing the above fix will make the mpp file open in the client application without giving any warnings/errors.
    But when you click on a link to an mpp file, you'll get a download dialog that does not contain the correct info regarding the document.
    It will display "Type: Microsoft Project 14.0 PSI Serializer" instead of "Type: Microsoft Project Document"
    And it will also display an unknown document type icon, instead of the Microsoft Project Document icon.

    In screenshots, this is the difference:

    Before the fix above:
    Image and video hosting by TinyPic

    After the fix above:
    Image and video hosting by TinyPic

    We've asked Microsoft to fix that as well, but they refused to do so.
    So they will not solve this (registry fix included), not with a hotfix, not in the next SP, not in a future product release of Project.
    The above registry fix is the best solution you'll get from Microsoft support.


    • Marked as answer by kurtvd Tuesday, June 19, 2012 11:42 AM
    • Edited by kurtvd Tuesday, June 19, 2012 11:44 AM
    Tuesday, June 19, 2012 11:42 AM

All replies

  • Project displays that message when we provide an incorrect command line argument to Winproj.exe. So if there is a white space anywhere in the filename string, that may be the cause of the error message dialog box. Try double quotes around the filename string including the path etc...

    And for the other part of the question, check the following KB article and try to apply it for .mpp extension:

    http://support.microsoft.com/kb/162059

    Monday, December 19, 2011 12:32 PM
  • Hi Kurt,

     

    We had a very similar issue as you, and we handled it with the October 2010 CU for Project Professional 2007. You can download here:

    http://support.microsoft.com/kb/2412260.

    Also you can try a workaround as describes here: http://support.microsoft.com/kb/274394, but I should recommend the first one. That was what worked us.

     

    Best regards!


    Miguel Soler
    Monday, December 19, 2011 2:56 PM
  • Project displays that message when we provide an incorrect command line argument to Winproj.exe. So if there is a white space anywhere in the filename string, that may be the cause of the error message dialog box. Try double quotes around the filename string including the path etc...

    And for the other part of the question, check the following KB article and try to apply it for .mpp extension:

    http://support.microsoft.com/kb/162059


    Hello,

    We have white spaces in the path, but even if I move the file to a path without white spaces, the same behavior happens.
    So it doesn't seem to be an issue with white spaces.

    I ran the "fix it for me" tool from Microsoft, but still no luck. Same error is given, and the mpp file still opens in the browser.

    Tuesday, December 20, 2011 10:02 AM
  • Hi Kurt,

     

    We had a very similar issue as you, and we handled it with the October 2010 CU for Project Professional 2007. You can download here:

    http://support.microsoft.com/kb/2412260.

    Also you can try a workaround as describes here: http://support.microsoft.com/kb/274394, but I should recommend the first one. That was what worked us.

     

    Best regards!


    Miguel Soler


    We are running Project Professional 2010, so not 2007. I noticed there is a SP1 out for Project 2010, so I installed that one to see if it would solve the problem. We now have Microsoft Project 2010 (14.0.6023.1000) SP1 MSO (14.0.6023.1000).
    After installing SP1, the same problem still exists.

    The workaround is to convert the mpp file to the correct version, but in our case we have Project 2010 mpp files that we want to open in Project 2010. So there is no version issue in our case.

    Tuesday, December 20, 2011 10:03 AM
  • I tested Method 1 in XP with IE8 - for the mpp file extension -, it works:

    To configure Internet Explorer to open Office files in the appropriate Office program by using the Folder Options tool:

    1. Open My Computer.
    2. On the Tools menu (or the View menu), click Folder Options (or click Options).
    3. Click the File Types tab.
    4. In the Registered file types list, click the specific Office document type (for example, Microsoft Excel Worksheet), and then click Advanced (or click Edit).
    5. In the Edit File Type dialog box, click to clear the Browse in same window check box (or click to clear the Open Web documents in place check box).
    6. Click OK.

    And for the error message: open a CMD window, locate and test running Winproj.exe with the exact file path + name string used in running through IE8. If Project cannot open the mpp file from the command line, and you get the same error message again, that means the filename string is not correct.


    • Edited by Ismet Kocaman Tuesday, December 20, 2011 10:46 AM
    • Marked as answer by kurtvd Tuesday, June 19, 2012 11:42 AM
    Tuesday, December 20, 2011 10:46 AM
  • The workaround is to convert the mpp file to the correct version, but in our case we have Project 2010 mpp files that we want to open in Project 2010. So there is no version issue in our case.
    IMHO, it is not an issue related to any version of Project. You can try the same with Excel.
    Tuesday, December 20, 2011 11:22 AM
  • Hi,

    I tried the manual method, by unchecking the "browse in same window" for the mpp file extesion.
    After that, I still get the error message in Project, but then the file opens in Project (so not in the browser anymore).

    So one problem down, one left to solve.

    In my test scenario, I created a html file that only has a link:

    <html>
    	<head></head>
    	<body>
    		<a href="./test.mpp" target="_blank">here</a>
    	</body>
    </html>
    


    I have the html file and the mpp file directly under my C root. So no white space problems in the path.
    If I click on the link in the web page, I can click "open", "save" or "cancel".
    I click "open", then MS Project opens, give me the error message as given in my first post.
    Then I click "ok", and the file opens just fine in Project.

    If I open a command prompt and then execute: winproj.exe "c:\test.mpp"
    Then MS Project opens and the file loads without any error.

    So there still seems to be something wrong when opening the mpp directly from the browser.

    Tuesday, December 20, 2011 12:07 PM

  • <a href="./test.mpp" target="_blank">here</a> </body> </html>

     

    "file:///C:/test.mpp"
    Tuesday, December 20, 2011 4:15 PM
  • >> I click "open", then MS Project opens, give me the error message as given in my first post.

    I've checked Project's command-line switches in Help documents to find a way to supress the error message and DDE commands for &Open action thru Folder Options dialog box | File Types; unfortunately, I've found nothing useful. You're correct and there is no way to stop display of redundant error message box. 

    Tuesday, December 20, 2011 6:50 PM
  • >> I click "open", then MS Project opens, give me the error message as given in my first post.

    I've checked Project's command-line switches in Help documents to find a way to supress the error message and DDE commands for &Open action thru Folder Options dialog box | File Types; unfortunately, I've found nothing useful. You're correct and there is no way to stop display of redundant error message box. 


    When I change the link to:

    <a href="file:///c:/test.mpp" target="_blank">here</a>
    

    The behavior is the same (still error message in Project).

    So I'm blocked then? No way around this nonsense error message from Microsoft Project?

    Wednesday, December 21, 2011 10:37 AM
  • Hello Kurt,

    I've tested with IE8 but I normally use another browser and I do not get that problem ! You can insert links into an Excel file, it works OK with Excel.



    • Proposed as answer by Ismet Kocaman Thursday, December 22, 2011 11:18 AM
    • Edited by Ismet Kocaman Friday, December 23, 2011 11:33 AM
    • Unproposed as answer by kurtvd Wednesday, January 4, 2012 8:18 AM
    Wednesday, December 21, 2011 6:31 PM
  • Project User,

    I don't see the solution in adding links in an excel file? I'm working with a website that should link to an mpp file, and that still doesn't work without the error message.

    Wednesday, January 4, 2012 8:18 AM
  • Project User,

    I don't see the solution in adding links in an excel file? I'm working with a website that should link to an mpp file, and that still doesn't work without the error message.

    I once used Excel to create an index page (just a sheet) containing links to a couple of Project files. I see this is not an alternative in your case.

    Sorry, I did not provide a solution to your problem.


    Wednesday, January 4, 2012 8:38 AM
  • Yes that was my first thought as well.
    I posted this question first in the IE forums, but there they told me it was a Project issue and I should post it here (see my initial post).

    So I'm between opinions as where to look for the cause, and how to find it.

    Wednesday, January 4, 2012 9:23 AM
  • How is the design in the website ? Is there a fixed list of mpp files to select from ?
    Wednesday, January 4, 2012 9:27 AM
  • The number of mpp files is dynamic.
    When we create new projects, new mpp files are created as well.

    Each project has it's own webpage with all the project info, one of them is the link to the mpp file for the project.
    We link to the mpp files using a basic <a href=""></a> element in the webpage, so no list or anything fancy.

    Wednesday, January 4, 2012 9:45 AM
  • A workaround to consider: creating a batch file with a line "full_ path\winproj.exe" "full_path\filename.mpp" and using a link to filename.bat in html (using mpp filename as a batch filename is just for convenience). It is not practical but it worked.
    Wednesday, January 4, 2012 10:21 AM
  • I tried that approach and it works, but that means that I should create .bat files for every .mpp file we have.
    It also means that every user should have project installed in the same location.
    And I'm not sure if all of our users have the permission to run .bat files themselves.

    It's the same approach as creating .lnk files, and use those in the links on the web pages. That works as well, since you get rid of the web context that is giving problems.

    I would like to avoid workarounds like this and just have Internet Explorer or Project work the way they should.

    Wednesday, January 4, 2012 10:41 AM
  • Have you considered reporting the issue to the product support ?
    Wednesday, January 4, 2012 9:40 PM
  • Yes, we're considering that option now since we seem to have run out of alternative options.

    The issue here is only one of the problems we're hitting, so we'll see if we can combine them and open a case at MS.

    • Marked as answer by Mike GlenModerator Tuesday, February 7, 2012 7:09 PM
    • Unmarked as answer by kurtvd Tuesday, June 19, 2012 11:42 AM
    Thursday, January 5, 2012 8:41 AM
  • Yes, we're considering that option now since we seem to have run out of alternative options.

    The issue here is only one of the problems we're hitting, so we'll see if we can combine them and open a case at MS.

    Thank you for feedback. Please post back on progress. For further offline discussions, I am available at projectuser-at-fastmail.fm


    Thursday, January 5, 2012 9:13 AM
  • Hello,

    we're facing similiar issue, can you share how you've solved it?

    We have project server 2010 and want to had a link in the sharepoint site to open directly in the MS Project Professional. We've tried using the following: "full path for project professional" /S "http://server/projectserver/pwa\filename.mpp", but did not work. When opening the project professional de project server parameter is passed to the profiles window in project server and than gives the error message you've posted.

    Thanks in advance,

    Ana

    Tuesday, June 19, 2012 10:44 AM
  • Tuesday, June 19, 2012 11:23 AM
  • Ana,

    To open the mpp file in the client and not in the browser, see the steps provided by Project User above in this thread.
    To fix the error/warning message you get when opening an mpp file, see below.

    We have opened a case for this at Microsoft Support.
    It seems that they have a bug in their registry values that causes this.

    You can fix this by doing following steps:

    - Go to Start Run and enter Regedit.
    - Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MSProject.Project.9
    - Under this you should see a folder called CLSID.
    - For this CLSID folder, change the GUID from {74B78F3A-C8C8-11D1-BE11-00C04FB6FAF1} to {48F937AE-8FE0-40FB-A62D-000AF24AA907}.
    - Close the Registry and then test to confirm that the issue does not occur.

    HOWEVER (!)
    Doing the above fix will make the mpp file open in the client application without giving any warnings/errors.
    But when you click on a link to an mpp file, you'll get a download dialog that does not contain the correct info regarding the document.
    It will display "Type: Microsoft Project 14.0 PSI Serializer" instead of "Type: Microsoft Project Document"
    And it will also display an unknown document type icon, instead of the Microsoft Project Document icon.

    In screenshots, this is the difference:

    Before the fix above:
    Image and video hosting by TinyPic

    After the fix above:
    Image and video hosting by TinyPic

    We've asked Microsoft to fix that as well, but they refused to do so.
    So they will not solve this (registry fix included), not with a hotfix, not in the next SP, not in a future product release of Project.
    The above registry fix is the best solution you'll get from Microsoft support.


    • Marked as answer by kurtvd Tuesday, June 19, 2012 11:42 AM
    • Edited by kurtvd Tuesday, June 19, 2012 11:44 AM
    Tuesday, June 19, 2012 11:42 AM
  • Hello Kurt, Thank you for the feedback. --Regards.
    Tuesday, June 19, 2012 1:28 PM
  • Thank you for your inputs Kurtvd. I've tried the workaround suggested, but still have the same error. I'm trying to open a file from project server 2010 and not from a network drive. Do you have any idea about how to solve it?

    Thanks,

    Regards,

    Ana

    Tuesday, September 18, 2012 9:42 AM
  • Ana,

    We don't use Project Server here, so I don't know if there's something different for that product.

    All I can say is that with the registry change, we were able to get rid of the message on our environment.
    We use Project Professional 2010 and IE 8.

    If you have the option of opening a support ticket at Microsoft, please do so.
    Maybe then they will realise that they should provide an official fix for this problem.

    Tuesday, September 18, 2012 9:45 AM