locked
Maxtor external hard drive stopped working once Service Pack 1 was installed RRS feed

  • Question

  • I have read all the previous forum posts regarding Vista and its problems with external hard drives, but none of the solutions suggested work.
    The external hard drive was recognised and worked without problems until the Service Pack 1 was installed last week.
    Now there is a yellow exclamation mark over the device in Device Management and error Code 10 has appeared.
    I uninstalled the hard drive driver, rebooted the computer and tried to reinstall the driver, which failed.
    Does anyone have any advice or solutions to this problem?
    Thanks
    Monday, April 14, 2008 4:21 PM

Answers

  • Hi,

     

    Generally, error code 10 means driver not correctly loaded or corrupt. As the first step, I recommend you to update the driver for the motherboard and BIOS (if they are not updated compared with manufacturer’s website). If the problem persists, please let me know the model of involved Maxtor external hard drive.

    Just for your reference, there’re only a few devices that encounter compatibility problems after SP1 is updated. For these devices, please check for available driver updates released by IHVs via their website or Windows Update (Contact the manufacturer if necessary).

     

    Cheers,

    Lionel

     

    Wednesday, April 16, 2008 9:03 AM