locked
Windows 7 Screen Saver Timeout Broken when applied through GPO. RRS feed

  • Question

  • Hello,

    I have a 2003 domain with 2 DCs and about 40 clients. Most of the clients are Windows XP and we are migrating to Windows 7. I have a 2008 R2 member server set up so I can use the 2008 GPO Manager and RSAT to manage GPO settings for the Windows 7 clients. I am experiencing a problem with a GPO and my Windows 7 clients.

    I have the screen saver set to blank the screen and lock after 15 minutes., requiring a password to unlock. Everything works just fine on the Windows XP clients. However, the Windows 7 clients never lock, the screensaver never kicks in. I can see with gpresult and in the Windows 7 registry that all the settings are being applied. When I change something in the GPO and run gpupdate /force on the client, the setting apply in the Win 7 registry just fine. I can also see in the "Persoinalization" control panel that all the settings are correct (and greyed out as they are managed through GPO) and change with GPO updates. However, it just never kicks in. I have made sure the scrnsave.scr is valid and even tried the direct path to the file. Nothing works.

    The only way I can get it to work is to set the timeout in the GPO to "not configured", which naturally frees up the timeout field in the control panel, and then have the user set the timeout themselves.

    Here are my GPO settings:

    USER CONFIGURATION->ADMINISTRATIVE TEMPLATES->CONTROL PANEL->PERSONALIZATION:

    - Enable Screen Save: Enabled

    - Prevent changing screen saver: Disabled

    - Password protect screen saver: Enabled

    - Screen Saver Timeout: Enabled, 900 seconds

    - Force specific screen saver: Enabled, scrnsave.scr

    Thanks in advance,

    Nikhil

    Wednesday, November 3, 2010 2:37 PM

Answers

  • I think I may have just found something, it is very obscure, but I this did the trick on two machine so far...

    The Windows 7 image I deployed to my PCs was originally built and sysprepped in VMWare. The VMWare tools were installed on the image. After I removed VMWare tools on the PCs,  the screensaver GPO began working.

    VMWare tools cannot be uninstalled unless you are in a virtual machine, it spits out an error when trying to uninstall. So, I had to manually uninstall the tools be removing registry keys, system files, program files , and services related to VMWare. Once I did this, the screensaver GPO began working.

     

     

    • Marked as answer by Miya Yao Monday, November 15, 2010 8:58 AM
    Wednesday, November 10, 2010 8:45 PM

All replies

  • Hi Nikhil,

     

    Thanks for the post!

     

    I would like to figure out these:

     

    -          Is there any other group policy conflicting with the Windows 7 computers?

    -          Are the Windows XP and Windows 7 computers in the same OU?

     

    If they’re not in  the same OU, I recommend you create the Group Policy like following:

     

    Computer Configuration\Administrative Templates\System\Group Plicy

      -User Group Policy loopback processing mode (Merge Mode)

     

    Also set the following key:

     

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop

     

    ScreenSaveActive value=1  ScreenSaverIsSecure value=1

     

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, November 5, 2010 10:03 AM
  • There are no other group policies in our environemnt. Both XP and Windwos 7 clients are in the same OU.

    Yes, the registry keys are set as directed. Again, everything looks fine. Even the Control Panel reflects my GPO settings and update as I chaneg the GPO. Its just that the GPO never kick in.

    Is there a tool I can use to monitor the countdown timer that trigger the system to actiuvate the screen saver? Maybe there is a process running in the backround that is resetting the timer?

    Wednesday, November 10, 2010 7:01 PM
  • We are experiencing this issue right now.

    The problem we see is this:

    Group Policy is set to apply the following changes:

    • Password Protect The Screen Saver - Enabled
    • Screen Saver Timeout (900 seconds) - Enabled 

    As Microsoft states in this article:

    http://technet.microsoft.com/en-us/library/ee617164%28WS.10%29.aspx

    This policy setting allows you to lock the system.

    If you enable this policy setting, the system locks at a user-defined interval. This policy setting is effective even when no screen saver is selected.

    If you enable this policy setting with the Enable screen saver policy setting, you ensure that the system lock will work even when no screen saver is selected.

    The problem appears to be related to the GPO not actually changing the timeout period even though it shows it has been changed in the GUI.

    Our experience with this is as follows:

    If a user has previously selected a screensaver and set their timeout to 3 minutes for example, the GUI will reflect the change of 15 minutes as applied through GPO, but after 3 minutes, the screen will lock instead of the 15 minutes established in the GPO.

    We have been around and around with this for the last 2 days and nothing seems to alter this functionality. We have tried modifying reg keys as well with no luck.

    Wednesday, November 10, 2010 8:03 PM
  • I think I may have just found something, it is very obscure, but I this did the trick on two machine so far...

    The Windows 7 image I deployed to my PCs was originally built and sysprepped in VMWare. The VMWare tools were installed on the image. After I removed VMWare tools on the PCs,  the screensaver GPO began working.

    VMWare tools cannot be uninstalled unless you are in a virtual machine, it spits out an error when trying to uninstall. So, I had to manually uninstall the tools be removing registry keys, system files, program files , and services related to VMWare. Once I did this, the screensaver GPO began working.

     

     

    • Marked as answer by Miya Yao Monday, November 15, 2010 8:58 AM
    Wednesday, November 10, 2010 8:45 PM
  • Hi,

     

    Glad to hear you find the culprit.

     

    Also thanks for the sharing, it can be beneficial to other communities.

     

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 11, 2010 3:04 AM
  • I just wanted to add that I had this issue and determined it was the mouse. Wireless MS mouse using default HID-compliant driver and the screensaver will not engage. Install latest intellipoint drivers and the issue is resolved. Hope this helps somebody out there resolve this issue.
    Monday, February 28, 2011 7:40 AM
  • This is still a problem, with no VMware tools to remove, in my testing.  Machine is up to date on all patches, Win7 x64.    Also mouse driver is not a factor, moving the mouse prevents the screen saver from engaging, as it should, stop moving the mouse, the screen saver will engage at the timeout value last selected by the user (not the timeout value chosen by the GPO).

    Can an MVP or someone from MS please make sure this is acknowledged as a known problem?  And hopefully fixed before Windows 8?

    Tuesday, August 30, 2011 7:09 AM
  • I too am having the same problem.  The GPO has a defined screensaver in the C:\Windows\SysWow64\screensaver.scr with a timeout of 1800 and required user account to lock so when they come back to the computer they have to enter their credentials.  Mine is not working and no VM software is included.  No local GPO as well.
    Christopher C. Denny
    • Proposed as answer by ccdenny3 Saturday, October 1, 2011 3:52 PM
    • Unproposed as answer by ccdenny3 Saturday, October 1, 2011 3:52 PM
    • Proposed as answer by ccdenny3 Saturday, October 1, 2011 3:53 PM
    • Unproposed as answer by ccdenny3 Saturday, October 1, 2011 3:56 PM
    • Proposed as answer by ccdenny3 Saturday, October 1, 2011 3:56 PM
    • Unproposed as answer by ccdenny3 Saturday, October 1, 2011 3:56 PM
    Friday, September 9, 2011 12:23 AM
  • Same problem here. No VMware tools involved.
    • Proposed as answer by ccdenny3 Saturday, October 1, 2011 3:59 PM
    • Unproposed as answer by ccdenny3 Saturday, October 1, 2011 3:59 PM
    Thursday, September 22, 2011 12:00 AM
  • same problem here.  No VM tools...
    Friday, September 30, 2011 7:19 PM
  • As many had this issue with setting the GPO for a screen saver and time out and it fails, you can also set registry keys.  So, I created the registry key in the GPO of the following that would go to all clients that had the timeout of 30 minutes:

    HKEY_CURRENT_USER\Control Panel\Desktop

    ScreenSaveTimeOut=1800


    Christopher C. Denny
    • Proposed as answer by ccdenny3 Saturday, October 1, 2011 3:58 PM
    Saturday, October 1, 2011 3:58 PM
  • As many had this issue with setting the GPO for a screen saver and time out and it fails, you can also set registry keys. So, I created the registry key in the GPO of the following that would go to all clients that had the timeout of 30 minutes:

    HKEY_CURRENT_USER\Control Panel\Desktop

    ScreenSaveTimeOut=1800


    Christopher C. Denny
    Saturday, October 1, 2011 3:59 PM
  • As many had this issue with setting the GPO for a screen saver and time out and it fails, you can also set registry keys. So, I created the registry key in the GPO of the following that would go to all clients that had the timeout of 30 minutes:

    HKEY_CURRENT_USER\Control Panel\Desktop

    ScreenSaveTimeOut=1800


    Christopher C. Denny
    Saturday, October 1, 2011 3:59 PM
  • I'm experiencing the same problem. Have a Windows 2008 R2 Domain with 3 domain controllers and aprox. 100 workstations. 90% of the Workstations are running Windows 7 Pro, and the rest is a mix of Windows 7 Ultimate and Windows XP Pro SP3. Got a GPO for the whole domain stating that screensaver should be enabled, ask for password on resume and wait about 20 minutes to kick in. Most of the workstations have applied the GPO correctly, but there are quite a few that aren't. Screensaver always kicks in but at 2-5 minutes instead of the 20 minutes configured. If you run rsop.msc it sees that the gpo has been applied, and we can verify the settings by going to the registry keys. It is ackward as I've not seen this kind of problem with the Windows 2K3 domain and XP clients. No VMWare but in the Domain Controller. All our servers have been virtualized using VMWare ESXi 5.0. Hope somebody can get to the bottom of this and let us know an answer that will help. Thanks in advance.
    Thursday, January 19, 2012 4:28 PM
  • Was this ever resolved.   Experiencing same issue 2003 R2 domain, win xp, win 7 clients, two OU's, two screen saver GPO's, one GPO 5 min another GPO 60 min,  Win 7 shows in GUI as 60 but locks after 5 min.

    Wednesday, March 28, 2012 7:26 PM
  • I have the same issue. One OU, 2008 R2, the screensaver settings are loaded correct from GPO, XP users see the screensaver, but Win7 users see only black screen
    Wednesday, May 30, 2012 8:47 AM
  • I am having the same issue 2008R2 / SBS2011 with Win7Pro stations.  Set time out to 15 minutes with password.  Most pc's react fine to the GPO but a handful of machines have immediate timeout / locking apply.  You can verify that the GPO applies on each, but in an moment or two the system will lock far before the fifteen minute timeline.  Servers are in XEN 5.6 environment - PC were syspreped but without any ties to the Xen enviroment.  I have verified that the bios time and the VM times are in sync within a minute or two, but am at a loss why this issue is popping.

    Wednesday, June 20, 2012 3:51 AM
  • In the GPO's you can set registry key values directly.  This is what I did to resolve the GPO issue.  Had the same issue as you are and this was my quick resolution to that.

    Christopher C. Denny

    Wednesday, June 20, 2012 3:55 AM
  • This only happened on a couple users and for some reason a restart fixed it.

    Wednesday, June 20, 2012 12:35 PM
  • Any resolution on this?  Same issue, GPO appears to be applied, all settings are correct.  Result, screen goes directly to lock out, never see the screensaver.

    Doh!

    Saturday, November 23, 2013 2:04 AM