Unable to add RD Virtualization host


  • Hi all

    I got a problem to add the RD virtualization host.

    I deployed RDS for test.
     -1 virtual RD Connection Broker (Windows Server 2012)
     -1 virtual RD Web Access (Windows Server 2012)
     -1 RD Virtualization host 1 (Windows Server 2012)

    Then I created Pool managed collection. worked well.

    But I add another RD virtualization host from RD Connection Broker is failed.
    "Could not add the RD Connection Broker server to the TS Virtual Desktop Server settings on the RD Virtualization host 2"

    I checked RDMS overview, there is RD Virtualization host 2. but I can't create collection or add virtual desktop.

    I also checked event viewer, found some logs below,
    (1) Error
      -Event ID:1537
        VM host [RD Virtualization host 2] is not being added to the broker or not currently running.

    (2) Error
      -Event ID:8210
         [Collection Name]:provisioninig failed. Reason:

    (3) Error
      -Event ID:2056
          The Remote Desktop Connection Broker server could not enumerate the targets for the provider named NULL from the database.
          Pooled virtual desktop collection name: NULL
          Error: Logon to the database failed

    Any ideas?


    Friday, February 07, 2014 7:39 AM

All replies

  • How exactly your setup would be ?

    You are adding another RDVH are you going to Cluster them ? Or you want to make HA Connection Broker ? Can you elaborate ?

    Sanket. J Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, February 07, 2014 2:06 PM
  • Hello Sanket,

    Thank you for reply.

    I just want to add an another RDVH.

    I have a 1 Failover cluster.(included 2 Hyper-V nodes(node1, node2)).
    I created 2 VMs(RDCB, RDWeb) on node1 and installed VDI role. RDVH is node2.
    After that, created 1 pool-managed collection. So far so good.

    But when I tried to add an another node1 for RDVH it failed.

    RDCB HA is not configured yet.(I plan to HA configure)


    Sunday, February 09, 2014 3:58 AM
  • Hi,

    Please try to add the RD Virtualization host from the Deployment Overview and see how it works.


    Jeremy Wu

    TechNet Community Support

    Sunday, February 09, 2014 3:22 PM
  • Hi Jeremy,

    Result of add the RDVH is below. (It's Japanese locale)

    Even though message has occurred like above, HONVMVDI1 is added normally.

    I think RDVH role installed successfully, but RDCB dosen't recognize HONVMVDI1.

    It's weird.


    Monday, February 10, 2014 1:52 AM