none
Win 10 Prompts for Username at Lock Screen RRS feed

  • Question

  • As far as I can remember, when locking the computer, Windows would hold the username and only require you to type in the password. I just did the upgrade to Windows 10 on my Surface Pro 3 and one other desktop PC in our organization and now we have to type in the username every time at the lock screen rather than just the password. These are domain joined machines but I don't know if that makes a difference. When locking the screen either by our screensaver lockout policy or by manually locking (Windows key + L) it just shows "Other user" and then I have to type in the username every time. Any suggestions? Thank you in advance for your time!
    Friday, July 31, 2015 5:39 PM

Answers

  • We've noticed this issue as well, exact same syptoms.

    After reading this thread however I did come across a KB article with a workaround that seems to suggest this is intended and to go back to the behaviour from previous versions of windows we should disable Fast User Switching:

    https://support.microsoft.com/en-us/kb/3082141

    A little annoying to have to remove another feature to bodge the behaviour we'd prefer but at least its a bit of a better trade off (I know I lock my machine far far more frequently that I use Fast User Switching).

    • Proposed as answer by Marc3742 Monday, August 17, 2015 9:33 AM
    • Marked as answer by Scott_42 Monday, August 17, 2015 3:40 PM
    Monday, August 17, 2015 9:32 AM

All replies

  • Hi,

    Based on your description, your issue is most probably caused by "Do not display last user name in logon screen " group policy.

    Please check if you enable this policy.

    1. Navigate to this path

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options

    2. Find Interactive logon: Do not display last user name entry, double click it to make sure it's disabled.

    3. Run gpupdate /force command to apply this changes.

    4. Lock the computer to check the result.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 3, 2015 8:13 AM
    Moderator
  • I will check in on this but if this is what is causing this to happen then how come I don't have this issue with any other versions of Windows and I also did not have this issue on the same device with the same GP prior to upgrading...

    • Edited by Scott_42 Monday, August 3, 2015 1:11 PM
    Monday, August 3, 2015 1:10 PM
  • We are having the same issue.  Doesn't happen on Windows 7 or 8.1.  Forcing people to type their username and password to unlock = user revolt.  The monitor also shuts off after one minute when locked no matter what the power settings are.
    Tuesday, August 4, 2015 7:52 PM
  • Well, I'm glad I'm not the only one. Good catch on the monitor shut off too. I hadn't actually noticed that but you're right, there seems to be no way to work around either issue through power options or group policy that I have been able to find yet (I'll post if I do when I get a chance to do some more thorough testing). I don't generally like to be nitpicky about things but I agree that releasing this upon our users would have a horrible impact.
    • Edited by Scott_42 Tuesday, August 4, 2015 9:34 PM
    Tuesday, August 4, 2015 9:32 PM
  • and annoyingly, the GPO which you think would "fix" this, "Interactive logon: Display user information when the session is locked"....does nothing :(
    Friday, August 7, 2015 12:03 AM
  • Hi,

    Have you checked that?

    Base on my test. My domain Windows 10 computer also only show "Other user" after locking current user.

    I checked that group policy, yes, it's set as "Enable".

    After change it to "Disable", the username is back on my lock screen.

    In addition, you could contact your IT admin to see if this setting is configured on the AD side.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Karen HuModerator Tuesday, August 11, 2015 7:27 AM
    • Unproposed as answer by Scott_42 Tuesday, August 11, 2015 9:45 PM
    Tuesday, August 11, 2015 7:26 AM
    Moderator
  • I'm not sure which policy you are talking about.  The 'Interactive logon: Display user information when the session is locked' policy that Stuart is talking about does not have 'enable' or 'disable' options.  You can check a box that says 'Define this policy setting'.  Then you get three options;

    User display name, domain and user names 

    User display name only

    Do not display user information

    None of these options makes a difference with Windows 10.  No matter which one I select, the lock screen still says 'Other user' and forces me to enter my username and password.  Perhaps you could share exactly which group policy you are setting to 'disable' that worked for you.

    Oh yeah, and the screen still shuts off after 1 minute.  Haven't figured that one out either.


    • Edited by Sean Te_ Tuesday, August 11, 2015 6:50 PM
    Tuesday, August 11, 2015 6:40 PM
  • I just did a test on a fresh Windows 10 machine off of our domain. Here are the results:

    1. By default, the last username is always displayed (persists through reboots and lock screen).

    2. Enabling GPO "Interactive logon: Do not display last user name" causes the behavior we're seeing ("Other user" appears and it is required to type in username and password).

    3. Disabling GPO "Interactive logon: Do not display last user name" allows username to persist through locking and rebooting.

    4. Altering "Interactive Logon: Display user information when the session is locked" in any way makes no difference no matter which option you select.

    It appears to me that Microsoft may have merged the logon screen with the lock screen and now enabling "Interactive logon: Do not display last user name" affects both instead of just the logon screen (such as initial logon screen after a reboot). With the previous versions of Windows, only the logon screen was affected by this policy and NOT the lock screen.

    Please let me know if anyone else comes to the same conclusion or has different results. It is unfortunate that there appears to be no solution at this time.

    For me, disabling the GPO "Interactive logon: Do not display last user name" is not an option because our security policy prohibits us from caching usernames to persist across reboots (but it is okay for the lock screen). Up until Windows 10, the logon and lock screens have always behaved as desired (separately) with the aforementioned policy enabled.

    Tuesday, August 11, 2015 9:42 PM
  • I believe Karen is referring to "Interactive logon: Do not display last user name" (Karen, please correct me if I'm wrong) but see my test results I posted in response. I also still do not have anything that changes the one minute screen sleep either but I will see if I can come up with some testing for that. Let me know what you think.
    Tuesday, August 11, 2015 9:45 PM
  • I did some tests and had the exact same results as Scott.  We, also, cannot disable "Interactive logon: Do not display last user name" because of our security policy.  I don't remember having this issue with the technical preview that I tested otherwise I would have submitted this to Microsoft as something that needs to be changed.

    As for the one minute screen timeout, I had the same problem with Windows 8.1.  In that case, I found out about a registry key that exposes the setting "Console lock display off timeout" in the "Changed advanced power settings" menu under "Display".  If you don't add this particular registry key you don't see that setting.  The default value for this timeout is one minute (WTF??)  If I set it to 0 it effectively ignored this setting.  However, changing it in Windows 10 has no effect (I'm seeing a pattern here...).  Here is the original article I found about the issue in 8.1

    http://www.eightforums.com/tutorials/8267-power-options-add-console-lock-display-off-timeout.html

    Wednesday, August 12, 2015 2:56 PM
  • For me, disabling the GPO "Interactive logon: Do not display last user name" is not an option because our security policy prohibits us from caching usernames to persist across reboots (but it is okay for the lock screen). Up until Windows 10, the logon and lock screens have always behaved as desired (separately) with the aforementioned policy enabled.

    If so, this might be your domain policy cause.

    Please remove this computer from the domain to check the result.

    Since my Windows 10 lab machines, either domain joined or workgroup didn't have this issue.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Monday, August 17, 2015 9:14 AM
    Moderator
  • We've noticed this issue as well, exact same syptoms.

    After reading this thread however I did come across a KB article with a workaround that seems to suggest this is intended and to go back to the behaviour from previous versions of windows we should disable Fast User Switching:

    https://support.microsoft.com/en-us/kb/3082141

    A little annoying to have to remove another feature to bodge the behaviour we'd prefer but at least its a bit of a better trade off (I know I lock my machine far far more frequently that I use Fast User Switching).

    • Proposed as answer by Marc3742 Monday, August 17, 2015 9:33 AM
    • Marked as answer by Scott_42 Monday, August 17, 2015 3:40 PM
    Monday, August 17, 2015 9:32 AM
  • Well I guess that about confirms it. I've managed to muster up some settings with results that come about as close as possible to what it was before:

    Interactive logon: Do not display last username Enabled
    Interactive logon: Display user information when the session is locked User display name, domain and user names
    Hide entry points for Fast User Switching Enabled

    These specific settings produce the following results:

    1. Username does not persist across reboots
    2. Username is displayed on lock screen
    3. Fast user switching is no longer an option

    So yes, there is a trade-off if multiple users share a workstation (which is common for my organization). If you want it to present the username from the lock screen and if another user needs to log in but the previous user has left for the day, the new user must reboot the workstation to log in.

    I suppose from a security standpoint, it would be better to just leave it so it never remembers the username. It also trades the step of choosing to "Switch user" from the lock screen for typing in a new username. It's just inconvenient for users that lock the screen and need to log back in (especially since we have to enforce automatic lockout after a certain amount of inactivity). Maybe this is where Microsoft is coming from, to increase security for fast user switching or change the step for switching users, but no matter which way you look at it, whether you want to keep the username at the lock screen or not, it's going to be a new hassle and training for the end users for many organizations. Also, if you choose not to present the username at the lock screen with fast user switching disabled, only the logged in user can unlock it (even though it allows to type in a different username). This could be confusing for many people but would at least prevent them from accidentally locking out another user's account (this may be old news for many of you).

    However, Marc's solution is acceptable for cases in which a user has a personal desktop, laptop, tablet, etc... where fast user switching is not necessary. Thank you for the info, Marc! I hadn't come across that article yet but it appears that for now at least, unless Microsoft pushes out an update to change the behavior, this is how it is.

    Any further thoughts? Otherwise, I am now accepting Marc's response as the accepted solution.






    • Edited by Scott_42 Monday, August 17, 2015 3:53 PM
    Monday, August 17, 2015 3:40 PM
  • I was actually referring to written security policy as opposed to a GPO (a company IT SOP) that prohibits us from caching usernames to persist across reboots. I have already confirmed the GPO's that are causing this to happen. Please see Marc's post and my response to it below.

    Thanks!

    Monday, August 17, 2015 3:43 PM
  • I Enabled the disabling of Fast User Switching based on this article.  Worked like a charm.

    http://www.addictivetips.com/windows-tips/how-to-enabledisable-fast-user-switching-in-windows-8/

    • Proposed as answer by Chris Wilkes Tuesday, September 8, 2015 1:04 AM
    Thursday, August 20, 2015 3:42 PM
  • Enabling the "Hide entry points for Fast User switching" worked for us as well.  Not exactly ideal since our desktop techs use it on a regular basis.  But for those of us testing Windows 10 who don't need the option it works for now.

    On a side note, I found a workaround for the lock screen one minute timeout problem.  If you set your lock screen to 'slideshow' and have at least two pictures in the folder it is pointing to (requirement or slideshow won't work) it no longer shuts off the monitor after one minute when locked.  In fact, there is now an 'Advanced Slideshow Settings' menu available that gives you screen timeout options of 30 minutes, 1 hour, 3 hours, or never.  I don't know if these options can be set by group policy, but for now it allows those of us testing Windows 10 to avoid the annoying one minute timeout issue.

    Thursday, August 27, 2015 2:35 PM
  • I know this is kind of an old post now and this may be old news, but the recent November update for Windows 10 seems to have fixed this issue. Without doing any workarounds the user switching and lock screen once again have the desired, expected behavior as in the past versions of Windows.
    • Edited by Scott_42 Monday, December 21, 2015 7:06 PM
    Monday, December 21, 2015 7:06 PM
  • I prefer that it ask for the user name as well. A security issue arises after restarting and by habit I type the password first. Windows will then save the password in the event log!
    Tuesday, May 10, 2016 1:55 PM
  • My issue was exactly this policy, thanks a lot.

    Regards.

    Wednesday, June 22, 2016 3:43 AM
  • this is only solution that worked for me :* <3 other suggested solutions were useless
    Sunday, October 22, 2017 9:00 PM