locked
Unable to change a password via web RRS feed

  • Question

  • Hi All,

    OS:2003

    Exchange server :2003

    http://mail.abc.com/exchange/

    options - change password - "The page cannot be displayed" massage appears.

    Workaround : IISPWADMIN , But failed to trouble shoot need expert help to overcome with this problem.

    similar pwd problem like below link:

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/f2beed08-c111-441c-8099-b745720e06ed

    Regard's

    Akif

    Sunday, April 3, 2011 8:51 AM

All replies

  • So the issue is, “The page cannot be displayed” appears when user clicks the “Change Password” option after set up the “IISPWADMIN”. Please correct me if I’ve misunderstood the issue

    Quote: “similar pwd problem like below link”

    So, there’re multiple OWA virtual directories or website in the link that you provided?

    Have you checked the steps in the “Troubleshooting” section in KB 297121?

    Please check the related traces in the IIS log after reproduced the issue

    Resources:

    OWA password change displays %iis.REMOTE_USER% in account field

    James Luo

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, April 4, 2011 9:58 AM
  • Hello,

     

    # Yes “The page cannot be displayed” appears when user clicks the “Change Password” option.

    #Added the *.htr under IISPWADMIN properties using section in KB 297121?.

    #adsutil.vbs set w3svc/passwordchangeflags<var>1  performed </var>

     

    Still the problem is not resolve, need your help to solve it.

     

    Regard's


    Tuesday, April 5, 2011 7:51 AM
  • What's in your environment.

     

    Front end and Backend.

     

    What are the permissions on the virtual directories?

    Wednesday, April 6, 2011 2:52 PM
  • Hello,

     

    OS:2003

    Exchange server :2003

    All the permissions are "Default" in nature on virtual directory.

     

    Regard's

     

    Saturday, April 9, 2011 7:16 AM
  • Implementing the Change Password feature with Outlook Web Access

    http://support.microsoft.com/kb/297121

    Please make sure your can access the change password page over HTTPS. 

    "Microsoft requires SSL on the IISADMPWD virtual directory."

     

    If you do not have a publicly trusted SSL certificate you can create a quick self-sign certificate with "SelfSSL" part of the IIS 6.0 Resource Kit

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=56fc92ee-a71a-4c73-b628-ade629c89499&displaylang=en

    Start > All Programs > IIS Resources > SelfSSL > SelfSSL

     Microsoft (R) SelfSSL Version 1.0
    Copyright (C) 2003 Microsoft Corporation. All rights reserved.

    Installs self-signed SSL certificate into IIS.
    SELFSSL [/T] [/N:cn] [/K:key size] [/S:site id] [/P:port]

    /T               Adds the self-signed certificate to "Trusted Certificates"
                     list. The local browser will trust the self-signed certificate
                     if this flag is specified.
    /N:cn            Specifies the common name of the certificate. The computer
                     name is used if not specified.
    /K:key size      Specifies the key length. Default is 1024.
    /V:validity days Specifies the validity of the certificate. Default is 7 days.
    /S:site id       Specifies the id of the site. Default is 1 (Default Site).
    /P:port          Specifies the SSL port. Default is 443.
    /Q               Quiet mode. You will not be prompted when SSL settings are
                     overwritten.

    The default behaviour is equivalent with:

    selfssl.exe /N:CN=computername /K:1024 /V:7 /S:1 /P:443

    Run:

    selfssl /N:CN=webmail.contoso.com /K:1024 /V:3650 /S:1 /P:443

    This will create a certificate for your Default Web Site valid for 10 years.  Do not run this command if you already ahve a funtional exisitng certificate as it will replace your current certificate.

     


    Tuesday, April 12, 2011 1:03 AM
  • Hi,

     

    Try to troubleshoot with above link ,SSL Certificate is valid and still problem not resolved ,

     

    Regard's

    Wednesday, April 13, 2011 6:02 AM
  • When you are testing OWA change password did you get the same behavior accessing OWA locally on the Exchange server that you setup IISADMPWD?

    Example: Try to open Internet Explorer on the server and access https://localhost/exchange

    Login to OWA and go to options and click on change password button.

    When the pop-up windows display “Internet Explorer cannot display the webpage”, Right-click on the blank area of the error page and look at the properties.  You should see a address (URL) like this:

    res://ieframe.dll/dnserrordiagoff.htm#https://localhost/iisadmpwd/aexp2b.asp?http://localhost/exchange/e2k3user/?Cmd=close

    You should see that OWA is attempting to access the page https://localhost/iisadmpwd/aexp2b.asp

    Open a new browser window on the server and try to browse to that address to see if you are able to.

    If it fails try to see if you can browse to http://localhost/iisadmpwd/aexp2b.asp

    If you only setup IISADMPWD on a back-end server and you are using a front-end server to access OWA, you will need to setup IISADMPWD so that directory is accessible to the end-user across the internet.

    -----------------------

    If you have problem accessing the change password directory try to delete it and create it again as per the instruction in KB:

    To configure the IISADMPWD virtual directory, do the following:

    1.     Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.

    2.     Right-click the default Web site, point to New, and then click Virtual Directory.

    3.     In the Virtual Directory Creation wizard, type IISADMPWD in the Alias box, and then click Next.

    4.     In the Directory box, type <hard disk>:\winnt\system32\inetsrv\iisadmpwd or the location where your hard disk is your default hard disk (Example: C:\WINDOWS\system32\inetsrv\iisadmpwd), and then click Next.

    5.     Verify that only the Read and Run script check boxes are selected, such as the ASP check box, click Next, and then click Finish.

    6.     Verify that the IISADMPWD virtual directory has only basic authentication set and, if you use Windows 2003/IIS 6.0, verify that the application pool is set to ExchangeApplicationPool.

    -------------

    If you did not check the Run script when creating IISADMPWD you may get:

    “The page cannot be displayed”

    You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.


    Please try the following:

    • Contact the Web site administrator if you believe this directory should allow execute access.

    HTTP Error 403.1 - Forbidden: Execute access is denied.
    Internet Information Services (IIS)


    ----

    Wednesday, April 13, 2011 10:36 AM
  • Hi,

    I appreciate your valuable input , kind find below error details, Planning to delete IISADMPWD and create it again. 

    res://C:\WINDOWS\system32\xpsp3res.dll/dnserror.htm#https://mail.abc-d.com/iisadmpwd/aexp2b.asp?http://mail.abcd.com/exchange/xyz.user/?Cmd=close


    http://mail.abcd.com/iisadmpwd/aexp2b.asp

    #When i try to browse above .asp below error occur.


    HTTP/1.1 503 Service Unavailable

     

    Regard's

    Wednesday, April 13, 2011 10:50 AM
  • If you get 503 “Service Unavailable” the Application Pool for your IISADMPWD may be stopped.

    ---------

    6.        Verify that the IISADMPWD virtual directory has only basic authentication set and, if you use Windows 2003/IIS 6.0, verify that the application pool is set to ExchangeApplicationPool.

     --------

    The KB also specifies that the IISADMPWD should be set to ExchangeApplicationPool, and since your OWA is working your ExchangeApplicationPool is working.

    Maybe your DefaultAppPools is stopped, and your IISADMPWD is set to use (by default) the DefaultAppPools.

    Wednesday, April 13, 2011 11:07 AM
  • Hello,

     

    I created  IISADMPWD under "Default web site" aexp2b.asp can browse from the server , But unable to open http://mail.abcd.com/iisadmpwd/aexp2b.asp.

     

    One more IISADMPWD under "Exchange virtual server" , I can not browse from server as well as from web.

     

    Need an expert advice to resolve this issue .....

     

    Regard's


    Saturday, April 16, 2011 8:04 AM
  • Any valuable input to resolve this issue appreciated ............

     

    the iisadmpwd virtual folder properties, select configure in the application settings area of the virtual directory tab, and remove the davex.dll.

    The IISADMPWD deleted and re-created.

     

    Still unable to solve the issue.

     

    now the status is:

     

    res://C:\WINDOWS\system32\xpsp3res.dll/dnserror.htm#https://mail.abc-d.com/iisadmpwd/aexp2b.asp?http://mail.abc-d.com/exchange/xyz.user?Cmd=close

     

    Again when i try to access:

    #When i try to browse aexp2b.asp below error occur.

    The page cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

     

     

    Have a lovely day to all ......

     

    Regard's

     


    Monday, April 18, 2011 10:00 AM
  • It sounds like you are attempting to setup IISADMPWD on an Exchange back-end cluster under the Exchange Virtual Server website…

    The Exchange virtual Server website is only accessible when using the Exchange cluster IP.

    Please setup IISADMPWD on the Exchange front-end server’s Default Web Site instead of the back-end.

    http://support.microsoft.com/kb/297121

    Note The steps are the same for clustered Exchange servers. When front-end servers are in use with an Exchange cluster, no configuration is necessary on the cluster itself.

    Monday, April 18, 2011 12:19 PM
  • Hello Jhon,

     

    I need remote help from microsoft to resolve this issue, Can you guide me about the process , My management updated me with Volume license only not active id , how to get it if needed.

     

    Thanks a lot!

     


    Tuesday, April 19, 2011 7:47 AM
  • Your request for remote help falls into the paid support category which requires a more in-depth level of support.  Please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Tuesday, April 19, 2011 10:31 AM