none
Can't send a Wake on LAN packet from Windows 10 PC RRS feed

  • Question

  • I have a dual boot PC - Win 7 Pro and Win 10 Pro. I also have a linux-based file server that I need to wake from standby for regular backups.

    With Win 7 I can use one of the many WOL programs to wake the file server, and it's then just another accessible network device.

    If I boot into Win 10, however, the server never receives a WOL packet from the PC. If I start up the server separately, it is then accessible to the Win 10 PC exactly as for Win 7.

    Another Win 10 PC on my network works perfectly.

    Any ideas, please? Note: I am not trying to wake the Windows PC, just using it to send a WOL packet to the server.

    Thursday, August 13, 2015 10:07 AM

Answers

  • Yes, you've understood correctly.

    I'm pleased to say that the problem has not yet been solved, but I have managed to avoid it.

    For many years I have been using a program called wakeup.exe, origin unknown, dated 2007, with no problems. When the W10 issue arose I tried a few other command-line WOL programs but all had the same result. I have just tried another, called WolCmd.exe, from Digital Wired Limited, 2005, and this one works perfectly.

    So thanks for your responses, and I'll get on with my life, as I have no great desire to get into network packet sniffing.

    Friday, August 14, 2015 9:08 PM

All replies

  • Have you made an exception for your program in the Windows Firewall?
    Thursday, August 13, 2015 4:02 PM
  • Yes, I tried that, although it shouldn't make a difference as the default behaviour is to allow all outbound unless explicitly blocked.

    On the Win 7 boot, and on the other Win 10 PC, I didn't make any special changes to the firewall.

    Thursday, August 13, 2015 5:02 PM
  • Hi cjn01,

    First of all, please ensure the machine has got the latest updates.

    Since another Windows 10 could work well, it may be related to the specific application`s configuration.

    We could try to disable the firewall and the antivirus software temporarily to have a troubleshoot.

    Considering you are working with a third party programs and we are lack of resources to configure the program. It is recommended to ask for help from the third party support.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Friday, August 14, 2015 7:55 AM
    Moderator
  • Thanks for the suggestions. I have already worked my way through all those, apart from the last one.
    Friday, August 14, 2015 8:16 AM
  • Ok so I understand.

    PC1 is dual-boot 7/10 and when using 10 cannot wake the Linux PC.
    PC2 is Win10 and is able to wake the Linux PC.

    Presuming this is correct, I would recommend that you monitor the network interface on PC2, then send the wake packet to the Linux. Capture the entire transaction. This will let you have a trace where the process is working correctly.

    Then do the same on PC1 and then compare the two.

    Also, check in any of the advanced Event Viewer logs to see if there is anything mentioned in there.

    Friday, August 14, 2015 4:01 PM
  • Yes, you've understood correctly.

    I'm pleased to say that the problem has not yet been solved, but I have managed to avoid it.

    For many years I have been using a program called wakeup.exe, origin unknown, dated 2007, with no problems. When the W10 issue arose I tried a few other command-line WOL programs but all had the same result. I have just tried another, called WolCmd.exe, from Digital Wired Limited, 2005, and this one works perfectly.

    So thanks for your responses, and I'll get on with my life, as I have no great desire to get into network packet sniffing.

    Friday, August 14, 2015 9:08 PM
  • WolCmd.exe found on depicus web site which looks like the one described above does not work on my Windows 10 device.

    weirdest thing WolCmd and wol.exe are working inside VirtualBox running Windows 7 hosted on the same Windows 10 device, so it's not a firewall or ethernet driver issue

    the problem seems to originate from the arp table on Windows 10: when the ip+mac are deleted by the system, both programs failed to wake to target device, weather mac only or mac+ip+mask are specified

    imho, a recent fix, probably security one, caused the problem

    please fix asap





    • Edited by flic1 Monday, October 10, 2016 5:12 PM
    Monday, October 10, 2016 12:11 AM
  • I experience the same issue. Any solution yet?

    Best regards, Patrick http://www.klangexzellenz.de

    Monday, April 17, 2017 5:36 PM
  • Very annoying.  Same issue here.   I can sent wol commands from one of my windows 10 systems to wake up my linux box,  but I cannot do the same from another window 10 system.  I can't tell what is causing this.  
    Friday, April 28, 2017 2:07 AM
  • I had the same issue: I was able to wake-on-LAN other PCs from one Windows 10 machine but failed to do so on a second Windows 10 machine.

    It turns out that VirtualBox was the culprit.

    When you install or update VirtualBox, it creates one or multiple virtual network adapters (e.g., “VirtualBox Host-Only Ethernet Adapter”). And it could very well be that other virtualization solutions do the same.

    When I disabled these virtual network adapters (Device Manager => Network Adapters), sending magic packets for wake-on-LAN was possible again using the second computer.

    • Edited by Holy G Monday, December 11, 2017 5:39 PM
    • Proposed as answer by Dequester Tuesday, April 10, 2018 6:48 AM
    Monday, December 11, 2017 5:37 PM
  • I had the same issue: I was able to wake-on-LAN other PCs from one Windows 10 machine but failed to do so on a second Windows 10 machine.

    It turns out that VirtualBox was the culprit.

    When you install or update VirtualBox, it creates one or multiple virtual network adapters (e.g., “VirtualBox Host-Only Ethernet Adapter”). And it could very well be that other virtualization solutions do the same.

    When I disabled these virtual network adapters (Device Manager => Network Adapters), sending magic packets for wake-on-LAN was possible again using the second compute

    In my case disabling Hyper-V Virtual Ethernet Adapter did the trick!

    • Proposed as answer by Dequester Tuesday, April 10, 2018 6:47 AM
    • Unproposed as answer by Dequester Tuesday, April 10, 2018 6:48 AM
    Wednesday, January 24, 2018 8:04 AM
  • I had this problem after Windows 10 installed some updates. After wasting a good 4 hrs, I found the solution here: https://www.nirsoft.net/utils/wake_on_lan.html

    "On some Windows 10/8 systems, the Wake-Up feature doesn't work if the 'Send The Wake-on-LAN Packet To...' option is set to 'Broadcast Address 255.255.255.255'. If you have this problem, you should set this option to 'Broadcast Address According to IP Address'."

    So in Aquila WakeOnLan (what I use), the solution is to Send WOL to FQDN/IP

    • Proposed as answer by bvrulez Friday, November 9, 2018 12:18 PM
    Thursday, May 10, 2018 8:02 AM
  • This is the right answer! I had the same troubles on two Windows 10 machines (a PC and a laptop). Since I updated them suddenly WOL did not work any more. Changing Broadcast to IP immediately fixed it. 

    Also, it is very annoying that the one answer that is marked as correct here is actually not even an answer!!! But overall this pretty much represents Microsofts behaviour in general.
    Friday, November 9, 2018 12:21 PM