none
Windows 8: After deploying background (GPO) after login black screen. (VDI)

    Question

  • Im having a problem i hope you guys can help me with.

    In the company we got a VDI-setup for zero-clients.

    OS: windows 8

    The management decided that everyone should get the same desktop background. (Localized on a central share. User can open and modify picture)

    In the GPO it is set as a background (\\company\map\picture)

    Even tried updating registry after this didnt work (add the desktop value with the same path to the file)

    Tried another share where other (working) scripts are. Same issue there.

    After some looking around i discovered trough Settings / ease of access / more options a button that says Show Windows Background. After turning it off and on the wallpaper gets applied... but after logoff/login its black again.. and i need to do the same action again. Since i dont want to do that for 250+ users every time they login im looking for a permanent solution for this.

    Anyone having an idea?


    Tuesday, February 23, 2016 3:27 PM

Answers

  • Problem found.

    Solution:

    I deployed the same policy to a new VDI pool. And guess what. it did work there. Not a hour later i couldnt login the vdi pool that was having the problem. While building the image i found out that in the VMware OS Optimization Tool is an option for not showing the background etc. This option was turned ON. So i guess the whole problem was in that 1 little option. Windows 8 was optimized for not showing background so it dissapeared. 

    So after the new image the background also worked on this VDI pool. 

    Thanks for helping all of you. Case closed.

     

    Tuesday, March 08, 2016 2:47 PM

All replies

  • > In the GPO it is set as a background (\\company\map\picture)
     
    Copy the file to a local path and define this local path in your GPO.
    Will additionally speed up loading the desktop :)
     
    Tuesday, February 23, 2016 4:44 PM
  • Hi,

    Have you configured “Prevent change wallpaper” in GPO?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 24, 2016 8:01 AM
    Moderator
  • Hi,

    Have you configured “Prevent change wallpaper” in GPO?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Yes in the same GPO so user cannot change it to something else.. or is that the whole issue that then even the system cannot change it?
    Wednesday, February 24, 2016 11:57 AM
  • > In the GPO it is set as a background (\\company\map\picture)
     
    Copy the file to a local path and define this local path in your GPO.
    Will additionally speed up loading the desktop :)
     
    A local path is in our case not an option. Long story but its a no go.
    Wednesday, February 24, 2016 11:57 AM
  • > A local path is in our case not an option. Long story but its a no go.
     
    Curious about that story...
     
    Anyway: "Always wait for the network at startup and logon" already
    enabled? Spanning Tree on switches configured for fastopen/portfast?
    Maximum wait time for group policy processing set to 45 or 60 seconds?
     
    Wednesday, February 24, 2016 12:46 PM
  • OK tried the following things:

    - Aways wait for the network at startup and logon turned on -> No solution. Still black. After the showing background button the background is right. after logoff login its gone again.

    - Turned off the "prevent change wallpaper"  -> No solution. Same problem.

    - Login script with the change wallpaper -> no succes

    -Downloaded the VDI GPO bundle. There was a policy stating "Show desktop background" wich i turned on. Still no succes.

    Weird thing is that in "Start" - "Desktop" the picture is shown as a background. But when clicking the desktop it doesnt show. Refreshing desktop doesnt work either. Only thing that does work is turn off / on the windows background.

    EDIT: Problem exsists on zero clients and on laptops running VM Horizon view.



    Wednesday, February 24, 2016 1:17 PM
  • Hi,

    I suggest you run GPresult /h <file path> and post it to us for further research.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, February 25, 2016 5:29 AM
    Moderator
  • Its all in dutch.. would that be a problem?

    If i look trough the gpresult i see it does get applied (again: it is showing in the start menu and in the personalisation part.. its showing everywhere except the desktop itself.

    I found this as a POSSIBLE solution for the issue:

    This issue occurs because you have excluded the following folder from the roaming profile:

    AppData\Roaming\Microsoft\Windows

     

    Add this path to the Directories to Synchronize

    -

     

    There is a file called Transcoded wallpaper inside the above path and it is the jpg with blue background that Windows 7 requires for the desktop.

    Ive been looking into this.. but appdata is already being redirected to the homefolder. At least the AppData (roaming). 

    Part of the GPO:

    Mapomleidingverbergen
    Afbeeldingenweergeven
    Instelling: gebruik de map Documenten
    AppData(Zwerven)verbergen
    Instelling: Standaard (Alle mappen naar dezelfde locatie omleiden)verbergen
    Pad: \\**\dfs\***-RDFolders\%USERNAME%\Application Data
    Optiesverbergen
    Exclusieve rechten aan gebruiker toekennen voor AppData(Zwerven) Uitgeschakeld
    Inhoud van AppData(Zwerven) naar de nieuwe locatie verplaatsen Uitgeschakeld
    Omleidingsbeleid ook toepassen op de besturingssystemen Windows 2000, Windows 2000 Server, Windows XP en Windows Server 2003. Ingeschakeld
    Werking van beleidsverwijdering Inhoud laten staan
    Configuratiebeheer Groepsbeleid
    Evaluatie van primaire computer Niet geëvalueerd omdat beleid van primaire computer niet is ingeschakeld

    The ** is company name/initials. the path seems to be right.

    I did hear from a VDI user if he switches from virtual machine the settings go away (example: Yesterday he was on VDI machine Laptop1. Today he logs in on Laptop2. All his settings are gone (outlook archive maps and win8 start menu layout) While the machines are configured to be floating  and made from 1 image.....

    Thursday, February 25, 2016 8:14 AM
  • Hi,

    I noticed that the GPO is applied when you turn off the Show Windows Back ground.

    Would you mind telling me where did you set the option?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 26, 2016 3:01 AM
    Moderator
  • turn off and on... 

    that happens when i put my mouse near the clock and the extra menu pops up.. 

    http://www.bleepstatic.com/tutorials/windows-8/pc-settings-screen/settings-charm-bar.jpg

    Click the change pc settings and ease of access => more options

    there are at the top 2 sliders 1 about animations and 1 about background. If i slide the background off and on.. it works.

    I've been trying a few things now.. and i'm out of options now. I wonder if theres a script or something for that wich i can run at startup to do the same thing. 

    Friday, February 26, 2016 9:33 AM
  • Hi,

    If you want deploy wallpaper by script, you could refer to similar threads below.

    https://social.technet.microsoft.com/Forums/scriptcenter/en-US/b19a1d11-7ad4-4ee6-9ae8-c1ec7d3702a7/script-to-change-logon-wallpaper-on-windows-xp-and-7-?forum=ITCG

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/6355ea5b-ac34-4840-82e5-6641da3640e2/change-and-customize-windows-7-logon-screen-wallpaper-script?forum=ITCG

    But I suggest you deploy wallpaper by group policy.

    Best Regards,

    jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 01, 2016 5:44 AM
    Moderator
  • Ill look into the scripting thing. Ive tried such a thing before wich didnt work. 

    Ill get back on this after the weekend (vacation yay)

    Wednesday, March 02, 2016 1:53 PM
  • Problem found.

    Solution:

    I deployed the same policy to a new VDI pool. And guess what. it did work there. Not a hour later i couldnt login the vdi pool that was having the problem. While building the image i found out that in the VMware OS Optimization Tool is an option for not showing the background etc. This option was turned ON. So i guess the whole problem was in that 1 little option. Windows 8 was optimized for not showing background so it dissapeared. 

    So after the new image the background also worked on this VDI pool. 

    Thanks for helping all of you. Case closed.

     

    Tuesday, March 08, 2016 2:47 PM