locked
error when adding Exchange mailbox server RRS feed

  • Question

  • pls see below

     

    Summary: 3 item(s). 1 succeeded, 1 failed.
    Elapsed time: 00:03:41


    Preparing Setup
    Completed

    Elapsed Time: 00:00:00


    Mailbox Role
    Failed

    Error:
    The following error was generated when "$error.Clear();
              if ($RoleIsDatacenter -ne $true)
              {
                if (test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
                {
                  # upgrade the discovery mailboxes to R5 version, this will fix the RecipientDisplayType property of the discovery mailbox which was wrong in R4.
                  get-mailbox -RecipientTypeDetails DiscoveryMailbox -DomainController $RoleDomainController | where {$_.IsValid -eq $false} | set-mailbox -DomainController $RoleDomainController
                  $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
                  $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
                  $mbxs = @( get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1 );
                  if ( $mbxs.length -eq 0)
                  {
                    $dbs = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
                    if($dbs.Length -ne 0)
                    {
                      $mbxUser = @(get-user -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
                      if ($mbxUser.Length -ne 0)
                      {
                        enable-mailbox -Discovery -identity $mbxUser[0] -DisplayName $dispname -database $dbs[0].Identity;
                      }
                    }
                  }
                }
                else
                {
                  write-exchangesetuplog -info "Skipping creating Discovery Search Mailbox because of insufficient permission."
                } 
              }
            " was run: "Database is mandatory on UserMailbox. Property Name: Database".

    Database is mandatory on UserMailbox. Property Name: Database
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp

    Error:
    The following error was generated when "$error.Clear();
              if ($RoleIsDatacenter -ne $true)
              {
                if (test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
                {
                  # upgrade the discovery mailboxes to R5 version, this will fix the RecipientDisplayType property of the discovery mailbox which was wrong in R4.
                  get-mailbox -RecipientTypeDetails DiscoveryMailbox -DomainController $RoleDomainController | where {$_.IsValid -eq $false} | set-mailbox -DomainController $RoleDomainController
                  $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
                  $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
                  $mbxs = @( get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1 );
                  if ( $mbxs.length -eq 0)
                  {
                    $dbs = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
                    if($dbs.Length -ne 0)
                    {
                      $mbxUser = @(get-user -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
                      if ($mbxUser.Length -ne 0)
                      {
                        enable-mailbox -Discovery -identity $mbxUser[0] -DisplayName $dispname -database $dbs[0].Identity;
                      }
                    }
                  }
                }
                else
                {
                  write-exchangesetuplog -info "Skipping creating Discovery Search Mailbox because of insufficient permission."
                } 
              }
            " was run: "Database is mandatory on UserMailbox. Property Name: Database".

    Database is mandatory on UserMailbox. Property Name: Database
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp

    Elapsed Time: 00:03:41


    Finalizing Setup
    Cancelled



    Tuesday, December 28, 2010 7:40 PM

Answers

  • Did you run setup /prepareschema and /preparead?

    Open up ADSIEDIT.msc and locate the FedaretedMailbox (CN=FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042), go to the properties of that mailbox and locate the following attribute homeMDB. If it is empty or an incorrect value in it then populate the value with an existing database. The mailbox is located under the default users container.

    Or you can always delete the mailbox and re-run the setup /preparead this will recreate the mailbox.


    MCITP: Enterprise / Server Administrator | MCITP: Enterprise Messaging Administrator 2007/2010 | MCP | MCDST
    • Marked as answer by acmsoft Wednesday, December 29, 2010 5:18 AM
    Tuesday, December 28, 2010 9:30 PM
  • Does the ExBPA run clean?  Are you using the Discovery Mailbox?  My guess is that there is an attribute missing on the Discover Mailbox (like homeMTA or homeMDB within ADSIEdit).  If they are missing you will need to fix those values (you can look at those value from your other system mailboxes).  Or you can delete the Discovery Mailbox and recreate it:

    http://technet.microsoft.com/en-us/library/dd638177.aspx

    EDIT:  Tom beat me to the punch :)  same idea.


    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    • Marked as answer by acmsoft Wednesday, December 29, 2010 5:18 AM
    Tuesday, December 28, 2010 9:33 PM

All replies

  • Did you run setup /prepareschema and /preparead?

    Open up ADSIEDIT.msc and locate the FedaretedMailbox (CN=FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042), go to the properties of that mailbox and locate the following attribute homeMDB. If it is empty or an incorrect value in it then populate the value with an existing database. The mailbox is located under the default users container.

    Or you can always delete the mailbox and re-run the setup /preparead this will recreate the mailbox.


    MCITP: Enterprise / Server Administrator | MCITP: Enterprise Messaging Administrator 2007/2010 | MCP | MCDST
    • Marked as answer by acmsoft Wednesday, December 29, 2010 5:18 AM
    Tuesday, December 28, 2010 9:30 PM
  • Does the ExBPA run clean?  Are you using the Discovery Mailbox?  My guess is that there is an attribute missing on the Discover Mailbox (like homeMTA or homeMDB within ADSIEdit).  If they are missing you will need to fix those values (you can look at those value from your other system mailboxes).  Or you can delete the Discovery Mailbox and recreate it:

    http://technet.microsoft.com/en-us/library/dd638177.aspx

    EDIT:  Tom beat me to the punch :)  same idea.


    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    • Marked as answer by acmsoft Wednesday, December 29, 2010 5:18 AM
    Tuesday, December 28, 2010 9:33 PM
  • great it worked thank you both of you
    Wednesday, December 29, 2010 5:18 AM
  • I am having a similar problem to the OP. I'm installing 2x Hub, 2xMail, 2xCAS.  My HUBS install correctly.  When I try to install a mail server, it gives me the long, coded error that OP received.

     

    As for your response, I cannot find the Federated Mailbox anywhere in ADSI.  I did, however, try both /prepareschema /hosting, and /preparead /hosting, both of which ran successfully.  I cannot get anything but the Hub roles to install successfully...

    Friday, January 7, 2011 8:02 PM
  • Please see my reply to Tom!
    Friday, January 7, 2011 8:02 PM