locked
IE auto-login on intranet or domain-bound system but on external network, it keeps prompting password again and again RRS feed

  • Question

  • When I try to login to ADFS using IE on a domain-bound system, it auto login and redirect to the website.

    However, if I try to login from external network, IE keeps asking for password.

    Login from Chrome works no matter from where I try to login.

    So, it is not like IE login completely does not work for me but it only works on internal network.

    Any idea on what is going wrong here?

    Wednesday, July 31, 2019 10:55 PM

Answers

  • We started receiving complaints from the users in local network as well who used domain-bound systems.

    After more research, this issue turned out to be caused by ESET anti virus on client's machine. Once I added SSL certificate for ADFS site in list of known certificate in ESET, the login on client's machine started working.

    Ref: http://support.eset.com/kb7241/

    Friday, August 2, 2019 3:59 PM

All replies

  • Hiya,

    Try the following:

    Clear all cookies and open IE inPrivate browsing mode and see how it behaves.

    The only difference between the two scenarios is that IE has the site located in "Local Intranet" zone, which allows automatic login. So I presume that could be causing some problems with on external network.

    Friday, August 2, 2019 8:36 AM
  • By the way, if by External Network you mean over the internet, the authentication attempt should go through a Web Application Proxy (ADFS Proxy). You do not mention a WAP in your infra, do you have any?

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Friday, August 2, 2019 1:16 PM
  • We started receiving complaints from the users in local network as well who used domain-bound systems.

    After more research, this issue turned out to be caused by ESET anti virus on client's machine. Once I added SSL certificate for ADFS site in list of known certificate in ESET, the login on client's machine started working.

    Ref: http://support.eset.com/kb7241/

    Friday, August 2, 2019 3:59 PM