locked
Hyper-v ERROR while creating an external virtual switch: Switch create failed, the system cannot find the file specified RRS feed

  • Question

  • Hello, i am facing a weird problem.

    I just installed HYPERV role on a new server, i chose the NIC for the Virtual switch while installing, installation complete.

    Went in the HYPERV management console, no switch is created.

    So i decided to create it myself, BUT whenever i try to create this new external switch, through the chosen network card, all i get is the error attached 

    I tried everything:

    i removed hyper v then installed it again.

    i removed the network card and installed it again.

    i tried creating the VS on another network card, they all lead to the same error!

    I am starting to lose hope here.

    i have a feeling that this is something related to the registry.

    i did all my research on the internet no one seems to have an answer.

    Friday, February 23, 2018 11:46 AM

All replies

  • I have had the same issue - the fix was to simply delete the virtual switch and recreate it :)
    Monday, March 12, 2018 11:32 PM