none
VM's stucked starting

    Question

  • Host: Server 2008 R2

    VM's: Ubuntu 16.04.2 LTS

    Backup sw: Ahsay

    Due to host-level backup initiated by Ahsay which takes VM into saved state, backs up and tries to restore VM I ended up with 2 VM's in State Starting-Critical (one of them Status Restoring (99%), other Status Starting (10%))

    They stay stucked in these states and I have tried "everything" to stop them for wiping away, but no luck.
    Deleted Saved state didn't do anything, Cancel starting did nothing.
    Cannot kill relevant vmwp process, have tried CMD, TaskManager and SysInternals ProcessExplorer, no luck.
    Even host restart (this is production server and therefore by far without consequences) doesn't help.

    What may be done (brutally or not) to get rid of them ?

    Sunday, April 23, 2017 9:17 AM

All replies

  • Hi Sir,

    >>tries to restore VM I ended up with 2 VM's in State Starting-Critical (one of them Status Restoring (99%), other Status Starting (10%))

    >>Cannot kill relevant vmwp process

    Generally , vmwp process (corresponding vm GUID ) can be killed in taskmanager .

    Is there any error message when you delete that process ?

     

    VMWP process of that problematic VM will be listed in task manager after restart the host ?

    If yes , I'd suggest you change the VM property for "automatic start action" (then restart the host again ):

     

    If that process doesn't appear ,you may copy that VHD to other place then  create a new VM then mount the VHD of that problematic VM to see if that VHD can be used .

    If that VHD can be used then you may remove that problematic VM .

     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 25, 2017 1:33 AM
    Moderator
  • No error message if killing from TaskMan or ProcExp (Sysinternals), if taskkill from cli it says something like "no instances running"

    Both VM's were stucked starting and I used an extra VHD copy to spin up a new VM.

    Then a few hours later the host restarted itself for some strange reason which I still do not know. This was not by a controlled shutdown, more like power cycling, but the good thing is that the 2 hanging VM's did not try to start.
    For the one which had a saved state I was now able to delete the saved state and both are now clean (and dead, ready for my manual scavenging).

    I have later tried the same Linux image on a Windows 10 machine as Hyper-V host, it responded correct on both save/start, pause/resume and host restart with automatic start action (controlled this time :)), I have not tried this one with Ahsay backup.
    This latter was with Windows 10 which is a lot newer Hyper-V stack, could this explain the strange behaviour ?

    I will now try to replicate with another Server 2008 R2 host machine as lab setup and see if this one mis-behaves too.
    If possible, I will try with Ahsay for this as well and report back.

    I also tried killing the relevant vmwp for this latter VM and it works, but restarts itself (even if startup actian is nothing), why this ?


    • Edited by EuroEager Tuesday, April 25, 2017 12:17 PM
    Tuesday, April 25, 2017 12:17 PM