none
Project 2010: Duration not calculating correctly RRS feed

  • Question

  • I have an issue with a project where durations are not calculating as expected. I have used projdatediff in order to find these items. In some cases, the projdatediff calculation (which is correct) is double what shows in the duration field.  For example, Start 7/29/16 - Finish 8/18/16 shows as 7 days Duration in the schedule, but is 14 days according to projectdatediff. A lot of the items have true durations which are double what is showing, but a few are even more (80 days vs. 558 actual days). I've checked constraints, calendars, resources, project options (which are set to 8 hour days), etc.  Any thoughts?
    Wednesday, January 20, 2016 5:03 PM

All replies

  • Naomi,

    Assuming your file isn't corrupt, we'll need a little more information before we can help. Can you post a screen shot of some of the tasks? If you're not verified for posting images, please give us the task details (i.e. standard or custom calendar, auto or manual scheduled, any task splits, definition of a "day").

    Also, is your installation of Project fully updated with the latest Public Update (Dec 2015)?

    Oh, just to make sure your file is not corrupt, try saving as XML and then re-open in Project. Note, you will lose any custom formatting. Does the XML version now work okay?

    John

    Wednesday, January 20, 2016 10:30 PM
  • John,

    Thanks for your response.  I decided to check via XML first and the file appears to just hang and not open.  If I kill Project and try again, I get a message that there was a serious problem when previously opening the file.  So I assume that's the base issue. 

    Wednesday, January 20, 2016 11:45 PM
  • Naomi,

    If the XML hangs, then most assuredly, the Project file has some corruption. I had a user a while back with a similar issue, the XML wouldn't open in Project. It turned out there was a problem with the formatted text in the Notes field for one of his tasks. Once that was corrected, everything worked fine.

    If you have a recent backup copy of the file that does work properly, then you might consider starting with that and rebuilding to your current status. If not, you could try successive iterations to find where the corruption might be. One method I use is to delete half the tasks, or resources and see if that helps. If it does then you are reasonably assured that the problem was somewhere in the group of objects that were deleted. Keep iterating to narrow it down.

    Note, the XML process normally works to eliminate minor file corruption but there are a couple other things you can try. See Wiki article, http://social.technet.microsoft.com/wiki/contents/articles/32054.ms-project-clearing-file-corruption-andor-bloat.aspx.

    John

    Thursday, January 21, 2016 2:13 AM
  • Thanks.  I've already tried all three of the items in the article link.  Are you familiar with "Recovery Toolbox for Project" and whether others have had success using it?
    Thursday, January 21, 2016 6:41 PM
  • Naomi,

    Okay, at least you tried the simple procedures for recovery, sorry they didn't help.

    No I'm not familiar with "Recovery Toolbox for Project". With a quick Google search I see one review of a supposed user who thinks it's the cat's meow, but that's it. Perhaps someone else will jump in with a comment on this utility.

    John

    Thursday, January 21, 2016 7:29 PM