locked
Removing databases from Exchange DAG RRS feed

  • Question

  • Hello,

    I have four servers in my DAG.  There was a lot of whitespace in two of the databases, so I created two new ones and moved the mailboxes to them.

    Now I'd like to remove the old databases from all four servers.  Are there any best practices for this?  Or do I just remove them?

    Thanks in advance for any assistance.

    Wednesday, November 7, 2012 2:51 PM

Answers

  • Yep, Just remove them. Remove the copies first, then the final copy and if there are maiboxes on them, Exchange wont let you remove that last copy.

    If the arbitration mailboxes on those databases, move them elsewhere

    Get-Mailbox –Arbitration | New-MoveRequest –TargetDatabase <OtherDB>

    • Proposed as answer by steve siyavaya Wednesday, November 7, 2012 3:18 PM
    • Marked as answer by Sharon.Shen Tuesday, November 13, 2012 9:07 AM
    Wednesday, November 7, 2012 2:54 PM
  • You can remove them but ensure you have moved the arbitration mailboxes to the new DB which got created.

    http://muc-ug.org.in/index.php/how-to/exchange-2010/94-default-mailbox-database-a-move-arbitration-mailboxes.html


    ***Don't forget to mark helpful or answer***

    **Note:(My posts are provided “AS IS” without warranty of any kind)

    • Proposed as answer by Sharon.Shen Thursday, November 8, 2012 8:31 AM
    • Marked as answer by Sharon.Shen Tuesday, November 13, 2012 9:07 AM
    Wednesday, November 7, 2012 5:31 PM
  • Hi,Wind,

    Hope the above guys has providen you enough information,hope everything goes well,in case you have any problems when you remove the database you can have a look at the following blog post

    http://blogs.technet.com/b/timmcmic/archive/2010/08/29/exchange-2010-sp1-error-when-adding-or-removing-a-mailbox-database-copy.aspx

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    • Marked as answer by Sharon.Shen Tuesday, November 13, 2012 9:07 AM
    Thursday, November 8, 2012 8:33 AM

All replies

  • Yep, Just remove them. Remove the copies first, then the final copy and if there are maiboxes on them, Exchange wont let you remove that last copy.

    If the arbitration mailboxes on those databases, move them elsewhere

    Get-Mailbox –Arbitration | New-MoveRequest –TargetDatabase <OtherDB>

    • Proposed as answer by steve siyavaya Wednesday, November 7, 2012 3:18 PM
    • Marked as answer by Sharon.Shen Tuesday, November 13, 2012 9:07 AM
    Wednesday, November 7, 2012 2:54 PM
  • http://technet.microsoft.com/en-us/library/dd298164.aspx

    ExchangeGeek

    (MCITP,Enterprise Messaging Administrator)

    **My posts are provided “AS IS” without warranty of any kind**

    Wednesday, November 7, 2012 2:59 PM
  • You can remove them but ensure you have moved the arbitration mailboxes to the new DB which got created.

    http://muc-ug.org.in/index.php/how-to/exchange-2010/94-default-mailbox-database-a-move-arbitration-mailboxes.html


    ***Don't forget to mark helpful or answer***

    **Note:(My posts are provided “AS IS” without warranty of any kind)

    • Proposed as answer by Sharon.Shen Thursday, November 8, 2012 8:31 AM
    • Marked as answer by Sharon.Shen Tuesday, November 13, 2012 9:07 AM
    Wednesday, November 7, 2012 5:31 PM
  • Hi,Wind,

    Hope the above guys has providen you enough information,hope everything goes well,in case you have any problems when you remove the database you can have a look at the following blog post

    http://blogs.technet.com/b/timmcmic/archive/2010/08/29/exchange-2010-sp1-error-when-adding-or-removing-a-mailbox-database-copy.aspx

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    • Marked as answer by Sharon.Shen Tuesday, November 13, 2012 9:07 AM
    Thursday, November 8, 2012 8:33 AM
  • Hi,Wind,

    Any updates here?

    If you have worked out the issue please kindly let us know.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Tuesday, November 13, 2012 1:54 AM