locked
Minimizing IE window, on clicking on video pause button. RRS feed

  • Question

  • Hi Experts,

    We embedded a video in SharePoint 2013, but in Internet explorer when we are clicking on pause button, IE window minimizing automatically.

    Does anyone experienced this issue....

    Mahi


    Mahesh Sinha


    • Edited by Mahi Sinha Tuesday, May 3, 2016 6:21 PM
    Tuesday, May 3, 2016 6:16 PM

Answers

  • Hi,

    The issue relate IE document mode, if you change IE document mode to 11, it will works.

    By default, SharePoint 2013 set document mode to 10.

    <meta http-equiv="X-UA-Compatible" content="IE=10" />
    

    As a workaround, we can create new aspx page using SharePoint designer 2013. And add the following code in the page, then modify the iframe to make it works.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html dir="ltr" xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title>Test</title>
    <meta http-equiv="X-UA-Compatible" content="IE=11" />
    </head>
    
    <body>
    
    <iframe width=640 height=360 src='https://xxx.sharepoint.com/portals/hub/_layouts/15/VideoEmbedHost.aspx?chId=cdd9a6c4%2Da909%2D40d6%2Da54e%2D2c45d1e6914f&amp;vId=38b57002%2D2fc6%2D4139%2Da031%2De7d926a7d833&amp;width=640&amp;height=360&amp;autoPlay=false&amp;showInfo=true' allowfullscreen></iframe>
    
    </body>
    
    </html>
    

    And then, we can see it working fine and the "full screen" button also works.

    Best Regards,

    Dennis


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 4, 2016 8:49 AM

All replies

  • Which version of IE do you have?

    Por favor recuerde &quot;Marcar como respuesta&quot; las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado &quot;tal cual&quot; y no implica ninguna responsabilidad de parte de Microsoft.

    Tuesday, May 3, 2016 10:08 PM
  • Hi

    IE is minimizing or just lost his focus?


    顺其自然地勇往直前!—Justin Liu

    Wednesday, May 4, 2016 1:25 AM
  • Hi,

    Please provide more details about how to reproduce this issue, others would get easier to research on it.

    Best Regards,

    Dennis


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 4, 2016 1:56 AM
  • Federico it's IE 11.



    Mahesh Sinha

    Wednesday, May 4, 2016 2:25 AM
  • @Junstin It's minimizing, it's same as lost his focus also.
    Sometimes when we refresh the page or open the window again, it works fine, but most of the time having issue.
    In other browsers it's working fine like chrome.

    Mahesh Sinha


    • Edited by Mahi Sinha Wednesday, May 4, 2016 2:35 AM
    Wednesday, May 4, 2016 2:26 AM
  • @Dannis, you can reproduce the issue easily.

    Just take the embed URL from O365 video lib and put the embed URL on any SharePoint page in script editor or content editor web part.

    You can also refer : https://support.office.com/en-us/article/Embed-a-video-from-Office-365-Video-59e19984-c34e-4be8-889b-f6fa93910581

    Display a video from Office 365 Video on a SharePoint on-premises site or other website.

    Let me know if anything more required.


    Mahesh Sinha

    Wednesday, May 4, 2016 2:32 AM
  • Hi,

    The issue relate IE document mode, if you change IE document mode to 11, it will works.

    By default, SharePoint 2013 set document mode to 10.

    <meta http-equiv="X-UA-Compatible" content="IE=10" />
    

    As a workaround, we can create new aspx page using SharePoint designer 2013. And add the following code in the page, then modify the iframe to make it works.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html dir="ltr" xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title>Test</title>
    <meta http-equiv="X-UA-Compatible" content="IE=11" />
    </head>
    
    <body>
    
    <iframe width=640 height=360 src='https://xxx.sharepoint.com/portals/hub/_layouts/15/VideoEmbedHost.aspx?chId=cdd9a6c4%2Da909%2D40d6%2Da54e%2D2c45d1e6914f&amp;vId=38b57002%2D2fc6%2D4139%2Da031%2De7d926a7d833&amp;width=640&amp;height=360&amp;autoPlay=false&amp;showInfo=true' allowfullscreen></iframe>
    
    </body>
    
    </html>
    

    And then, we can see it working fine and the "full screen" button also works.

    Best Regards,

    Dennis


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 4, 2016 8:49 AM
  • Thanks Dennis for breif solution.

    We have tried to create simple HTML page with embed URL of video, it's working fine as you said, but when I tried to implement the IE document mode to 11 in existing SP page in SP Designer. Facing the same issue and when i check in developer tools, it's shwoing IE=10 only. 

    I guess it's referencing the master page.

    Dennis, we can't update the master page, If possible please suggest some other workaround.

    Mahi


    Mahesh Sinha

    Wednesday, May 4, 2016 6:41 PM
  • Thanks Dennis for breif solution.

    We have tried to create simple HTML page with embed URL of video, it's working fine as you said, but when I tried to implement the IE document mode to 11 in existing SP page in SP Designer. Facing the same issue and when i check in developer tools, it's shwoing IE=10 only. 

    I guess it's referencing the master page.

    Dennis, we can't update the master page, If possible please suggest some other workaround.

    Mahi


    Mahesh Sinha

    Wednesday, May 4, 2016 6:43 PM
  • Hi,

    If you don't want to update the master page, as a workaround, we can create simple ASPX pages with embed URL of video, then add pages link URL in the SharePoint page. User can click the page hyperlink to show video. Or we can click the link to open a popup window to show the video.

    Best Regards,

    Dennis


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, May 5, 2016 1:55 AM
  • Dennis we need to play the video on the same page only. We can't redirect the user to another page or popup.

    We also tried with Media web part, it's working only when the user is logged in O365. If user is not logged in on O365, it's showing "Media load failed" error.

    Mahi


    Mahesh Sinha

    Thursday, May 5, 2016 3:01 AM