none
Configuring built-in firewall for Onedrive RRS feed

  • Question

  • Hi,

    I use the built-in firewall in windows. I blocked all connections by default, inbound and outbound. For applications created the rules for access to the network. On windows 8.1, OneDrive was enough to add the permission for

    %SystemRoot%\System32\SkyDrive.exe

    But on windows 10 it's not enough for

    %USERPROFILE%\AppData\Local\Microsoft\OneDrive\OneDrive.exe
    

    Error - logon failed. The OneDrive icon in system tray is grey when the firewall is enabled, and white - firewall is disabled.

    What to do with OneDrive? Thanks for the help and advice.

    P.S: open TCP port 443 helps. Question: what program is used to log in to OneDrive?


    Tuesday, October 6, 2015 6:56 PM

Answers

  • I fixed it! The problem is the path to the app in the firewall rules:

    %USERPROFILE%\AppData\Local\Microsoft\OneDrive\OneDrive.exe

    - does not work (why?!), but

    C:\Users\PROFILE_NAME\AppData\Local\Microsoft\OneDrive\OneDrive.exe

    - works!

    Thanks to all! Topic can be closed :)



    • Proposed as answer by -Mr Happy- Friday, January 15, 2016 8:24 PM
    • Marked as answer by Я на TechNet Saturday, January 16, 2016 3:09 PM
    • Edited by Я на TechNet Sunday, September 16, 2018 1:53 PM delete private information
    Friday, January 15, 2016 7:56 PM

All replies

  • Hello,

    I have not setup and I cannot see any rules specifically for OneDrive in the built in firewall, but my OneDrive works as expected. This a clean install of Windows 10.

    Have you created any rules to restrict connections that has also stopped OneDrive?

    Have you tried resetting the firewall to default settings on the Windows Firewall Control Panel?


    • Edited by -Mr Happy- Tuesday, October 6, 2015 8:09 PM
    Tuesday, October 6, 2015 8:09 PM
  • Yes, I blocked all connections by default, inbound and outbound. For each program I create a rule for access to the network. That's the problem, I can't create the rule so that OneDrive can connect to the network. I only know that helps open port TCP 443 for all programs and add in an exception for the firewall:

    %USERPROFILE%\AppData\Local\Microsoft\OneDrive\OneDrive.exe

    What program needs 443 port to work with OneDrive?

    Wednesday, October 7, 2015 6:25 AM
  • You may like to edit your post as it says 'permitted'

    A quick look when OneDrive opens for me when being run opens the OneDrive exe and connects. I was viewing its connections with TCPView

    My system does have consistent connections with explorer.exe and svchost.exe so I don't know if they play a part, but the OneDrive exe is run under the process.

    I can only suggest you use TCPView with your block all rules disabled, connect to OneDrive. Then enable the block all rules and view and compare.

    Good luck.


    Wednesday, October 7, 2015 5:42 PM
  • Alas, svchost.exe and explorer.exe first been added to the rules. TCPView shows that only OneDrive is trying to network, although in reality it is not. I will continue to try to solve, please do not close this topic. I would appreciate community help. And another said that if via port 443 to allow only secure connection in TCPView shows that OneDrive is trying to get on login.live.com but it is not possible. It may be some programs in Windows 10 are responsible for the authorization on the site Microsoft? Very strange. In Windows 8.1 there is no such problem. Why so?
    Thursday, October 8, 2015 6:39 PM
  • Hi Влад Сидоров,

    "P.S: open TCP port 443 helps. Question: what program is used to log in to OneDrive?"

    Port 443 is related to SSL\TTL protocol when we use https.
    I assume Windows 8.1 uses http to access the login.live.com and Windows 10 use https.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Friday, October 9, 2015 2:35 AM
    Moderator
  • I fixed it! The problem is the path to the app in the firewall rules:

    %USERPROFILE%\AppData\Local\Microsoft\OneDrive\OneDrive.exe

    - does not work (why?!), but

    C:\Users\PROFILE_NAME\AppData\Local\Microsoft\OneDrive\OneDrive.exe

    - works!

    Thanks to all! Topic can be closed :)



    • Proposed as answer by -Mr Happy- Friday, January 15, 2016 8:24 PM
    • Marked as answer by Я на TechNet Saturday, January 16, 2016 3:09 PM
    • Edited by Я на TechNet Sunday, September 16, 2018 1:53 PM delete private information
    Friday, January 15, 2016 7:56 PM