none
Sharing Printer across different domain failed to connect.

    Question

  • Hi,

    I apologizes if this question have been asked before but i have tried looking for answer for this for some times without any luck to get a workaround that work for me.

    We have two domain environment where both are interconnected by individual dial-up VPN connection(No site-to-site VPN). I given reference for our domains as Domain A & Domain B.

    Domain A:

    I have one Epson LQ590 connected via USB cable to a PC Running Windows 10. This printer I shared to everyone to Allow Print. This printer can work perfectly for USB printing and Local Area Network printing. The PC which Epson LQ-590 attached have a dial-up VPN connection(will get fixed IP to the Domain B network) . All PC in this domain are running Windows 10.

    Domain B:

    Physically different location. Users from Domain A will dial-up VPN to Domain B network and open RDP connection to Terminal Server in Domain B. Terminal Server is hosted by Windows Server 2012 R2 Standard. Users from domain A will add Printer from Domain A(Epson LQ-590) to their Terminal Session in Domain B with referencing \\{Dial-up VPN IP}\Epson Lq590. 

    Problem:

    Above setting are working fine previously up to Windows 7. Recently we are upgrading all the PC in Domain A to Windows 10. After Upgraded, I encountered error when connecting printer "Windows Couldn't connect to printer. Check the printer name and try again. ......". I couldn't understand the error message where it ask to check printer name because I can see the printer name correctly when I browse to the printer host IP( \\{Dial-up VPN IP}\Epson Lq590). 

    after google around for awhile, I found few advise to enable Policy "Allow Print Spooler to Accept Client Connections" . After enabling this Policy and restart print spooler, I can successfully add this printer. Unfortunately, the very next morning I received a call from user telling the printer is missing. Then I checked and confirm it is missing and unable to re-add the printer. I tried to restart print spooler again on Printer Host PC and try to add again from terminal session and i found out it can connect now.

    So my observation now the only way for me to get this printer working is by manually restart Print Spooler on the printer owner PC. This is quite annoying because even if I allow user to run the Restart Spooler Script, I still required to assist them for re-adding the printer in Terminal session. 

    What I've done without success:

    • Change all available driver for Epson LQ590 - same result
    • Change other PC to host the printer - still same result
    • enable Policy in Printer Owner PC to "Allow Print Spooler to Accept Client Connections"  - can work but require Spooler Restart everytime Windows Startup
    • Disable all firewall\AV program
    • Disable Bidirectional Printing Support under Printer Properties --> Port
    • Set "Use Printer Offline/Online"

    Hopefully somebody has experienced in similar issue can shed some light on which part should I investigated to get this issue solve.


    • Edited by AskMeHelp Friday, April 20, 2018 12:41 AM simplify words
    Wednesday, April 18, 2018 8:42 AM

All replies

  • I would add the Windows print feature LPD service to the machine with the USB printer.

    Makes sure the share name for the printer is all on word EPSONLQ590.  NO spaces. Make sure you have a vendor driver and nothing that is Type 4 or Class in the name.

    On the machines connecting the printer, add a local printer targeting the IP of the machine sharing the printer use a Standard TCP/IP Port in LPR mode.  The SPM UI will kick you to the Custom settings but you can script this.

    Queuename is the sharename, remember no spaces.

    Enable Byte counting

    leave SNMP disabled.

    Pick the correct driver for the printer.

    print a test page.

    Make certain it works after a couple days, then make the same changes to the other client systems.


    Alan Morris formerly with Windows Printing Team

    Wednesday, April 25, 2018 2:09 PM
    Answerer
  • Thank you for the suggested solution, currently I am not free to give it a try. Will get back with the updates in couple of days.

    Updates so far:

    1. on USB connected PC:

    • Installed Windows Print Features LPD Service(verified running) on USB connected PC
    • Checked sharename is 'EPSONLQ590'
    • Installed printer with correct driver without any Type 4 or Class in driver name
    • Test print locally succeed

    2. on client connecting PC:(tried from Windows 10 and Windows Server 2012)

    • add the EPSONLQ590 with pointing USB connected PC's IP Address
    • assign Standard TCP/IP Port with LPR mode. Set quename as Sharename(as instructed all on word without space)-byte counting enabled-SNMP disabled-same driver(w/o class or type 4)
    • result: Test print return "printer busy or error" in the print status
    • in attempt to solve printer busy issue, tried to disable bidirectional printing and enable direct print without any success.

    is it so common Windows 10 spooler losing credentials?

    • Edited by AskMeHelp Wednesday, May 02, 2018 8:42 AM updated
    Friday, April 27, 2018 7:58 AM
  • okay.  I'm not sure what the issue with Windows 10 spooler losing the credentials.  The LPD solution is just another method to get print jobs into the system without the need for Windows authentication which seems to be leading to the connection failures.


    Alan Morris formerly with Windows Printing Team

    Tuesday, May 01, 2018 7:17 AM
    Answerer