locked
Setting Security on all Users Calendars with a Script RRS feed

  • Question

  • We want it to be manditory that all users in the organization shares their calendars as read-only to everyone.   We have a script we found that sets permissions on the calendars and we run it nightly.   Recently we've discovered that new users Calendars are still unable to be read.   I ran the script manually and it didn't error, it appeared to complete but it didn't change the permissions.   Is there a better way to do this? 
    Tuesday, October 18, 2011 7:07 PM

Answers

  • Hello,

     

    How about using the following script:

     

    ======================

    $alias = Get-Mailbox |select alias

    $Calendar=$alias+":\Calendar"

    Add-MailboxFolderPermission -Identity $Calendar -User everyone -AccessRights Reviewer

     

    =========================================================

     

    Simon Wu

    Exchange Forum Support

     

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

     

     

    Wednesday, October 19, 2011 8:27 AM

All replies

  • You can add the permission setting to the new mailbox creation process.

    As to why the script doesn't work, it's hard to say since you didn't post the script.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Tuesday, October 18, 2011 9:36 PM
  • Hello,

     

    How about using the following script:

     

    ======================

    $alias = Get-Mailbox |select alias

    $Calendar=$alias+":\Calendar"

    Add-MailboxFolderPermission -Identity $Calendar -User everyone -AccessRights Reviewer

     

    =========================================================

     

    Simon Wu

    Exchange Forum Support

     

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

     

     

    Wednesday, October 19, 2011 8:27 AM
  • Wednesday, October 19, 2011 3:39 PM
  • Hello,

     

    Can you check the calendar permission for the problematic user by running:

     

    Get-MailboxFolderPermission -Identity user@contoso.com:\calendar |FL

     

    Thanks,

    Simon

    Thursday, October 20, 2011 8:03 AM
  • This is what I get back.

     

    RunspaceId   : 139e519f-c224-4d2d-9e9e-3c39b78539fe
    FolderName   : Calendar
    User         : Default
    AccessRights : {None}
    Identity     : Default
    IsValid      : True

    Thursday, October 20, 2011 1:31 PM
  • Hello,

     

    How about manually running the following command:

     

    Set-MailboxFolderPermission -Identity user@contoso.com:\calendar -User “Default” -AccessRights Reviewer

     

    Simon Wu

    Exchange Forum Support

     

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

     

     

    Friday, October 21, 2011 2:21 AM
  • Hello,

     

    Is there any update the on this thread?

     

    Simon Wu

    Exchange Forum Support

     

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 28, 2011 2:28 AM
  • No I ran that command and nothing changed.  
    Friday, October 28, 2011 3:02 AM
  • PFDavAdmin might be an option for you.  You can configure calendars in bulk and I believe there may be scripting options.
    Friday, October 28, 2011 3:06 PM