locked
SCOM 2016 - Not able install push the agent on the clients RRS feed

  • Question

  • Hi,

    During the process of agent installation discovery is working properly, when I try to push agents on the clients I getting following message:

    I apply roll-up 4 two days ago. Has anyone had experience with this?


    Thursday, May 10, 2018 1:06 PM

Answers

  • This is the solution for my problem... :)

    https://social.technet.microsoft.com/wiki/contents/articles/51280.scom-troubleshooting-repairing-agent-fails-the-client-has-been-disconnected-from-the-server.aspx

    Friday, November 2, 2018 3:33 PM

All replies

  • Hi,

    This is the only direct reference I found regarding your exact issue. Abdul Karim's reply on

    SCOM 2012 UR3 - Console error - stack overflow

    "

    Hello, 

    I had the same issue while pushing agent on one of our servers. Upon troubleshooting I found out that, the agent on that server was installed manually and was not approved from pending management.

    Upon un-installing the agent from that server, I was successfully able to push it from the console, without facing a problem.

    Hope this helps someone.

    Regards,


    Abdul Karim. (http://sites.google.com/site/scomblogs Twitter:@Abdul_SCOM)

    "

    Also have seen this happen when there's an issue with time sync. Please see:

    SCOM 2016: Error while connecting to management server: The client has been disconnected from the server

    Error: ‘The client has been disconnected from the server. Please call ManagementGroup.Reconnect() to reestablish the connection.’

    Hope this helps

    Cheers


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!)

    Thursday, May 10, 2018 2:18 PM
  • Hi,

    On top of it just try to discover and install agent from other MS , check if still persist.  If yes,

    then restart the services on all the MS in given manner and see if error still occurs:-

    Sequence for stop is :-

    System Center Management Configuration
    Microsoft Monitoring agent
    System Center Data Access Service

    Start:-

    System Center Data Access Service
    Microsoft Monitoring agent 
    System Center Management Configuration


     

    Cheers, Gourav Please remember to mark the replies as answers if it helped.




    • Edited by GouravIN Thursday, May 10, 2018 4:21 PM
    • Proposed as answer by GouravIN Friday, May 11, 2018 4:08 AM
    Thursday, May 10, 2018 4:20 PM
  • >> The client has been disconnected from the server.
    Please try this to see whether to solve the issue
    1) Restart System Center Data Access Service
    2) Restart Center Management Configuration Service
    3) Reopen operations console with //clearcache option
    4) using discovery wizard again to discovery and deploy agent to client machine

    Roger

     

    Friday, May 11, 2018 3:41 AM
  • Thanks for your help guys. I try all that you advise but, the error still occurs.  Looks like I don't have a problem to add new servers. The error pops up only when I want to add servers which already been in SCOM with the domain A. For the research purpose those servers were removed from domain A and join to domain B, but after some time I move the servers back to the domain A and after that I am not able to push the agents again. Hostname stays the same, I remove old agents manually from Programs and Features and re-add SCOM domain user in the local administrator group which I am using to push the agents. That user is a member of Operations Manager Operators user role.

    Should I change something in the Database???

    Friday, May 11, 2018 8:18 AM
  • This is the solution for my problem... :)

    https://social.technet.microsoft.com/wiki/contents/articles/51280.scom-troubleshooting-repairing-agent-fails-the-client-has-been-disconnected-from-the-server.aspx

    Friday, November 2, 2018 3:33 PM