none
Issue with permission level

    Question

  • My (small) company is running an office 365 solution including sharepoint

    I'm a fairly new sharepointuser and currently just trying to get a feel for the possibilities in the solution.

    Following a simple online guide I've tried to apply a new document template to a site content type. It's all fairly straightforward but when saving the template I'm told I don't have permission.

    If I ask permission in the form, I promptly get an email in my mailbox, where I can approve my own permission request. Approving the request doesn't save the new template though, nor does it help reloading the page or trying to add the template again.

    I've tried adding various templates of different formats, and I've tried different site content types - the results are all the same.

    My permission level for the site should be 'full control' which I can verify when I check permissions for my user - but I see that there's a 'deny' factor in play as well. 

    Googling this suggest that this is a site policy setting, but instructions for changing it all seem to assume an on-premise solution where I can log on to the server. Our solution is cloud based.

    Can anyone confirm that the 'deny' section on my permission setting is in fact the issue and how to change it - or otherwise speculate as to what may cause my problem?


    Saturday, December 3, 2016 10:19 AM

All replies

  • Hi,

    Based on my understanding, you’re trying to create custom content type and assign custom file template to this content type, but got permission issue.

    Could you try to grant your current user as site owner and check?

    Go to Site Settings-> Site permissions->yourSite Owners

    If the issue exists, could you provide your detail steps.

    Best Regards,

    Lee


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, December 6, 2016 5:25 AM
  • Hi Lee

    I'm actually already site owner, but my steps are as follows:

    1) I go to 'site settings' -> 'site content types' and select my nyew content type (a document style content type).

    2) I click 'advanced settings', select 'Upload a new document template' and choose my word template file (currently that template file is in fact an empty word document)

    3) I save the template and get the following error:

    "Sorry, You don't have access to this page"

    4) After that, I can approve the access request myself, but the template is never uploaded successfully..


    Tuesday, December 6, 2016 8:00 AM
  • Hi,

    Could you provide the screenshot of ‘check permissions’ for your account.

    Best Regards,

    Lee


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, December 6, 2016 9:40 AM
  • I'm having this same issue; did you ever figure it out?  
    Tuesday, April 3, 2018 6:51 PM
  • I just tried the same steps and it works for me. It has to be your permissions. As Lee suggested, please share a screenshot of your check permissions page.

    Please remember to mark the reply as answer if it has helped.

    Tuesday, April 3, 2018 7:18 PM