locked
Exchange 2007 - IMAP4 service starts and then immediately stops - Failed to start listening (Error: 10048). Binding: :::993 RRS feed

  • Question

  • Im trying to start the IMAP4 service, but it stops immediately after being started. When trying to start the service from server manager I get the error message, "The Microsoft Exchange IMAP4 service on SERVERNAME started and then stopped. Some services stop automatically if they are not in use by other services or programs"

    The event log records three errors:

    1. Failed to start listening (Error: 10048). Binding: :::993.
    2. The address is already in use. Binding: :::993.
    3. Failed to open one or more bindings. The service will be stopped.

    What am I doing wrong?

    It seems like possibly some process is already bound to port 993...? I'm not sure how to go about checking that specifically. Thanks.

     

    Friday, April 30, 2010 8:55 PM

Answers

  • Well I installed a couple of exchange rollup updates, restarted the server and magically the service started working.
    • Marked as answer by Elvis Wei Wednesday, May 5, 2010 9:27 AM
    Saturday, May 1, 2010 4:23 AM

All replies

  • One more thing, I tried "telnet 127.0.0.1 993" connection failed...

    Friday, April 30, 2010 8:58 PM
  • Im trying to start the IMAP4 service, but it stops immediately after being started. When trying to start the service from server manager I get the error message, "The Microsoft Exchange IMAP4 service on SERVERNAME started and then stopped. Some services stop automatically if they are not in use by other services or programs"

    The event log records three errors:

    1. Failed to start listening (Error: 10048). Binding: :::993.
    2. The address is already in use. Binding: :::993.
    3. Failed to open one or more bindings. The service will be stopped.

    What am I doing wrong?

    It seems like possibly some process is already bound to port 993...? I'm not sure how to go about checking that specifically. Thanks.

     

    Is your ex2007 server updated with latest Update Rollups with SP2?

    Regards,


    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
    • Proposed as answer by Laeeq Qazi Saturday, May 1, 2010 2:24 PM
    Friday, April 30, 2010 9:08 PM
  • It's possible a process is already listening to 993, you can use netstat -an to check that from a command prompt. Pipe the output to a text file and do a Ctrl+F for 993.

    If the error actually has those three colons rather than IPs then I'd suspect the bindings for the IMAP service are messed up. You can configure these in the Server Configuration\Client Access section of the EMC.


    Active Directory, 4th Edition - www.briandesmond.com/ad4/
    Saturday, May 1, 2010 12:08 AM
  • Ok, you might be on to something. EMC\Server Config\Client Access... on the Binding tab for IMAP4, in the Secure Sockets Layer Connects section, there are two items listed:

    (All available IPv6 addresses) : 993
    (All available IPv4 addresses) : 993

    When I try to edit IPv6, the window that comes up asks me to specify an IP and it has :: in the field. If I change the option to Use all IP addresses available on this server, I get an error that the value 0.0.0.0:993 is already present in the collection.

    Conversely when I try to edit IPv4, the radio box selection for Use all IP addresses available on this server is already selected...

    Should I delete the IPv6 item from the list?

    Saturday, May 1, 2010 4:06 AM
  • On Sat, 1 May 2010 04:06:04 +0000, ArbitrageMan wrote:
     
    >
    >
    >Ok, you might be on to something. EMC\Server Config\Client Access... on the Binding tab for IMAP4, in the Secure Sockets Layer Connects section, there are two items listed:
    >
    >(All available IPv6 addresses) : 993 (All available IPv4 addresses) : 993
    >
    >When I try to edit IPv6, the window that comes up asks me to specify an IP and it has :: in the field. If I change the option to Use all IP addresses available on this server, I get an error that the value 0.0.0.0:993 is already present in the collection.
    >
    >Conversely when I try to edit IPv4, the radio box selection for Use all IP addresses available on this server is already selected...
    >
    >Should I delete the IPv6 item from the list?
     
    You can't select the "use all IP addrersses . . ." radio button for
    the IPv6 address range. Instead, specify a specific address.
     
    If you want to listen on all available IP addresses:
     
    .. The IPv6 binding should be:
    .. 0000:0000:0000:0000:0000:0000:0.0.0.0:993
     
    .. If you select the "Use all available . . ." for IPv4, the IPv4
    binding will be:
    .. 0.0.0.0:993
     
    You can see the bindings easily enough like this:
     
    get-imapsettings | fl *bindings
     
    UnencryptedOrTLSBindings : {0000:0000:0000:0000:0000:0000:0.0.0.0:143,
    0.0.0.0:143}
    SSLBindings : {0000:0000:0000:0000:0000:0000:0.0.0.0:993,
    0.0.0.0:993}
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Saturday, May 1, 2010 4:22 AM
  • Well I installed a couple of exchange rollup updates, restarted the server and magically the service started working.
    • Marked as answer by Elvis Wei Wednesday, May 5, 2010 9:27 AM
    Saturday, May 1, 2010 4:23 AM
  • May I know which Rollup Updates to install to fix this problem please ?

    Event Type: Error

    Event Source: .NET Runtime 2.0 Error Reporting

    Event Category: None

    Event ID: 1000

    Date: 1/4/2011

    Time: 11:04:51 AM

    User: N/A

    Computer: ExcServ01

    Description:

    Faulting application microsoft.exchange.imap4service.exe, version 8.1.263.0, stamp 47a985c6, faulting module kernel32.dll, version 5.2.3790.4480, stamp 49c51cdd, debug? 0, fault address 0x000000000000dd50.



    /* Infrastructure Support Engineer */
    Tuesday, January 4, 2011 2:03 AM