none
Project Online: Reports are not working RRS feed

  • Question

  • Hi:

    First let me explain in detail what I'm doing:

    1. I'm using a trial of Project Online. 
    2. For that I've created several users on a separate Domain (PRUEBAMST)
    3. I created two projects (One project for the last month, just to use timesheets and have something to report on, this project is finish. The other project is normal with ongoing tasks)
    4. I have one domain for the project online (PRUEBAMST) but in my client station I'm logged in another domain (DATCO.PERU.COM). Basically because I'm making a thoroughly evaluation.

    Now the issue:

    1. Each time I download a report to excel from Project Online and From the ribbon DATA I select the "Refresh All" Icon I only get info for a Project named "Timesheet Administrative Work Items".
    2. Even if I connect directly to the OData using IE10 and to "<mysite>/sites/pwa/_api/ProjectData/Tasks" I get the same info. I can't get the info for any of my two projects.

    Is it a security issue? Do I have to refresh something? Do I have to run a task on the server to refresh the data?

    Please any help, or pointer,  would be really appreciated.

    regards,

    Mauricio Sougarret

    Monday, March 4, 2013 4:36 PM

Answers

  • Hi Mauricio, there isn't permissions that would restrict the returned projects in the oData feed so you should see all plans that have been published.  Just to check - how did you create these plans (Project Professional or directly in Project Web App (PWA)) and how did you publish?  You should see plans created in Project Web App regardless of publishing - at least their names in the Projects feed - but plans from Project Professional that are not published will not appear.  Both SharePoint Task List type plans and Enterprise project type plans created from PWA should show as entries in the oData feed.

    The only other reason apart from unpublished plans from PWA that would stop plans showing was if a backend queue process failed which meant the data did not reach the reporting database which is the source of data for the oData feed.  Are there any jobs showing in your queue as failed?  PWA Settings, Manage Queue Jobs or My queue jobs.

    If there are then we will need more information about your Project Online tenant to dig deeper.  If you are not happy sharing here in the forum then please e-mail me at Brian.Smith@Microsoft.com and I can see what is going on for you.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    • Marked as answer by msouga Monday, March 18, 2013 11:17 PM
    Wednesday, March 6, 2013 10:23 PM
    Owner

All replies

  • Hi Mauricio, i thought it is possible that the account in domain(DATCO.PERU.COM)has no permission one these two projects. Can you try to grant permission to the client account and then check it?

    Tuesday, March 5, 2013 2:22 AM
    Moderator
  • Thanks for your reply Daisy but how I grant the permission of a client account from a different domain in Office 365? BTW my company is using the domain name datcoperu.com.pe with O365 in production so I can't use it for evaluation pourposes..


    • Edited by msouga Tuesday, March 5, 2013 5:29 PM
    Tuesday, March 5, 2013 5:29 PM
  • Hi Mauricio, in your situation, It is recommended to use SSO which allows you and your users to access cloud services with your Active Directory corporate credentials.  you can refer to this document :http://community.office365.com/en-us/wikis/sso/office-365-sso-content-map.aspx to get the detailed step for configuring SSO.
    Wednesday, March 6, 2013 2:08 AM
    Moderator
  • It doesn't sound like a security issue as you can see the OData feed with other project data. 

    Can you see the projects in _api/ProjectData/Projects?

    Have you published the projects?


    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Wednesday, March 6, 2013 3:29 AM
    Moderator
  • I have published several projects. I have tried the _api/ProjectData/Projects but I can only see info for "Timesheet Administrative Work Items". Do I have to grant rights to my user somewhere else?

    Using SSO defeats completly the cloud concept, I mean it's to hard to deploy and manage, for me a cloud solution must be administrable by a user with average IT knowledge.

    BTW I have deleted the original PWA and created a new one "Just in case" but I have the same results.

    • Edited by msouga Wednesday, March 6, 2013 8:44 PM
    Wednesday, March 6, 2013 8:41 PM
  • Hi Mauricio, there isn't permissions that would restrict the returned projects in the oData feed so you should see all plans that have been published.  Just to check - how did you create these plans (Project Professional or directly in Project Web App (PWA)) and how did you publish?  You should see plans created in Project Web App regardless of publishing - at least their names in the Projects feed - but plans from Project Professional that are not published will not appear.  Both SharePoint Task List type plans and Enterprise project type plans created from PWA should show as entries in the oData feed.

    The only other reason apart from unpublished plans from PWA that would stop plans showing was if a backend queue process failed which meant the data did not reach the reporting database which is the source of data for the oData feed.  Are there any jobs showing in your queue as failed?  PWA Settings, Manage Queue Jobs or My queue jobs.

    If there are then we will need more information about your Project Online tenant to dig deeper.  If you are not happy sharing here in the forum then please e-mail me at Brian.Smith@Microsoft.com and I can see what is going on for you.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    • Marked as answer by msouga Monday, March 18, 2013 11:17 PM
    Wednesday, March 6, 2013 10:23 PM
    Owner
  • Hi Mauricio - is this working for you now?  Let me know if you need any more assistance.

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Monday, March 11, 2013 10:57 PM
    Owner
  • Hi, Brian.

    In my previous trial enviroment Excel Services cannot connect too.

    My be security problem. I cannot create new trial site. 

    Testing for money only. :)

    http://office.microsoft.com/en-us/project/free-project-management-software-project-trial-FX103797290.aspx?WT%2Eintid1=ODC_ENUS_FX103472268_XT103993060



    MS Project and Project Management |PM Consulting Services, Microsoft Gold PPM and Gold ISV Partner

    Tuesday, March 12, 2013 7:47 PM
  • Hi Brian:

    Sorry for the delay, everything is working now I don't know what really happened. I think it has something to do with the queue but it's only a guess. Project Service is a great product.

    I have found some other minor glitches with the web client I will report them on another thread.

    Thanks for your support.

    Monday, March 18, 2013 11:22 PM