locked
Sony Vaio VGN-S270B - Don't have SoundMax Integrated Digital Audio driver for Vista Ultimate RRS feed

  • Question

  • I have installed Vista Ultamate RTM on Sony Vaio VGN-S270B with good results, but I have an issue with sound card:

    Sony Vaio VGN-S270B - 1024MB - Soundmax Digital Integrated Audio.

    I also check on Windows Update, my notebook have 2 successful updated:

    + Sony Corporation driver update for Sony Programmable I/O Control Device.

    + Sony Corporation driver update for Sony Notebook Control Device.

    But don't have driver for Soundmax Digital Integrated Audio :(

    I tried different way: check on Sony website - don't have, and other Soundmax Digital Integrated Audio driver for HP, Dell, ... but unsuccessful.

    Help for download?

    Friday, January 26, 2007 2:09 AM

All replies

  • I have the same problem with a sony vgn-s360 (same chipset).  I only get choppy distorted sound and artifacts in video with old oem drivers.
    Saturday, February 3, 2007 9:03 AM
  • i alsohave the same problem with a sony vgn-s360, let me know if you find a solution please.

    thanks

    Sunday, February 18, 2007 6:07 PM
  • Windows vista home premium worked well, i needed the ultimate cause the multi language support. after upgrading sound isnt anymore recognized, it seems as i dont have a sound card, may be a cold start could help, but it seems not.  The notebook is a vaio  VGN-FE41S
    Wednesday, February 21, 2007 11:03 AM
  • Apparently we all have the same issue - my Sony VGN-S360  has no sound  with Vista Ultimate.  I have to use my Logitech  USB headphones.  Hopefully  someone will find an answer. 
    Sony had me uninstall  everything associated with the sound  card to see if Vista would assign generic drivers, but obviously this did not work.
    Keep us posted - thanks-

    P.S -  anyone have any word on release date for Epson R800 printer Vista drivers?
    Wednesday, February 21, 2007 3:08 PM
  • I have the same issue with my Sony VAIO VGN-AR170G.  I upgraded to Windows Vista ultimate and now my sound drivers aren't working properly.

     

    Basic sound (Windows beeps and the like) work, but Windows Media does not produce sound and high-def audio doesn't work.  And any programs which depend on high def sound (DirectX apps, InterVideo DVD, iTunes) don't work either.

     

    Hopefully Sony will post a fix to this soon.  So far my experience with Vista has been rather unpleasant.

    Wednesday, February 28, 2007 3:06 PM
  • I had the same issue with Sony VAIO VGN-S360.

    I previously had Vista Enterprise edition installed and audio worked fine. I have read other posts where Vista Basic/Home and audio worked fine.

    When I upgraded to Ultimate (for Media Center) and SoundMax audio stopped working.

    During the upgrade, the folder windows/old was created. I went into the Unknown Device and Updated Driver and told it to search C:\Windows.old - and it found the old driver.

    Everything is working now.

    Let me know if this makes sense or if you need more info.

     

    Thursday, March 1, 2007 6:21 AM
  • Hey, I did a clean install (foolish, I know), so there's no old directory in place for me to look for drivers. could you post the driver online?

    Also, any ideas how to fix the mouse drivers also, so my back/forward and up/down scrolls work?

    KZ 

    Saturday, March 10, 2007 5:16 PM
  • I also did a clean install on my s360 and it says "no audio output device is installed".
    Is there any way to fix this problem or does my computer no longer have sound?

    any help would be greatly appreciated, please!!!!
    Monday, March 12, 2007 3:29 AM
  • Is there any possible way that you could make this file available to other people because I did a clean install and dont have any old driver files. I would really appreciate it. I really need some sound on my laptop! I also have an s360
    Monday, March 12, 2007 3:31 AM
  • All of the drivers i used are also in the X505 driver dowload listed above.

    Here is what was installed:

    aed.dll

    aeaudio.sys

    drmk.sys

    portcls.sys

    smsens.sys

    smwdm.sys

    They all were included in the X505 install - so try that?

    Otherwise, get me you email address and i will email them to you.

    Monday, March 12, 2007 4:36 AM
  • can anyone help? after downgrading to windows XP fron Vista i lost the sound driver. can anyone direct me how to get the sound drivers for my laptop
    Sunday, March 18, 2007 3:33 PM
  • i am trying to install miniTV usb on my sony vaio FE serie. It tell me to open drmk. sys but i can't find that on my system if u can send me the link to download it on my system i 'd really appreciate it. send to bjthompson85@hotmail.com. thanks
    Monday, April 2, 2007 5:20 PM
  • Can someone please email me the info jsblair@hotmail.com
    Saturday, April 21, 2007 2:49 PM
  •  thomcost wrote:
    <p>All of the drivers i used are also in the X505 driver dowload listed above.</p> <p>Here is what was installed:</p> <p>aed.dll</p> <p>aeaudio.sys</p> <p>drmk.sys</p> <p>portcls.sys</p> <p>smsens.sys</p> <p>smwdm.sys</p> <p>They all were included in the X505 install - so try that?</p> <p>Otherwise, get me you email address and i will email them to you.</p>
    <br>Can you send a copy of these files to me as well <a href="mailto:chris.j.steele@gmail.com"><br>Thank You<br>
    Tuesday, April 24, 2007 10:54 AM
  •  Thong Tran wrote:

    I have installed Vista Ultamate RTM on Sony Vaio VGN-S270B with good results, but I have an issue with sound card:

    Sony Vaio VGN-S270B - 1024MB - Soundmax Digital Integrated Audio.

    I also check on Windows Update, my notebook have 2 successful updated:

    + Sony Corporation driver update for Sony Programmable I/O Control Device.

    + Sony Corporation driver update for Sony Notebook Control Device.

    But don't have driver for Soundmax Digital Integrated Audio Sad

    I tried different way: check on Sony website - don't have, and other Soundmax Digital Integrated Audio driver for HP, Dell, ... but unsuccessful.

    Help for download?

    Thursday, May 3, 2007 1:43 AM
  • If you could email these it goes much appreciated....same chipset and followed all Sonys clean install steps but it will not allow me to update the driver as it says the best driver is already installed.  Thanks in advance for the email or link to download
    Tuesday, June 5, 2007 3:40 PM
  •  ... hi can u please send me the driver if possible .. i reboted my pc and i need the drmk.sys... i tried everything it didnt work...

    if possible by anychance i would greatly appriciate it . thank u.

    Monday, July 16, 2007 3:10 AM
  • OK I GOT MINE TO WORK....

     

    This is what I did.

     

    First of all I downloaded the Vista RTM ISO with Bit torrent (I think it is legal if not oh well I paid for a copy of Vista)

    Ok then I restored a fresh copy of XP with restore discs

    then I installed Vista home Basic (upgrade not clean install) with out a serial, my sound worked i almost cried!!!

    I then turned around and installed Home Premium (upgrade not clean) with out a serial. 

    Then the same to Ultimate. 

    My sound was working so i put in my product key and all is working fine.

    I hope this helps and I know it took FOREVER to do all this but it works i ran Vista for 4-5 months without sound so it is so nice to have it back.  Maybe I am way behind everybody but i have never found these instructions before.

     

    Email me if any questions

    -JOE-

    Monday, August 20, 2007 3:33 PM
  • can someone send me the audio drivers? thanks in advance.
    btran44@hotmail.com
    Sunday, August 26, 2007 10:13 PM
  • I have sony VAIO VGN-N17g series laptop. There is no sound coming from this laptop. Anybody can help me about this problem. Thanks in advance. My email-id is prem.thainagar@gmail.com

     

    Thursday, October 11, 2007 6:05 AM
  • could you send me a copy? i'd appreciate it. cabir.zhou@gmail.com
    Friday, November 16, 2007 8:13 AM
  • Hi,

     

    I have a VAIO notebook with VISTA Premium on it and I am facing the same problem of sound drivers like most of users. I found this post of yours and think you might be of help. Please email me the drivers at saurabhagr@yahoo.com or v_2sagar@hotmail.com

     

    Looking for some help ASAP.

     

    Saurabh

     

    Saturday, November 17, 2007 4:43 PM
  •  

    Hi,

    I have a Sony VGS-360 laptop as well with Windows Vista Ultimate. Could anyone that has it working e-mail me the sound driver files? Thanks in advance! E-mail is below.

     

    danleming at gmail dot com

    Tuesday, December 11, 2007 1:50 AM
  • I am also having the problem of the missing smwdm.sys file and cannot install my audio driver for Vista as a result. Can someone send me the Vista version of smwdm.sys or point me where I can get it?

     

    Please reply to CI@Mayhews.us

     

    Sincerely,

    Loren Mayhew

     

    Wednesday, January 16, 2008 2:16 AM
  • For all the people out there with VAIO laptops - mine is VGN-s260 - I hope to give some hope regarding the SoundMax drivers for Vista.

    I managed to have my laptop working with ultimate and soundmax only after I first installed XP , I got all the drivers for XP on the Sony site and I had a stable XP install.

    Then I upgraded to ultimate and the sound drivers works fine. All the attempts to install ultimate then the driver from sony site did not work.

    By the way , Sony are just full of bull**it when they tell you that for this hardware config they think vista will not perform well. My laptop is QUICKER in vista that it was on XP , the interface is more responsive and maybe because everithing I install on vista I check teh compatibility first.

    Anyway install XP THEN upgrade to Vista , ive it a try for me it worked.

    Wednesday, January 30, 2008 9:13 PM
  • for all of you out there who have problems with your audio, when upgraded to vista ultimate. try this go to control panel,click additional options, and on the left chose hardware and sound. then under sound go to manage audio devices. make sure that your default is speakers/headphones, not other like optical and such. for some reason on alot of pc's when doing an upgrade the audio driver tends to switch to a different default because its changing system files and the audio drive settings get hung up. helped me and some other people hope it helps you as well. let me know if it does please. GOOD LUCK!!!
    Saturday, February 16, 2008 3:27 AM
  • Plzz e-mail the following files:-

    aed.dll

    aeaudio.sys

    drmk.sys

    portcls.sys

    smsens.sys

    smwdm.sys

    included in the X505 driver install.

    my e-mail id :-



    arnabkaycee@gmail.com

    ITS URGENT.



    Monday, February 25, 2008 11:04 AM
  • so the answer to this problem is to do an XP install and then do the upgrade to Vista Ultimate?  There is no other way of getting sound to work on the Sony laptop?  if anyone has the drivers can you please email them to me at mikerailz@gmail.com, I have a VGN-360 laptop, just finished a clean install of Vista and of course, my sound is not working. I find it hard to believe that we need to go through this process to get the sound to work.  All help is much appreaciated
    Tuesday, March 18, 2008 6:04 PM
  • Thomocost i will greatly appreciate it if you could email me those audio drivers for the vgn-s360. Vista without sound sucks! My email is jotaeme03@yahoo.com. Thank you so much!

    Wednesday, April 16, 2008 4:41 AM
  • Guys,

     

    Just uninstall the sound driver from device manager and restart. The system will detect the driver.

     

    Fendi.

    Thursday, April 17, 2008 4:58 PM