none
Project Server error when creating customized Project Site automatically RRS feed

  • Question

  • Hi all,

    I am implementing Project Server 2010 in an existing SharePoint Server 2010 farm.  This particular farm was migrated from MOSS 2007 by attaching the databases from MOSS to the SP2010 farm.  I installed PJS on a totally new site collection.

    For the most part PJS is working well, but when I try to customize the template for Project Sites, I am getting this error message at the time of creation of the sites:

    <class name="CreateWssSiteContent: Creating project site failed! Project Uid=614e18c2-c9db-45e2-add9-3f7b8d40c89d, site URL=http://cafeto/PWA/Test2, site name=Test2. Microsoft.SharePoint.SPException: The site template requires that the Feature {90cd055f-f21f-42c5-b3fe-bb67173583d4} be installed in the farm or site collection... 

    I have found some hints in the Web indicating that this ID refers to a 2007 hot fix feature called S2SiteAdmin.

    What options do I have right now?  Should I try to enable a MOSS2007 feature in SP2010?  Is there any way to tell the site template to stop requiring that old feature?

    Thanks in advance for your help.

    Saturday, October 1, 2011 2:07 AM

All replies

  • Hi,

    Thre are a couple of options that come to mind:

    1. On your PS2007 template site, deactivate that feature in the site / site collection (I am not sure what that particular site is scoped to) and then migrate the sites across again.

    2. If you have a site with content that was migrated that you can access, remove the content from it, check the features to ensure that feature is not activated and retemplate it in 2010.

    Hope this helps,

     


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Saturday, October 1, 2011 2:16 AM
    Moderator
  • Thanks Alex for your quick response.

    The problem is that the Project Server site template does not come from PS 2007.  I installed Project Server 2010 on a new site collection.  The only features active in my Project Server template are:

    • Metadata Navigation and Filtering
    • Offline Synchronization for External Lists
    • Project Sites Collaboration Lists
    • SharePoint Server Enterprise Site features
    • SharePoint Server Standard Site features
    • Team Collaboration Lists

    Regards,

    Leopoldo Espaillat

    Saturday, October 1, 2011 4:21 AM
  • Hi,

    The Features you mention above are the default ones activated in a normal Project Workspace (I just spun one up to check).

    Doing a quick get-spfeature on my test farm indicates that feature is not there oob on a 2010 farm, thus the feature you are seeing erroring must be in the databases you brought over from 2007.

    You mention you installed PJS in a new site collection, I trust this means you provisioned the /PWA site in a new site collection? What about the project workspaces from your 2007 instance, did you migrate them in a content db and associated site collection?

     

     


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Saturday, October 1, 2011 5:20 AM
    Moderator
  • Hi,

     

    I agree with you in that this phantom feature probably came from 2007.

    You are also right in assuming that I provisioned /PWA in a new site collection, and also in its own database.

    The project workspaces are totally new, we're trying to create them in PJS 2010 when we publish the projects.  We don't have workspaces to migrate from 2007.

    Thanks again for your support.

    Saturday, October 1, 2011 6:13 PM