locked
Turn off Automatic reboot after Updates RRS feed

  • Question

  • How many developers here find the automatic reboot after windows updates, really, really, annoying?

    Yes I always save my work, but when you have VM's running and IDE's in mid-debug... come on.

    I know this is by (BAD) design to apply certain updates, but at least give us the option to postpone until next boot! Forcing a time on your users feels like abuse - Oh sorry, we control your desktop, so we decide what happens to it, and when.

    P.S. I DO leave the PC on over night, as I DO need to run my nightly backups. I also DO want automatic updates, but just ask us to reboot. 

    Im not the first one to ask about this.

     

    1. 1
      Back up your registry.
    2. 2
      Open regedit by typing "regedit" into the Start > Run dialog.
    3. 3
      Navigate to HKEY_LOCAL_MACHINE\ Software\ Policies\ Microsoft\ Windows\ WindowsUpdate\AU.
    4. 4
      Create or change the DWord value NoAutoRebootWithLoggedOnUsers to 1.
    5. 5
      Exit and reboot.

    Wednesday, March 9, 2011 6:30 AM

Answers

  • Hi,

    Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Windows Update

    Right click on “No auto-restart for scheduled Automatic Updates installations” and select Properties

    Change the radio button to select “Enabled” and hit Ok

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, March 14, 2011 6:59 AM
    Moderator