Project opens in read only mode RRS feed

  • Question

  • Hi All,

    We are facing issue in MS Project 2013 that the projects often opens in read only mode. The users have to clear the cache to fix this issue. We increased the cache size limit but didn't work. The users are properly checking in the changes back to the server.This issue comes often if a user is opening the project in MSP after a break (after weekends,vacations etc.)

    Please update whether this is due to a patch issue.

    Existing Patch details

    Patch Release Date : July 5, 2016

    Patch Version: 15.0.4841.1000

    Please help in this.


    Tuesday, August 1, 2017 10:01 AM

All replies

  • Hi Rose_003,

    Projects will not check themselves out on the server by themselves, so one of the following 3 scenarios must be in play here... (I'm assuming that checked-out projects is the issue here...)

    1. The project is being opened by the user in MS Project and it is not being closed and checked-in properly.  I ALWAYS use the File | Close option in MS Project as it ALWAYS asked me to check-in the project.  I know you say this is happening anyway.

    2. The project is being opened by a user in PWA and it is not being checked in there.  Always use the close button from the ribbon - closing the browser does not check-in the project.

    3.  An automated process is causing the project to be opened and then it is failing to close it, such as a 3rd party app to publish the project.  

    Finally, two pointers for you;  increasing the cache size will not solve your problem, only checking in the project will do that; you can see who the project is checked out to by using the Force-In Enterprise Objects feature within PWA settings.

    Ben Howard [MVP] | web | blog | book

    Tuesday, August 1, 2017 11:41 AM
  • I agree with Ben's answer.  It sounds like you have a custom application, 3rd party application or PowerShell script that is running periodically and failing which then leaves the project checked out.  

    Look at your queue and see if you can find out when the check in and check out history for a project having the issue.  Somewhere in the history, you may see where it was previously checked out. Then look into the SharePoint Monitoring History and see if there is a job running at that time.

    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Blog contains my field notes and SQL queries

    Thursday, August 17, 2017 10:04 AM
  • For what it's worth, we experience the same issue in our PMO.

    I've sat with people to see they're checking projects in correctly, and they are. 

    Sometimes only myself with admin permissions can resolve it by re-publishing the project.

    I would say it doesn't fit with any of the three possible reasons given.  This has happened ever since we had a patch update.

    Monday, August 21, 2017 10:18 AM
  • Hi,

    Is the project actually checked out, or does the client application just think so....

    Ben Howard [MVP] | web | blog | book

    Monday, August 21, 2017 2:43 PM
  • I am having the same problem. The status of the project is checked in. All other administrators can check the project out and edit it. I can't. I checked it out in the browser for edit this morning and cannot check it out and edit in MS Project anymore.
    Monday, June 24, 2019 3:31 PM
  • So where is the status saying Checked-in?  In PWA settings, PWA itself on the Project Detail Pages, or in MS Project in the File | Open dialogue box?  

    Given you have read the thread and tried the options above, then open MS Project, click on File | Open and browse to all projects on the server.  Then open the file from there, or clear your active cache, and then open the file; do all of this from MS Project, not from the browser.

    Ben Howard [MVP] | web | blog | book | downloads | P2O

    Monday, June 24, 2019 3:44 PM
  • Same situation here - after a few weeks of use, projects can only be opened as read only.

    Does not happen to all projects.

    Projects in question are showing as checked in within PWA - tried 'force-close' option but not showing in list.

    Tried opening project from PWA, choosing 'open in Microsoft Project for editing'

    Tried opening from MS Project app as described by Ben above, same result.

    Seems to be a discrepancy in checked-out status between PWA and desktop app. Any reasons why this may be?

    • Edited by Pete__Mc Thursday, February 13, 2020 12:18 PM
    Thursday, February 13, 2020 12:17 PM