none
Error while restoring the BRM of Windows machine RRS feed

  • Question

  • I am getting below error while accessing the network share for the restore.I have given the absolute path up to the parent folder of WinowsImageBackup. There was no prompt for Administrator password because I am booting from ISO on completely new machine.

    Please suggest.

    Tuesday, March 10, 2020 12:35 PM

All replies

  • Hi,

    If the backup is located on a network share, you need to make sure that your new virtual machine can access the server that has stored the Bare Metal Recovery (BMR) backup, otherwise it won't work.

    If you have a DHCP, you can simply add a network adapter to the new virtual machine so that it receives an IP configuration, then you should be able to access the network share.

    If you don't have a DHCP, or if you're not able to get an IP configuration for your new server, you'll have to install a fresh Windows Server, then boot into WinPE and attempt to perform a BMR.

    Note: When creating a new virtual machine, make the hardware (disks, CPU, memory) identical to the server that "crashed" (the one you're about to restore).

    Also make sure there's no firewall blocking the connection.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, March 10, 2020 12:49 PM
  • I have tried below and its able to access the share. However, if I try GUI method then it gives the previous error.Any idea why ?

    wpeutil initializenetwork

    wbadmin get versions –backuptarget:\\server\share


    Tuesday, March 10, 2020 1:00 PM
  • Might have something to do with the new virtual machine (without any OS). As a test, what if you try the same procedure (the GUI method) from a server that has Windows installed?

    You don’t need to restore, just test if you can access the backup.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, March 10, 2020 1:12 PM
  • I'll try that and update you. However, I have tried command line method and it has successfully restored my machine. However, I again have one doubt may be too curious to find out how it works :p

    My backup size is coming around 549MB(See below), then how come it is able to restore whole C:drive with 34GB of usage.

    

    Tuesday, March 10, 2020 1:24 PM
  • Looks good, the GUI is not always the best method, wbadmin - the command method (which the GUI is built on top of) is just as good, if not better...

    The partition that is currently being restored is the System Reserved partition, this one is around 500mb, it contains two important things:

    • The Boot Manager and Boot Configuration Data: When your computer starts, the Windows Boot Manager reads the boot data from the Boot Configuration Data (BCD) Store. Your computer starts the boot loader off of the System Reserved partition, which in turn starts Windows from your system drive. 

    • The startup files used for BitLocker Drive Encryption: If you ever decide to encrypt your hard drive with BitLocker drive encryption, the System Reserved partition contains the necessary files for starting your computer. Your computer boots the unencrypted System Reserved partition, and then decrypts the main encrypted drive and starts the encrypted Windows system.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, March 10, 2020 1:35 PM
  • I have tried restoring using machine that already has OS, but it again fails with same error. Not sure why the GUI is failing.
    Tuesday, March 10, 2020 1:50 PM
  • Have you formatted and created partitions for your new virtual machine? You can do this by booting with the Windows Server image, follow the steps until you get to the "Which type of installation do you want?" step, select Custom: Install Windows only (advanced), then create new partitions and format them.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, March 10, 2020 1:53 PM
  • I had one test machine which already has disks formatted and partitions created.
    Tuesday, March 10, 2020 2:01 PM
  • Please provide all the steps you've taken in detail, to get a better understanding what's been done in the GUI method.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, March 10, 2020 2:10 PM