locked
Unable to associate file types RRS feed

  • Question

  • Windows 7 won't let me associate a file type with an application stored in another hard drive, not the C drive. When I right click open with... and choose the preferred app the dialog box will let me select it, but when I click OK it then doesn't appear the new list. And the old file association remains.

    This is surely a bug. If the association change hasn't worked then I'd expect windows to alert me to that fact. I'd also like to disassociate this file type from opening any other apps, but surprise surprise windows 7 won't let me choose 'none' as an option.

    Woefully user unfriendly
    Saturday, March 6, 2010 1:45 PM

Answers

All replies

  • Hi,

    you can delete manually file associations in registry or remove with this program:
    http://www.winhelponline.com/articles/231/1/An-Utility-to-Unassociate-File-Types-in-Windows-7-and-Vista.html
    • Marked as answer by Nicholas Li Monday, March 15, 2010 5:29 AM
    • Unmarked as answer by Nicholas Li Monday, March 15, 2010 5:30 AM
    • Proposed as answer by mini Thursday, August 14, 2014 12:07 PM
    Saturday, March 6, 2010 4:24 PM
  • Thanks. But why won't Windows 7 let me choose an application on a different SATA drive (not usb) to open that file type? The drive is always plugged in, but I need the flexibility for future backups and image restores.

    If it's not possible it should throw an error, not just quietly ignore my choice after the select .exe dialog!
    Sunday, March 7, 2010 10:43 AM
  • Hi,

     

    To set an association, please refer to the following document:

     

    Change which programs Windows uses by default

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    • Marked as answer by Nicholas Li Monday, March 15, 2010 5:29 AM
    Thursday, March 11, 2010 12:19 PM
  • I also have this issue, that my choice of programs to open a file is simply discarded and ignored.

    The linked document is of no help, since *most* applications are not listed under "Set Default Programs", and many filetypes are not listed in the "Associate Filetype with a program" list -- AND, there is no provision to ADD a filetype to the list.

     

    Blocked at every turn.

     

    This is not answered, please unmark it.

    Monday, April 4, 2011 11:39 PM
  • Hi,

     

    To set an association, please refer to the following document:

     

    Change which programs Windows uses by default

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    That was a retarded answer which did not address the original concern. Posted twice. Houston?
    Saturday, December 10, 2011 2:56 PM
  • This is old but still seems to be some issues.  One likely fix for this is that there is a registry issue that isn't allowing the program to be "seen". 

    in run bar type regedit then

    HKEY_CLASSES_ROOT -> APPLICATIONS -> "your application" -> shell -> open -> command.  The key there will have your default location to open the program. 

    I have had issues with this where there are mulltiple versions of same program either x64 and x32 or concurrent versions where one hasn't been uninstalled.  Change this to whatever loacation you desire. 

    • Proposed as answer by GCrouch Friday, May 25, 2012 5:29 AM
    Thursday, December 29, 2011 7:26 AM
  • Not true. In most instances, there will be no key at all. You must use regedit to create the entire structure by hand, because windows failed to do so during the application's installation. Take a program whose file type associations do work properly, and study the structure in this hive in regedit. You will have to make all of those keys and values yourself to get the associations to work. This is a pretty glaring failure, and it's a little amazing that it has still not been fixed. I hesitate to recommend wholesale registry modification this way, but it's necessary to solve the problem.
    Thursday, December 29, 2011 4:34 PM
  • *I think I fixed the exact same problem by accidentally stumbling upon a very small and discreet drop down arrow on the right side of the option screen. I searched many tech bulletins and finally went back after reading many and happened to notice it.

    I've seen many recommendations to change/modify the system registry. PLEASE - before you attempt to do this try searching for it yourself and let me know if this helps you. 

    • Proposed as answer by twebster321 Friday, February 10, 2012 2:33 AM
    Friday, February 10, 2012 2:33 AM
  • Still no answer to this bug? I'm having the same problem. I want Nikon .NEF files to open with Nikon View NX2. I can browse to the ViewNX2.exe file and select it. Nothing changes. File type remains associated with Capture NX2. I can select Windows Live Photo Gallery instead, but that's not what I want.

    What gives???

    Any help out there Microsoft?

    And please don't post the canned answer again! It does NOT work!

    OK Edit...   I found in another thread to try this little utility to get around the Microsoft bug which has been a problem since 2008 (or longer).

     Go here: http://windowsxp.mvps.org/openwithadd.htm and download the little program. Worked great for me on Win 7 64bit.

    • Proposed as answer by Xrxfixr Thursday, March 29, 2012 12:08 AM
    • Edited by Xrxfixr Thursday, March 29, 2012 12:11 AM
    Wednesday, March 28, 2012 11:47 PM
  • Which "Options" screen? Can you be more specific?

    Thanks

    Wednesday, March 28, 2012 11:50 PM
  • This fixed my issue perfectly. I had been unable to set default file associations for .PSD, .AI or .INDD files after installing Adobe Master Collection CS6 over top of Adobe Master Collection CS4. Thanks Archaeous!
    Friday, May 25, 2012 5:31 AM
  • 2 for 2 open with add fixed my problem as well. I can now open .nef files with viewnx2
    Sunday, July 1, 2012 5:53 PM
  • The above registry change fixed my problem. It was still pointing to the older version that was there before the upgrade. I guess isn't smart enough to make the change when you upgrade programs.


    • Edited by OreTech Friday, August 17, 2012 11:44 PM
    Friday, August 17, 2012 11:44 PM
  • OK Edit...   I found in another thread to try this little utility to get around the Microsoft bug which has been a problem since 2008 (or longer).

     Go here: http://windowsxp.mvps.org/openwithadd.htm and download the little program. Worked great for me on Win 7 64bit.

    This is the solution.

    Worked great on Win 7 64 bits.

    20-June-2013

    Thursday, June 20, 2013 9:32 PM
  • Go here: http://windowsxp.mvps.org/openwithadd.htm and download the little program. Worked great for me on Win 7 64bit.

    Worked great for me too, thanks for posting!
    Sunday, January 12, 2014 12:45 PM
  • I was having this problem with Excel and I used Archaeous' tip to navigate in the registry to the Excel entry.  What I found was that the entry was pointing to Excel 2003 (which I had uninstalled). I changed the entry to point to  Excel 2007 that I had installed and it then showed up in the list when I used the "Associate a file type or protocol with a specific program" dialog.
    • Edited by Zeddicus_ZZ Wednesday, January 29, 2014 8:08 PM
    Wednesday, January 29, 2014 8:03 PM
  • This is old but still seems to be some issues.  One likely fix for this is that there is a registry issue that isn't allowing the program to be "seen". 

    in run bar type regedit then

    HKEY_CLASSES_ROOT -> APPLICATIONS -> "your application" -> shell -> open -> command.  The key there will have your default location to open the program. 

    I have had issues with this where there are mulltiple versions of same program either x64 and x32 or concurrent versions where one hasn't been uninstalled.  Change this to whatever loacation you desire. 

    I found that it is necessary to include quotes around both the command and the argument.

    For example, if your application is "MyApp.exe" and it is located at "C:\Path To MyApp\MyApp.exe", you would need to edit the key: 

    HKEY_CLASSES_ROOT\Applications\MyApp.exe\shell\open\command and change the Default Value (of type REG_SZ) to say 

    "C:\Path To MyApp\MyApp.exe" "%1"

    This is crucial if the path to the application has any spaces in it. 

    I am using Windows 7 x64 and this solved my problem.

    Friday, February 21, 2014 7:06 PM
  • Fantastic little programme, Thanks Ramesh for creating this - Win 7 
    Saturday, February 22, 2014 5:45 AM
  • Thank you! I couldnt associate my zbrush files! Adobe tried taking them over, but this program let me reset it back to how it should be!
    Friday, March 28, 2014 1:42 AM
  • Hi,

     

    To set an association, please refer to the following document:

     

    Change which programs Windows uses by default

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT

    What kind of bullshit it this? No, that document is not the answer. No effin' way that's the answer. It doesn't work. OP told you so in his question: he did exactly what that document says, and it. does. not. work.

    • Proposed as answer by Kylie Dare Tuesday, June 5, 2018 11:59 PM
    Thursday, April 24, 2014 12:13 PM
  • This is old but still seems to be some issues.  One likely fix for this is that there is a registry issue that isn't allowing the program to be "seen". 

    in run bar type regedit then

    HKEY_CLASSES_ROOT -> APPLICATIONS -> "your application" -> shell -> open -> command.  The key there will have your default location to open the program. 

    I have had issues with this where there are mulltiple versions of same program either x64 and x32 or concurrent versions where one hasn't been uninstalled.  Change this to whatever loacation you desire. 

    This is a very useful answer, and solved the problem for me. Reason was a wrong pointer to the location of the program file in the registry after a (buggy) uninstall and reinstall in a different location.

    Note that when you have different users on the same machine and the problem differs for different users, there might be something else wrong in your registry.  Best thing to do then (like I did) is to start cleaning your registry. I can recommend the free tool by AML (AML free registry cleaner). Tried CCleaner, but the free version can't deal very well with multiple users. AML does.

    So:

    If you find that one user account can and another can't do the association :

    1) download and install AML free registry cleaner

    2) run a complete scan. Make sure you tick the boxes for All Users and for association files in the options.

    3) Try to do the association

    If not working : 4) apply the regedit solution given above.

    Solved everything for me.

    • Edited by 8Ball Boris Thursday, April 24, 2014 1:18 PM Extra important info.
    Thursday, April 24, 2014 12:21 PM
  • This is old but still seems to be some issues.  One likely fix for this is that there is a registry issue that isn't allowing the program to be "seen". 

    in run bar type regedit then

    HKEY_CLASSES_ROOT -> APPLICATIONS -> "your application" -> shell -> open -> command.  The key there will have your default location to open the program. 

    I have had issues with this where there are mulltiple versions of same program either x64 and x32 or concurrent versions where one hasn't been uninstalled.  Change this to whatever loacation you desire. 


    Man thanks a lot! This fixed it for me.
    Friday, June 13, 2014 6:15 PM
  • While bugfinder says this is not true, it was true in my situation.  I deleted the keys from old versions of the same program, and only then was I able to associate the extension with the newest version of the program.  I am using Win7, 64 bit. 

    Thanks, GCrouch, for the insight.

    Friday, September 26, 2014 3:58 PM
  • I also have this issue, that my choice of programs to open a file is simply discarded and ignored.

    The linked document is of no help, since *most* applications are not listed under "Set Default Programs", and many filetypes are not listed in the "Associate Filetype with a program" list -- AND, there is no provision to ADD a filetype to the list.

     

    Blocked at every turn.

     

    This is not answered, please unmark it.

    I had the same problem just now.  I would select the program to open it with and then win7 would ignore it.  Fixed the problem by running ccleaner registry scan and it found old invalid references to that file type.  After cleaning those out (run registry scan a few times till it comes up clean for that file type, ccleaner doesn't always find all issues on first/second passes) it works fine now, windoze took the new association no problem.

    Thursday, January 8, 2015 7:44 PM
  • I had the same problem just now.  I would select the program to open it with and then win7 would ignore it.  Fixed the problem by running ccleaner registry scan and it found old invalid references to that file type.  After cleaning those out (run registry scan a few times till it comes up clean for that file type, ccleaner doesn't always find all issues on first/second passes) it works fine now, windoze took the new association no problem.

    was skeptical of this answer but downloaded the free version of ccleaner registry scan and it worked first time  I ran it. Perfect eric2084. Many thanks.
    Monday, January 19, 2015 9:10 PM
  • Windows 7 won't let me associate a file type with an application stored in another hard drive, not the C drive. When I right click open with... and choose the preferred app the dialog box will let me select it, but when I click OK it then doesn't appear the new list. And the old file association remains.

    This is surely a bug. If the association change hasn't worked then I'd expect windows to alert me to that fact. I'd also like to disassociate this file type from opening any other apps, but surprise surprise windows 7 won't let me choose 'none' as an option.

    Woefully user unfriendly

    I almost went crazy trying to resolve this issue!  My issue started with IE always asking me to let it be the default browser.  I discovered that the .html file types were not assigned to a program and none of the usual step would allow me to assign it.  I finally stumbled on the solution and feel obliged to enter it on this forum in order to save someone else's sanity.

    Here are the steps I used:

    1. Click the "Start" button, type "regedit" and press "Enter" while holding the "Ctrl" and "Shift" keys.
    2. Click "Continue" in the confirmation window, or type the administrator password, if requested.
    3. Navigate to "HKEY_CURRENT_USER\Software\Classes" in the Registry Editor. Right-click the extension under "Classes," select "Delete" and click "Yes" in the confirmation window.
    4. Navigate to "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt." Right-click the extension under the "FileExt" folder in the left-hand pane, and select "Delete." Click "Yes" in the confirmation window.
    5. Test that the association has been removed by double-clicking it from Windows Explorer. If it opens an associated program, then continue the procedure. If it asks you to choose a program, then the association has been removed.
    6. Hold the "Ctrl" key and press "F" to search the Registry. Enter ".EXT", replacing "EXT" with the actual extension, and press "Enter." Right-click any folder from the right-hand pane that is named after that extension, and delete it. This step may be unnecessary, but some programs place additional entries in randomly named folders.
    7. Use the "Default Programs" dialog to set the association as normal.

    After further investigation, I found that the original problem was caused by a badly coded program uninstall procedure file.


    Saturday, August 8, 2015 10:38 PM
  •  Thanks, Not sure what changed because I've used a program for years and all of a sudden I started having this problem. I know a lot about file associations and regedit, but after weeks of trying stuff or ignoring this problem I looked for help here and the above fixed the problem in a minute or two.
    Tuesday, February 16, 2016 1:47 PM
  • Bonjour. 

    Démarrer -> Exécuter 
    , taper regedit.exe 

    Déployer la branche 
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.nif 

    Si il existe une sous-clé nommée UserChoice , la supprimer tout simplement .

    La solution consiste bien à utiliser la commande Regedit.exe, déployer la branche HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.extension et supprimer la sous-clé nommée UserChoice 
    Pour supprimer définitivement l'association, il faut aussi supprimer le dossier .extension dans HKEY_CLASSES_ROOT 

    Tuesday, February 16, 2016 2:19 PM
  • Thanks -- worked for me too!

    Thursday, November 3, 2016 8:16 PM
  • Thanks, this pointed me in the direction of a solution.

    My problems came from multiple versions of Adobe InDesign installed. I used the Creative Cloud program from Adobe to remove the oldest version. (They don't use the Windows add/remove method. They have their own.) After it was uninstalled, the file types for .indd and .idml that go with InDesign disappeared, even though there were versions from 2014 and 2017 still installed.

    Open with dialog box didn't list the installed applications. I could Browse... and choose the new version, but it wouldn't stick. In Default Programs, file types, the extenstions weren't listed.

    So I went to the registry like you show and found that the listing for Indesign had a path still to the old, empty directory of the old and uninstalled version. I edited this to the current path for the installed version and saved.

    That allowed things to start working again. I was able to use the Explorer Open with dialog to re-associate the two extensions. 

    Wednesday, January 24, 2018 4:07 PM