locked
Exchange Migration - Routing Group Connector RRS feed

  • Question

  • Hi Everyone,

    I've just installed Microsoft Exchange Server 2010 onto another server in the domain, everything has gone pretty smoothly and I have moved a test mailbox across to the server.

    The issue I'm experiencing is that the test account is unable to send/receive email, from either internal or external users.

    To resolve this I have run:

    Get-RoutingGroupConnector | Remove-RoutingGroupConnector

    I have attempted to run the following command:

    New-RoutingGroupConnector -Name “Exch2003-Exch2010″ -SourceTransportServers “2010Exchange.domain.local” -TargetTransportServers “2003Exchange.domain.local” -Cost 100 -Bidirectional $true

    However all I get is:

    >>

    Any help would be greatly appreciated

    Cheers,

    Anthony

    Tuesday, June 17, 2014 1:02 AM

Answers

  • Turns out I was looking in the wrong place.

    For anyone else who may have the issue, I was able to resolve this by expanding:

    First administrative group -> Servers -> 2K3 Server -> Protocols -> SMTP.

    Right Click Default SMTP Virtual Server - > Properties

    Click onto the Delivery Tab -> Advanced.

    Removed anything in the smart host field.

    OK out of the advanced delivery, OK out of the Virtual Server properties.

    Right click the Default SMTP Virtual Server, Press "Stop". Repeat, except press "Start"

    This has resolved my Mail Flow issues.

    Thanks to all who assisted with this.

    Cheers,

    Anthony

    • Marked as answer by AnthWillison Tuesday, June 17, 2014 7:00 AM
    Tuesday, June 17, 2014 6:58 AM

All replies

  • Anytime you see ">>" then you probably missing something in the command line.  Instead of this...

    New-RoutingGroupConnector -Name Exch2003-Exch2010 -SourceTransportServers 2010Exchange.domain.local -TargetTransportServers 2003Exchange.domain.local -Cost 100 -Bidirectional $true

    Try this:

    New-RoutingGroupConnector "E2K3-E2K10" -SourceTransportServers 2010Exchange  -TargetTransportServers 2003Exchange  -Bidirectional $true

    I shortened a few things..


    Jim McBee - MVP, MCT, MCSE Using Exchange since the v4.0 beta in 1995 - Blog http://mostlyexchange.blogspot.com

    Tuesday, June 17, 2014 1:09 AM
  • Replace all the smart quote characters with straight quotes.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, June 17, 2014 1:10 AM
  • Anytime you see ">>" then you probably missing something in the command line.  Instead of this...

    New-RoutingGroupConnector -Name “Exch2003-Exch2010″ -SourceTransportServers “2010Exchange.domain.local” -TargetTransportServers “2003Exchange.domain.local” -Cost 100 -Bidirectional $true

    Try this:

    New-RoutingGroupConnector "E2K3-E2K10" -SourceTransportServers 2010Exchange  -TargetTransportServers 2003Exchange  -Bidirectional $true

    I shortened a few things..


    Jim McBee - MVP, MCT, MCSE Using Exchange since the v4.0 beta in 1995 - Blog http://mostlyexchange.blogspot.com

    Awesome, thanks for your help.

    Now outgoing email from the test account is working, however when I reply from either internal or external addresses the email does not seem to be getting through to the mailbox.

    Any idea's on this?

    Tuesday, June 17, 2014 1:23 AM
  • Have you looked at the SMTP queues?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, June 17, 2014 1:28 AM
  • Have you looked at the SMTP queues?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    The E2K3-E2K10 Routing Group Connector Queue reports 1 message queued (the message which I've attempted to reply).

    Status is listed as queued, delivery failures reports 0.

    EDIT: Status now listed as Retry and Delivery Failures is at two.

    EDIT: Edit: Under Tools -> Monitoring -> Status the new Exchange Server 2010 is listed as Unreachable. (Which it isn't, due to being online and fully accessible.)
    Tuesday, June 17, 2014 1:37 AM
  • I've done some research and found that the issue is usually caused by having a smart host set in the Exchange Server 2003, however I've tried setting the send-connectors to DNS lookup instead which has not resolved the issue.

    Current issue:
    2003 to Internet - OK
    2003 to 2003 - OK

    2010 to Internet - OK
    2010 to 2010 - OK
    2010 to 2003 - OK

    2003 to 2010 - FAIL

    Any advise would be great!

    Cheers,
    Anthony

    Tuesday, June 17, 2014 6:48 AM
  • Turns out I was looking in the wrong place.

    For anyone else who may have the issue, I was able to resolve this by expanding:

    First administrative group -> Servers -> 2K3 Server -> Protocols -> SMTP.

    Right Click Default SMTP Virtual Server - > Properties

    Click onto the Delivery Tab -> Advanced.

    Removed anything in the smart host field.

    OK out of the advanced delivery, OK out of the Virtual Server properties.

    Right click the Default SMTP Virtual Server, Press "Stop". Repeat, except press "Start"

    This has resolved my Mail Flow issues.

    Thanks to all who assisted with this.

    Cheers,

    Anthony

    • Marked as answer by AnthWillison Tuesday, June 17, 2014 7:00 AM
    Tuesday, June 17, 2014 6:58 AM