none
Communicator could not retrieve calendar or Out of Office information

    Question

  • We are connecting externally and receiving the following error with OCS2007 RTM and OC2007 RTM.

     

    ---------------------------
    Microsoft Office Communicator 2007
    ---------------------------
    Communicator could not retrieve calendar or Out of Office information from Exchange Web Services. Communicator will automatically continue to retry. If this problem persists, contact your system administrator.
    ---------------------------
    OK  
    ---------------------------

    Outlook autodiscover is configured correctly. The following succeeds:

    • Control-Right-Click Outlook icon | "Test Email Autoconfiguration"

    If I set an out-of-office message in Outlook, this is reflected in Communicator. But the error still appears.

     

    Any ideas?

     

     

    • Moved by Kathy Slough 2Moderator Wednesday, December 16, 2009 10:45 PM forum migration (From:OC Setup & Deployment)
    Tuesday, August 21, 2007 7:53 AM

All replies

  •  

    Hi all,

     

    One of my colleagues has the same problem.

     

    Anyone already a solution?

     

    Regards,

    Dieter

    Monday, August 27, 2007 9:42 AM
  •  

    I have the same problem!

     

     

     

    help with a decision!!!
    Wednesday, August 29, 2007 4:35 PM
  •  

    I was having this error using Communicator internally.

     

    I solved the problem by going to the Outlook Account setup and chossing the "alway use this profile" option. Apparently Communicator 2007 doesn't launch the "Choose profile window" from Outlook as Communicator 2005 used to do.

     

    Jorge

    Wednesday, September 19, 2007 4:18 PM
  • Some of the same fixes for this with the beta version work on the RTM version, see the FAQs. What Jorge suggested should work. You can also exit out of Communicator. Open Outlook first, and then wait a minute or so and then open Communicator.

    Just a thought.

    Wednesday, September 19, 2007 4:52 PM
  •  

    It does not work if Exchange server 2007 and Office Communicator 2007 on set one server.

     

    Thursday, September 20, 2007 8:53 AM
  • I have had Communicator on an Exchange server and it worked fine. Check the cert being used on the Exchange box is not the self-signed certificate.

     

    Tuesday, December 18, 2007 6:57 PM
  • I have to replace the self-signed certificate in Exchange 2007 with one from our internal CA.

     

    Thursday, December 20, 2007 3:39 PM
  • I had the same problem but mine was related to a corrupt mailbox on our Exchange 2007 server.  Information through my efforts:

    • When I uninstalled Office 2007 and reinstalled Office 2003 I did not have an issue connecting to the Exchange Web Services to get presence.
    • The problem followed me regardless of the workstation I logged onto.
    • I did have the problem when I moved back to Communication Server 2005.
    • While on MOC 2007 and Exchange 2007, when I was logged onto Communicator from multiple workstations (i.e. connection to Exchange Web Services) somehow the multiple connection  would allow for both instances of my MOC 2007 logon to recieve updated presence.  As soon as I logged off the one I would lose the connection.
    I initially thought it was a cert issue but since it was isolated to me that negated such thinking.  I also only had (1) profile.

    Hopefully this will serve to assist in any troubleshooting for isolated user issues such as this.
    Thursday, December 20, 2007 8:37 PM
  • I had the "Outlook Integration Error" for awhile, but it went away after deleting a second email profile. Now, I just cant seem to get MOC to detect that I'm in a meeting. Since the exclamation mark indicator is no longer visible (the one for my previous Outlook Integration Error), is there somewhere else I should look for possible explanations?

     

    Thursday, January 03, 2008 10:32 PM
  •  

    One of the most common problems is when you have a different SIP URI from your SMTP address. Check that both your email address and the SIP URI used in Communicator match in order to have Outlook integration.

     

    Jorge

    Friday, January 04, 2008 7:32 AM
  • This will be the case with some of my users. Is there a workaround for it, like adding the SIP URI as an email alias, or is it a requirement that the SIP URI match the primary SMTP address?

     

    Thanks!

    Friday, January 04, 2008 1:42 PM
  •  

    Yes, they must match but you can add several SIP domains (domain.local, domain.com, domain.co.uk, newdomain.com, etc) in OCS 2007 so your users can have a matching SIP URI and email address.

    Friday, January 04, 2008 3:46 PM
  • How do you configure a different SIP URI, I can't seem to find that option.
    Monday, January 05, 2009 3:13 PM
  • Users can only have a single, primary SIP URI.  Take a look at these articles for some details on the attributes:
     

    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=29
    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=20


    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    • Proposed as answer by Brian Voller Monday, February 02, 2009 12:46 AM
    Monday, January 05, 2009 9:54 PM
    Moderator
  • Did anyone come up thit an answer as to why it will not get information from ExchangeWeb Services?
    I am running communicator 2007 r2, (on a server) Exhange 2007 SP1, with Mailbox, and Client an hub roles (on another) and one server running Ex2007 with just the UM role.
    All are in the same doamin and forest.
    The error from the Office Communicator is:

    ---------------------------
    Microsoft Office Communicator 2007
    ---------------------------
    Communicator could not retrieve calendar or Out of Office information from Exchange Web Services. Communicator will automatically continue to retry. If this problem persists, contact your system administrator.
    ---------------------------
    OK  
    ---------------------------

    Friday, June 19, 2009 2:23 PM
  • Hi friends,

    I'm the same issue, but all is correctly configured.
    Finally, the question are the SP2 for NET Framework: http://support.microsoft.com/default.aspx/kb/958934

    Regards, Javier
    Monday, November 30, 2009 9:04 AM
  • Just as another possibility -

    We recently moved over to Exchange 2010 sp1 and started seeing this issue with our test group of users that have been migrated and are running Communicator.  In our instance, we set the set the Windows Authentication provider under the EWS vdir in IIS to NTLM only, removing negotiate.  Once that was set on all CAS' in the array, the error is gone and we have free/busy information again for these clients!

     

     

    Wednesday, September 08, 2010 2:52 PM
  • This problem also me too. All my friends  have same issue, i think this should be server side integration error....please help me solve this issue.
    Tuesday, September 28, 2010 4:29 AM
  • I am having the same issue... Please help.
    Saturday, October 02, 2010 5:13 PM
  • We too are having this problem, however it was quite easy to isolate..and resolve.

     We have CAS's servers in two separate AD sites, the primary site has OCS2007R2 servers, the secondary site does not have any. For Exchange, the primary site proxies requests (OWA/EWS etc) to the secondary site. The primary site has CA issued certs, and the secondary does not. We issued CA certs to the secondary site and ensured that the AUTH methods for the CAS's were consistent (for the proxying to work effectively), that fixed the problem for us. Ultimately, having secondary OCS R2 servers in the secondary site, would be the best for us.

    Check that the certs in OCS and the Exchange CAS(s) are valid and have the right Subject and Domain Names(SAN)

    Check that the AUTH methods are set correctly, this is very important for CAS's across different AD sites, depending on your choice of proxying or redirection.

    Thursday, October 28, 2010 10:56 PM
  • I was also having this problem after switching to a new PC, I checked the Exchange certficates etc but nothing looked wrong.

    The only difference between my old and new PCs was that the new one had IE8 instead of IE7, I then found a post elsewhere suggesting that Microsoft has changed the behaviour on the Enable Integrated Windows Authentication advanced setting in IE8 so that if the setting is checked it will only attempt the use Kerberos authentication but if it is unchecked it will fall back to NTLM, so I tried unchecking it and problem solved- I no longer had the warning in Communicator once it was restarted.

     

     

    Thursday, December 02, 2010 11:58 AM
  • Hi Tony,

    Have you seen this:

    http://support.microsoft.com/kb/2028885

    That should contain the following:

    2172695   Communicator could not retrieve calendar or Out of Office information from Exchange Web Services" error message when you use Office Communicator 2007 with your mailbox in Exchange Server 2010

     

    I just have no idea where MS has published this article. Perhaps there is coming new update, as that hotfix did not fixed our problem. But at the same time I can see the following event on the CAS server:

    Log Name:      Application
    Source:        MSExchange Availability
    Event ID:      4018
    Task Category: Availability Service
    Level:         Error
    Computer:      casserver.domain.com
    Description:
    Process 6248[w3wp.exe:/LM/W3SVC/1/ROOT/EWS-1-129325180216838444]: An exception occurred while attempting to locate a Client Access server to handle a request for e-mail address <User A>SMTP:user.a@company.com. The returned exception is Microsoft.Exchange.Data.Storage.ServerNotFoundException: The server excVirtual.domain.com was not found in the topology.

     

    (edit: I have all servers in the same AD site..)

    Monday, December 13, 2010 11:47 PM
  • Hi,

     

    I have faced the same issue couple of times and so far fixed it by following any of the steps:

    * Ensure that the SIP address and the SMTP address is same. ( Note: outlook default profile should be configured with the sip address)

    * Ensure that the communicator latest hotfix is applied. Most of the issues will get fixed by applying it.

    * Ensure that Out of office and Auto-discover works fine.  You can test auto email configuration by right clicking on the outllook icon on the system tray--> check only auto discover option by filling your email address and password --> Test will show the results.

    * Ensure that the options related to outlook and communicator were enabled at both the ends ( communicator options and outlook options) 

     

    Hope the above info helps... 

    Tuesday, October 04, 2011 12:21 PM