locked
DSC : CCMX + Excel + Acrobat doesn't work ! RRS feed

  • Question

  • Hi everybody, i'm coming back again here because of a few DSC's question ...

    I've successfully sequenced CCMX( V7.40 ), everythings work fine, and i've made some dependencies in the OSD files to link CCMX with Acrobat and Excel ... unsuccessfully !
    For Excel, CCMX Query say that the DDE link with Excel has failed, and for Acrobat the preview is unavailable. For both, CCMX acts like if there was not Excel and Acrobat ...
    What i've done : in a VM (XP SP3 ) i've installed Acrobat and Excel, then sequenced CCMX, launched it through the sequencer ( everything works ), saved it, added the dependencies in the OSD file and finally  published it ! On the client i lauch CCMX but when the application need Excel or Acrobat it doesn't work.

    Does anybody have an idea, or maybe could explain me how an application calls another one, with the DDE or OLE links ? Or something else ? I don't know so much about these process, so it would be glad if someone could take some light in my cloudy brain ....

    Thanks for your answers

    /Christophe
    Christophe ROUET
    Wednesday, September 2, 2009 2:22 PM

All replies

  • First thing which comes to mind is, did you permission Excel or Acrobat for that user/group?
    Wednesday, September 2, 2009 4:15 PM
  • Hi, thanks for that, and yes the user has good rights to launch the dependencies. Besides the user can lauch individually in the same session Acrobat reader and Excel without a problem.
    I've looked for some information about CCMX, i know now the application call Excel with a DDE link ... but i don't know how it works exactly to reproduce it in app-V ... don't hesitate if you have an idea !
    Another example : i've got an application which call Crystal reports without a problem ( with DSC ) but it can't call Word, i konw it's a OLE link for this application. Pfff 10 days on that i'm gonna die at work ... :-)

    /Christophe

    Christophe ROUET
    Wednesday, September 2, 2009 6:54 PM
  • Christophe,

    You may be right. I am experiencing same type of issue with Project 2007 which calls Excel to open Visual Reports. It could not find Excel even if its installed locally...so just imagine when it's running  sequenced.

    Anyway, we first need to ensure your application is looking Excel correctly. To test, create a test OSD of CCMX and try to launch the Excel. If you cannot launch it, then try to add the sequenced Excel path in the PATH environment variable in CCMX OSD.

    Thanks
    Wednesday, September 2, 2009 8:15 PM
  • Hey, thanks for the advices ! "Glad" to hear i'm not alone ...

    I' ve tried what u said , but nothing to do, i've got the same message : " The DDE link with Excel failed " ...
    I've tried too to put the MANDATORY on TRUE for excel to load before launching CCMX, but it doesn't work much more ...

    I've worked on the DDE link, here is a definition, hoping you understand french language  :

    D.D.E est un protocole.
    Avec ce protocole, des données provenant d'une application peuvent être insérées dans un document d'une autre application. Elles restent liées à l'application d'origine. Tant qu'elles restent sur le même support, on pourra les mettre à jour à partir de ce dernier.
    Mais, à la différence de O.L.E, on ne pourra pas lancer l'application d'origine en cliquant dans l'objet.

    When i read this i think it's not possible to reproduce it with DSC because you can't open the application calling the object ( more or less the translation at the end of the french definition ). This means the first application try to copy / paste data in the second one ( here Excel ), keeping controling data through the second application. I've read too that DDE link is no more compatible with Vista and 7...

    What is your feeling about that ... shall i give up ...

    Have a nice day !

    /Christophe


    Christophe ROUET
    Thursday, September 3, 2009 1:34 PM
  • Hello,

    Just some questions;

    How does this behave when installed locally?
    If you suite them together into a single-package, does it behave as when installed natively?
    If you open a command-prompt within the package using DSC, can you then locate the executables referenced?

    /Znack
    Thursday, September 3, 2009 5:03 PM