locked
RSAT on Windows 7 with SP1 RRS feed

  • Question

  • I have installed RSAT for Windows 7 with SP1 (KB958830), and the install went without any errors or warnings.

    Like others in here I do, however, have some issues with Hyper-V tools.

     

    I ran a sfc /scannow, no errors found

    Im running (danish) Windows 7 x86 with SP1 installed.The computer is not part of any domains and run with workgroup settings.

    When I try to add Hyper-V role, I get an "An error has occurred. Not all of the features were successfully changed"

    My issues is similiar to http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/663884cd-15e7-4417-a1f4-c1f99e273783.

    I have added several other tools from the pack:

     

    Active Directory Users and Computers
    DHCP
    DNS
    Remote Desktop Serice
    ADSI Edit
    GPO management

    Just to mention some of it.

    Just Hyper-v casts the mentioned error.

    Hope anyone can pinpoint me in some direction to solve this

     

    Monday, February 6, 2012 8:48 AM

Answers

  • Okay, this is solved. I will provide the solution as I do hope some others might benefit from it.

    I use McAfee endpoint protection and have enabled Access Protection Policy to block changes to Browser helper object and shell extensions.

    The EPO system places loads of windows system files on the exclude list, but TrustedInstaller.exe was not one of them.

    TrustedInstaller adds a regkey in the Shell extension which is blocked due to policy.

    So, if you're using McAfee endpoint protection, EPO server 4.6 and enable Access Protection Policy to block Browser helper objects and Shell extensions, make sure TrustedInstaller.exe is in the exlude list, otherwise you will not be able to install Hyper-v tools from RSAT.

    This will apply to any security tool that will block shell extensions as well.

    I hope this will help others as I spent hours of internet searching, yet none had this as solution.

     


    /Morgra
    • Marked as answer by Morgra Monday, February 6, 2012 9:56 AM
    Monday, February 6, 2012 9:56 AM