locked
Acrobat DC RRS feed

  • Question

  • Hello All,

    Has anyone figured out how to publish Acrobat DC using the App-V client without having to have a user run the PowerShell command? This is not feasible for us.

    Any help would be greatly appreciated.

    Thanks!

    Thursday, June 7, 2018 3:38 PM

All replies

  • there are only 3 ways to publish the package:

    SCCM 

    AppV server

    AppV Client Powershel.

    I don't think there is a way to deploy a package with Client alone without powershell.

    Monday, June 11, 2018 3:23 AM
  • I don't think I made myself clear. We publish our packages via a publishing server using a client with PowerShell. I need to publish the Acrobat DC package in this same manor. We cannot have users running PowerShell as you need Admin privs. to run the command needed in PowerShell.
    Thursday, June 14, 2018 1:29 PM
  • have you tried to publish the package to the entire machine rather than to a security group, in that way, all user on that machine should be entitled, regardless it is a local user or AD user.
    Thursday, June 14, 2018 3:53 PM
  • It's Adobe. I have been trying to find a way to publish this package via publishing server > App-V client. I can publish it to my own workspace using the following:

    Add-AppvClientPackage [Path_to_AppV_Package] -DynamicDeploymentConfiguration
    [Path_to_DeploymentConfig_xml_File] | Publish-AppvClientPackage –Global |
    Mount-AppvClientPackage

    The problem being is, this is not feasible as admin privileges are needed.

    I am working on creating a dummy package with a script added in that runs the commands above but I am having an issue getting the deploymentconfig edited to work.

    Wednesday, June 20, 2018 3:27 PM
  • Do you mean you are trying to target users but have it publish globally? 

    Not saying its pretty, but we did this for our users.  We made a dummy package that installed the actual Adobe app-v package using the add-package event and published it globally.  Here are the steps I did in the dummy package:

    1. Read the PackageSourceRoot key, and use that as a path for the actual Acrobat DC .appv path (optional but it was easier this way for us)
    2. Ran powershell.exe -command set-executionpolicy unrestricted -force.  For some reason the script run by Acrobat (for licensing, etc) required this.  We did go to Adobe to confirm.
    3. Ran the Add-AppvClientPackage and Publish-AppvClientPackage -global commands (referencing the packagesourceroot location)
    4. At this point the Adobe Scripts run (for licensing) as they are in your actual Adobe .appv package, under machine publish.
    5. As per Adobe, AFTER that runs you are to run the MSI for the printer.  So I ran the msiexec.exe /I acrobatdc-config.msi /qb.
    6. Reverted the executionpolicy to restricted

    User IDs only had to be added to the dummy package.

    The order was VERY specific for us otherwise the MSI given by Adobe wouldn't work correctly.  We did it a while ago so its possible things have changed since then.

    Tuesday, July 10, 2018 8:30 PM
  • My apologies for the very late reply. This would have worked but I could never get the script to run in the dummy package. I believe this is due to GPO in our environment blocking it even though everything says we are able to do it. Also, due to activation and licensing options in AAMEE 3.x not functioning correctly without having to prepare a volume license serialization file with the provisioning tool, we decided to go with an app that is supported with App-V unlike Adobe products.
    Tuesday, May 21, 2019 12:45 PM