locked
Roaming Laptop App-V Users RRS feed

  • Question

  • We have a number of laptops that have a home Site but travel as well. What is the Best Practices for laptops?

    When users that Travel to another Site away from their home site, what are the best App-V settings, I.e. ISR, ASR, OSD SR?

    Our main issue is that when a user us at their home site, all the apps open great, faily quicky. Then when they travel to the other site the applications open slowly like a good minute or so to open.

    Any Thoughts?

    Thank You!


    Duramaxster

    Thursday, May 3, 2012 10:28 PM

Answers

  • Hello,

    This depends on what type of infrastructure you have.

    For example - using SCCM / standalone mode could not cause this behavior

    Using a Management Server (depending on how its built) could potentially cause this problem.

    A good start would be to investigate what happens in the background to determine what is impacting your specific environment (which you shared nothing about).


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, May 4, 2012 7:36 AM
  • ISR, OSR and ASR are used during publishing refresh and streaming only - on laptops ensure you pre-cache all applications (i.e. to 100%) before going offline. There should be no need to do anything different with those locations for laptops.

    What is logged in the App-V client log when the client is offline? What options have you set for disconnected mode?



    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Friday, May 4, 2012 8:35 AM
    Moderator
  • I would suggest the following configuration when you are roamimg.

    Enable Work Offline mode. Make sure all the apps are 100% in cache (You have to do that because in offline mode the client will not try to conatact to server).

    Set the registry value "RequireAuthorisationIfCached" to 0. You will be able to use the applications with greater responses.

    NOTE: If you only enable Disconnected Operation mode (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Client\Network\AllowDisconnectedOperation==1), then the client will try to connect to server periodically. And if you are using Streaming servers like HTTP/RTSP, then obviously you will enjoy slowness due to slow network speed. You might also get dialog boxes that will ask to close the app in 2 minutes.

    • Proposed as answer by znack Sunday, November 18, 2012 2:45 PM
    • Marked as answer by Aaron.ParkerModerator Sunday, November 18, 2012 6:02 PM
    Wednesday, May 16, 2012 10:35 PM

All replies

  • Hello,

    This depends on what type of infrastructure you have.

    For example - using SCCM / standalone mode could not cause this behavior

    Using a Management Server (depending on how its built) could potentially cause this problem.

    A good start would be to investigate what happens in the background to determine what is impacting your specific environment (which you shared nothing about).


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, May 4, 2012 7:36 AM
  • ISR, OSR and ASR are used during publishing refresh and streaming only - on laptops ensure you pre-cache all applications (i.e. to 100%) before going offline. There should be no need to do anything different with those locations for laptops.

    What is logged in the App-V client log when the client is offline? What options have you set for disconnected mode?



    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Friday, May 4, 2012 8:35 AM
    Moderator
  • Okay Great, so if I am hearing you correctly. the Roots above should point to their home Streaming Server. All applications load while connected to their home site. They go offline and all the applications should work as designed?

    Disconnected Operations: Allow Enabled  
    Disconnected Operations: Limit Disconnected Operations Disabled 



    This is the sftlog.txt file from a laptop this morning. This looks good, right? 

    [05/04/2012 07:24:26:313 AMGR INF] {tid=4AC}

    Entering Disconnected Operation
    URL: rtsp://mydomain.local/Off2010.V05/Microsoft Office 2010_8.sft
    Error: 0000008A-00000001

    [05/04/2012 07:24:26:343 AMGR INF] {hap=1D:app=Microsoft Outlook 2010 14.0.4763.1000:tid=4AC}
    The Application Virtualization Client lost contact with a server and entered disconnected mode.

    [05/04/2012 08:24:28:680 AMGR INF] {tid=4AC}
    Entering Disconnected Operation
    URL: rtsp://mydomain.local/FFOX36.V02/Mozilla Firefox 3.6.sft
    Error: 0000008A-00000001

    [05/04/2012 08:24:28:740 AMGR INF] {hap=21:app=Mozilla Firefox 1.9.2.3909:tid=4AC}
    The Application Virtualization Client lost contact with a server and entered disconnected mode.

    [05/04/2012 08:34:31:082 AMGR INF] {tid=4AC}
    Entering Disconnected Operation
    URL: rtsp://mydomain.local/Off2010.V05/Microsoft Office 2010_8.sft
    Error: 0000008A-00000001

    [05/04/2012 08:34:31:132 AMGR INF] {hap=1D:app=Microsoft Outlook 2010 14.0.4763.1000:tid=4AC}
    The Application Virtualization Client lost contact with a server and entered disconnected mode.


    Duramaxster



    Friday, May 4, 2012 4:21 PM
  • I would suggest the following configuration when you are roamimg.

    Enable Work Offline mode. Make sure all the apps are 100% in cache (You have to do that because in offline mode the client will not try to conatact to server).

    Set the registry value "RequireAuthorisationIfCached" to 0. You will be able to use the applications with greater responses.

    NOTE: If you only enable Disconnected Operation mode (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Client\Network\AllowDisconnectedOperation==1), then the client will try to connect to server periodically. And if you are using Streaming servers like HTTP/RTSP, then obviously you will enjoy slowness due to slow network speed. You might also get dialog boxes that will ask to close the app in 2 minutes.

    • Proposed as answer by znack Sunday, November 18, 2012 2:45 PM
    • Marked as answer by Aaron.ParkerModerator Sunday, November 18, 2012 6:02 PM
    Wednesday, May 16, 2012 10:35 PM