none
Class Not Registered RRS feed

  • Question

  • I previously had Win 7 and upgraded to 10 when it was available.  After the last Win 10 update, I started getting the message 'Class not Registered' when I tried to open Win  Edge.  The start key does not work.  When I click on Edge (tied to my task bar)  I get Class not Registered  and in the top of that box is Explorer.exe.  If I shut down my laptop,  turning it back on, after I log in, most times I get the black screen.  Occasionally I will get to the desktop and since I had the presence of mind years ago to download Mozilla I am able to get on the internet, when I finally get to the desktop.  That means I cannot shut down my laptop or I will have to go thru the gyrations of getting back my desktop (takes multiple tries).  I have read most of the help for Class not Register and most required that you use the windows key.  My windows key does not work.  Start does not work.  Shift Restart works to 35% and then errors.  Taskmaster functions do nothing.   Tried Safe Mode options and no help.  System check in Safe Start indicated errors but no repair options.  Win + any letter does not work.  So, please understand, if you have a solution, make sure it does not require the use of the Win key and/or Start key.  They do not work! 

    Monday, October 24, 2016 12:15 PM

All replies