none
DPM2012 SP1 RU3 not recognizing cleaning tape RRS feed

  • Question

  • I have a Dell TL2000 tape library with two LTO5 drives and a LTO5 cleaning tape labelled as CLNUxxxx in slot 24. At the advice of Dell I have disabled auto-cleaning in the library and am trying to schedule cleaning on the DPM side.

    DPM does not see the slot the cleaning tape is in after an inventory, regardless of whether this is slot 24 or whether we move it to another slot. The tape and slot simply don't appear in the Libraries view. I have assumed this is a sign that DPM is recognizing it as a cleaning tape, but when I run Start-DPMTapeDriveCleaning with the drive as a parameter, I get the following error:

    "Start-DPMTapeDriveCleaning : Cleaning tapes are not available in IBM TotalStorage 3573 Tape Library, to clean the selected drives. Please add cleaning tapes and restart the cleaning job. (ID: 31114)"

    Any ideas what I can do (other than re-enable auto clean on the library and break some of my backup jobs?

    I have upgraded my library and drive firmware and drivers to the versions recommended by Dell, but this has made no difference. I'm hesitant to upgrade DPM to a later rollup unless the changelog clearly addresses this issue, because the last rollup I applied destroyed my production system and caused weeks of disruption.

    Wednesday, August 13, 2014 5:44 AM

Answers

  • Hi,

    This library requires a registry key to function properly with DPM.


    Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent DWORD: RSMCompatMode
    Value: 13 (Decimal)


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, August 13, 2014 10:15 PM
    Moderator

All replies

  • Hi,

    This library requires a registry key to function properly with DPM.


    Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent DWORD: RSMCompatMode
    Value: 13 (Decimal)


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, August 13, 2014 10:15 PM
    Moderator
  • Wow, easy as that. Thanks - I hunted all over for that with no success!
    Wednesday, August 13, 2014 10:52 PM
  • Hi,

    ihave the same problem with DELLPowerVault 124T

    i created the register key but i have already the same error.

    Any idea???


    KETATA Ramy (N'oubliez pas de Marquer et Voter la ou les réponses qui aident à résoudre votre problème)

    Tuesday, October 21, 2014 1:48 PM
  • worked perfectly on my 2012 DPM, thanks!

    looks like for older DPM (2010) the value changes from 13 to 8 for those that are looking.

    thanks


    Brian D


    • Edited by bdavid01 Monday, September 14, 2015 4:10 PM
    Monday, September 14, 2015 4:09 PM
  • I have the same problem with DPM 2016 on Windows Server 2016. This registry key unfortunately did not help me. :(
    Thursday, June 8, 2017 8:54 AM