locked
Servers where patches will not install automatically or manually, Live updates are broken and when checking installed updates shows "NO UPDATES ARE INSTALLED ON THIS COMPUTER" SFC \SCANNOW will not run RRS feed

  • Question

  • Hello, (Bit of a long one but please read)

    We have 3 servers in same physical location and server OU etc that are exhibiting the exact same behaviors (we have server servers in this location that are not), as above theyt are all W2008 R2 SP1 and all built from the same standard image we use on hundreds of other computers, they have also been in production for different amounts of time and we started to see this behavior at different times with them: (Its odd they are all in the same site where there are also several other servers that are not effected, there must be a link ? )

    These servers are all missing several patches when checking our internal tool that reports from IBM endpoint management that we use to deliver patches (they are not all missing the exact same patches some ore or less than other), although SCCM (we used SCCM to deliver patches until around 6 months ago) and IBM EM are both running (some ptches hark back to the SCCM Delievry days) they are not patching and when attempting to patch manually by downloading the exact patch coresponding to the fixlet ID and the KB , the stanbdalone installer starts and after some time you receive an error message “The update is not applicable to yoru computer”. Windows update returns error 80070006 for all of the servers.

    it is worth noting that other applications and products also using the .MSU extension will insatll so it is not a problem with the installer service.

    The above led me to think a corrupt patch may have stopped the sequence of patching so I then looked in “Programs and Features” => “Installed updates” and this is blank for all of them returening the message:

    “NO UPDATES ARE INSTALLED ON THIS COMPUTER”.  (this I believe is a part of the fundamental issues and resolving this may resolve the patching)

    Another issue is that if you run  “SFC /SCANNOW” It starts the scan and then returns: “Windows Resource Protection could not perform the requested operation” (Also in safe mode and both from an elevated CMD and WMI is started as a service)

    The all three are probably related so I think fixing the “SFC and NO UPDATES SHOWN” issues will resolve the first.

    The things I have tried so far are:

    Running : wmic qfe list full /format:htable > c:\updates.htm             Should produce a list of updates but instead returns :  No Instance(s) Available (this is not hopeful)

    Fix: Ran the “SYSTEM UPDATE REDINESS TOOL” from  http://support.microsoft.com/kb/947821

    Result : Update Ran successfully but NO CHANGE

    Fix: Ran the automated and manual fix “RESET WINDOWS UPDATE COMPONENTS” here : http://support.microsoft.com/kb/971058/en then undated windows update agent.

    Result : All ran successfully and NO CHANGE

    Fix: Ran MBSA

    Result : Runs successfully and then stays at “Done downloading security update information” (Log gives no obvious information)

    Fix: Renamed the software distribution folder/restarted services (Various variations of this fix online, tried a few)

    Result: Runs as described in article with new Software distribution folder being created, NO CHANGE

    Fix: Create/Correct the  reg key for windows trusted installer located here HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version (several articles relating to this and the above issues)

    Result: the existing key was correct as should be from internal system information gathered , required in article.

    Fix: Ran the “Windows update trouble-shooter” as here : http://windows.microsoft.com/en-us/windows/troubleshoot-problems-installing-updates#1TC=windows-7

    Result:  It detected and fixed error’s but still no change.

    The WMI Repository checks out on them all for both of the methods I know to verify “Get-wmiobject –list |measure” and ensure count is over 900 and also “C:\>winmgmt /verifyrepository” and the repository came back as “WMI Repository is consistent”. I guess this is not hard evidence the WMI is OK, but these are the only methods I know.

    I have also tried removing the server from its OU , running a GP Update and then rebooting and testing but to no avail (Bit of a longshot but tried to link the distinction between the three servers and the OU GP is one of them)

    I have tried a few other articles registering .Dll’s etc , but I did not take a note of links as I was at the start of this and didn’t expect it to go so long so please reply with anything you see not above im happy to try again.

    I have thought about removing SP1 and reinstalling it but this will require a major downtime and only possible if the backup files of SP1 have not been removed.

    Any help is apreciated !

    Thursday, September 18, 2014 8:02 AM

Answers

All replies

  • Hi,

    Please try to rebuil the WMI repository.

    For detailed information, please refer to the blog below,

    http://blogs.technet.com/b/askperf/archive/2009/04/13/wmi-rebuilding-the-wmi-repository.aspx

    If issue persists, due to sfc doesn't work, could you try to repair your system with the installation disk?

    Best Regards.



    Steven Lee

    TechNet Community Support

    • Proposed as answer by Steven_Lee0510 Monday, September 29, 2014 12:07 PM
    • Marked as answer by Steven_Lee0510 Tuesday, October 7, 2014 2:17 AM
    Monday, September 22, 2014 5:19 AM
  • Hi,

    We've not heard from you yet. I assume the information provided by me has helped. I am marking my reply as answered now.

    In case the information did not help, please feel free to unmark the answer and come back to us with your comments.

    Best Regards.



    Steven Lee

    TechNet Community Support

    Tuesday, October 7, 2014 2:16 AM