Error: Project professional needs to be installed to open the project RRS feed

  • Question

  • Hi Team,

    When trying to edit files in office365 project

    In PWA -> Open the Plan -> When clicking on edit > it returns error that professional version has to be installed.

    Able to edit the plan before.

    Please help me on this



    Wednesday, March 1, 2017 1:02 PM

All replies

  • Hi,

    I see the same after applying updates. With version 1701 (Build 7766.2060) starting Project client from browser is not working. So I currently can't edit Enterprise calendars and resources in client.

    There is no issue with starting Project client and open project plan by File - Open.

    What version are you running? (File - Account)


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    Thursday, March 2, 2017 6:09 AM
  • I am seeing similar results with Project Server 2016 on premise (Server Update level Nov 2017), and Project Professional 2016.   The Project center quick launch for Project Professional works fine for the base Project Professional maintenance level, but as soon as I put on any maintenance on Project Professional, the quick launch breaks.  I have tried as far back as Jan 2016 maintenance for Project Pro and it still breaks.

    I have tried to repair on both Project Professional and on Office 2016 - no change.  I have cleared out the Project Cache, and the cache files in the Users\usr\AppData\Roaming\Microsoft\MS Project\16\Cache\ folder.  I have tried to clear browser history - no luck.  I have tried other browsers - no luck.  Running out of things to try.

    I am able to open all of these projects if I open Project Professional first and navigate to the project, but since we have over 3000 projects, the list is quite long. (just not convenient)

    All of our project managers are running Project Professional 2013, so they are not impacted by this, but in order to update the Enterprise Calendar I had to update to 2016.

    Thursday, March 15, 2018 2:46 PM
  • I found a temporary solution to my problem until MS fixes their code.  The issue is with the file Program Files\Microsoft Office\Office16\NAMEEXT.DLL  This is  found in IE under manage Add ons, (Run without permissions) - "Microsoft Office Project Task Launce Control".  There is both a 64 bit and a 32 bit.  It appears the 64 bit has a date of 2010 and the 32 bit a date of 11/2016 - I am running 64 bit (seems quite old).

    I installed the Project Professional product without any updates.  I made a copy of this file which was dated 7/31/15.  The quick launch was working.  Then I installed maintenance (Jan 2016).  The file above was updated to 1/13/16.  I tested Opening the Project Professional from PWA and it was now broken.  I renamed the new NAMEEXT and then copied in my saved copy back to that location, and it worked once again.

    Next I applied the Feb 2018 maintenance.  The file was updated to 1/17/2018.  Still broken.  Copied back the good saved version from July 2015, and it works again.

    • Proposed as answer by LabelleB Friday, March 23, 2018 8:21 PM
    Thursday, March 15, 2018 6:08 PM